Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hwinfo32 and msi afterburner
03-01-2011, 03:22 PM
Post: #1
Hwinfo32 and msi afterburner
Hi
Installed hwinfo32 v3.70-1153 today, when i run it msi afterburner crach?
No problem with previous verisions of hwinfo32.
Find all posts by this user
Quote this message in a reply
03-01-2011, 03:25 PM
Post: #2
Re: Hwinfo32 and msi afterburner
What did crash, application or the system?
Please attach the HWiNFO32 Debug File after the crash, so I can analyse it.

zook666 Wrote:Hi
Installed hwinfo32 v3.70-1153 today, when i run it msi afterburner crach?
No problem with previous verisions of hwinfo32.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-01-2011, 03:48 PM
Post: #3
Re: Hwinfo32 and msi afterburner
Hwinfo32 made msi afterburner crash.
Find all posts by this user
Quote this message in a reply
03-01-2011, 04:00 PM
Post: #4
Re: Hwinfo32 and msi afterburner
I suppose this is an issue of MSI Afterburner, since it doesn't use proper synchronization objects that are currently used by most monitoring applications.
HWiNFO32 with several other applications have recently moved to using Global namespace for these mutexes (to synchronize access to hardware when running concurrently), but some applications are still behind.
You can check this page for a list of applications: <!-- m --><a class="postlink" href="http://www.techpowerup.com/wiki/doku.php/systool/mutexes_to_avoid_collisions">http://www.techpowerup.com/wiki/doku.ph ... collisions</a><!-- m -->
According to information there, MSI Afterburner should use Global objects from version 2.1.0 beta 5, so I would suggest to get that version or a later and try it.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-01-2011, 06:32 PM
Post: #5
Re: Hwinfo32 and msi afterburner
HWiNFO32_3.68.1130 works with afterburner but not later versions?
Find all posts by this user
Quote this message in a reply
03-01-2011, 07:35 PM
Post: #6
Re: Hwinfo32 and msi afterburner
Because HWiNFO32 switched to Global namespace as other tools did as well.
Use the mentioned version of Afterburner or later and let me know if it works.
zook666 Wrote:HWiNFO32_3.68.1130 works with afterburner but not later versions?
Visit this user's website Find all posts by this user
Quote this message in a reply
03-01-2011, 07:44 PM
Post: #7
Re: Hwinfo32 and msi afterburner
tryd afterburner 2.1.0 beta 5 and 7, it just work with hwinfo 3.68 when i try it with 3.70 afterburner crash.
Find all posts by this user
Quote this message in a reply
03-01-2011, 08:31 PM
Post: #8
Re: Hwinfo32 and msi afterburner
Hm.. then who's the bad guy - HWiNFO32 or Afterburner? Since HWiNFO32 wins this fight Big Grin, I'd say the Afterburner needs a fix.
zook666 Wrote:tryd afterburner 2.1.0 beta 5 and 7, it just work with hwinfo 3.68 when i try it with 3.70 afterburner crash.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-01-2011, 08:51 PM
Post: #9
Re: Hwinfo32 and msi afterburner
its when i open sensors in hwinfo then afterburner crash, and its just 3.70. hmm something in 3.7 makes it crash xD
Find all posts by this user
Quote this message in a reply
03-01-2011, 08:55 PM
Post: #10
Re: Hwinfo32 and msi afterburner
But since it's Afterburner which crashes and HWiNFO32 survives, it's impossible for me to find why the other crashes. That needs to be fixed, but on other side.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)