Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.1.0 plugin not loading.
#1
Hi Nick, thanks for a great plugin.

I have a problem with v1.1.0 not working - v1.0.1 works fine.

This is on Windows 7 x64 or x86 with HWiNFO.xx v4.30 and Rainmeter 3.0.2 r2161.

The problem is that after importing the skin into Rainmeter , the skin loads ok but no hardware readings are available.

Bringing up Rainmeter's Log shows lots of Errors relating to Plugin: "HWiNFO.dll" not found.

If I revert back to version 1.0.1 of the skin everything works as expected.

Any suggestions ?

Thanks.
Reply
#2
Hi,

4.3 and 3.0.2 are working fine for me here on Win 8.1 x64. So it seems the issue should definitely be the "HWiNFO.dll" not found error you mention.

When you install the skin, the plugin gets copied from skin installer to "C:\Users\<username>\AppData\Roaming\Rainmeter\Plugins". So I'd recommend going to that folder and seeing if HWiNFO.dll is there. If it is, right click it, select properties, details tab, and ensure it is version 1.1.0.0.

If it isn't there or is the wrong version, you can copy it manually from the folder "C:\Users\<username>\Documents\Rainmeter\Skins\HWiNFO\@Resources\RedistrutablePlugin". But you need to ensure you are copying the correct dll (32 or 64 bit) to match the version of Rainmeter you are using. This is shown in the Rainmeter about dialog on the version tab (or check the task manager). Once you have the correct file and version, you should see that the errors go away, the plugin is listed in the Rainmeter dialog plugins tab, and the skin works.

Let me know how you make out.
Reply
#3
Hi, thanks for the suggestions.

The skin installs correctly , hwinfo.dll is in the right place and is the right version.

On further investigation I have found the problem - the Visual C++ 2010 SP1 Redistributable Package needs to be installed.

I found this out by installing an old version of Rainmeter ( 3.0 final ) which I think was the last version to download the C++ runtimes automatically, and the skin worked as expected ( no plugin errors in the Rainmeter log ).
So I clean installed again with Rainmeter 3.0.2 , the skin stopped working and Rainmeter complained about not finding the hwinfo.dll again. I then installed the C++ 2010 runtimes and the problem is fixed. Smile

Does the hwinfo.dll have a dependency on C++ 2010 ?

Cheers.
Reply
#4
Glad you figured it out. Yes, it does rely on the VC++ runtimes. This plugin was developed when it was included with Rainmeter (ver 2). I did not realize Rainmeter made a change and no longer includes it. I'll take a closer look later. At least the solution is simple.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)