Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AMD R9 390X2 crossfire black screen issue
#1
Hi.
I bought a 2 Sapphire R9 390X Tri-x OC Graphics card yesterday
but when i enable crossfire with running hwinfo, my screen blackout and i cant control my PC.
It doesn't happen when i close hwinfo.
is there any way to fix this problem?
sorry for bad English.
Reply
#2
Please try to disable the AMD ULPS feature if that will fix it.
Reply
#3
I have already disabled ULPS using MSI afterburner
But it still blackout.
Reply
#4
Disabling I2C will fix FPS drop but it doesn't fix blackout
Reply
#5
If you enable Crossfire when HWiNFO is not running and then start it, is it OK ?
Reply
#6
no, it happens when I installed HWINFO.
it is not happening when i uninstalled HWINFO
Reply
#7
So you need to completely uninstall HWiNFO for this to work?
Please try to disable the "Persistent Driver" option in HWiNFO and then try to switch Crossfire when HWiNFO is installed, but not running.
Reply
#8
it works!
thank you Martin. I love HWINFO.
Reply
#9
Thanks for the feedback Smile
Reply
#10
oops, I can't remove HWINFO driver...
Reply
#11
What do you mean that you cannot remove it ?
Reply
#12
Cannot stop HWiNFO64 driver [StopService (0x425)]
Reply
#13
Cannot remove existing HWiNFO64 driver [DeleteService (0x430)]
Reply
#14
When are those messages shown, always when closing HWiNFO ?
Reply
#15
it happens when i click remove in the driver management.
when i click it shows HWiNFO Driver removed successfully
but it shows Installed in Current Status. so iclicked it again then it shows the error
Reply
#16
tried reinstall HWiNFO but it doesnt fixes.
Reply
#17
When i enable crossfire with running HWiNFO, my PC get blackscreen with no signal.
But it doesn't happen when i uninstall HWiNFO.
So I tried to disable Persistent Driver.
it worked first time but blackscreen happend again from second time.
Then I tried to remove HWiNFO driver. It shows removed successfully but Current Status shows Installed so I clicked remove again. Error comes out:
Cannot stop HWiNFO64 driver [StopService (0x425)]
Cannot remove existing HWiNFO64 driver [DeleteService (0x430)]
Reply
#18

.dbg   HWiNFO64.DBG (Size: 868.17 KB / Downloads: 1)
.htm   MAIN-PC-KEN.HTM (Size: 242.85 KB / Downloads: 1)
Reply
#19
That looks like something is blocking the HWiNFO driver.
Try to make sure "Persistent Driver" is disabled and driver not installed.
Then reboot the machine and perform the Crossfire switch only when HWiNFO is not running.
Reply
#20
Yeeeaaaah IT WORKS!
THANK YOU!

here is what i did ↓
Open HWiNFO and close summary and sensor
Go to Program>Settings
Go to Driver Management tab then disable Persistent Driver and remove driver. DON'T CLICK REMOVE AGAIN if you already clicked once.
close HWiNFO then enable crossfire.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)