Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ASUS Prime x299 A 100% CPU Spikes - FIXED
#1
I have a new X299 Build consisting of:
  • ASUS Prime x299 A
  • i7-7800x
  • 64GB DDR4 3000
  • Corsair Hydro Series H110i 
  • ASUS ROG STRIX GTX1070
  • Two 500GB Samsung 960 EVO's in RAID 0
I've setup a informative Rainmeter dashboard and recently added HWINFO64 to it for my temps.

What I've noticed is that I get a 100% CPU spike at the Polling Frequency.  I'm monitoring a very few number of sensors, but the spike happens even if I totally disable ALL of the sensors.  I can manipulate the distance between the spike by modifying the Global Polling Frequency in HWINFO. 

Notes:
  • Spike still happens after closing everything other than HWINFO (including rainmeter)
  • HWiNFO64 v5.57-3240 although it happened on previous, non-beta versions
  • Spike happens even after disabling ALL sensors.
  • Spike stops as soon as I close HWinFO
  • I choose NOT to monitor the H110i and Asus voltage warning (no difference)
Pictures and Stuff:

[Image: tm.JPG]

[Image: ui.JPG]

[Image: smbus.JPG]

[Image: safety.JPG]

[Image: h110i.JPG]

[Image: general.JPG]

[Image: data.JPG]

[Image: rm.JPG]
Reply
#2
Please try to disable the "EC Support" option in HWiNFO and let me know if it makes any difference..
Reply
#3
(09-10-2017, 07:09 PM)Martin Wrote: Please try to disable the "EC Support" option in HWiNFO and let me know if it makes any difference..

First, thanks so much for the reply.

I unchecked ECC Support on the "Safety" tab.  I exited and restarted HWiNfo and my spikes are still there.
Reply
#4
Well, then another attempt - try to set the Drive Scan mode to "Disable Drive Scan".
Reply
#5
(09-10-2017, 07:24 PM)Martin Wrote: Well, then another attempt - try to set the Drive Scan mode to "Disable Drive Scan".

I disabled "Drive Scan" radio button and even unchecked the three check boxes below it - although I would assume they have no effect once disabled.

Exit and restart HWiNFO

Spike is still present.
Reply
#6
The ONLY scanners I have active:
Core #0 Clock
CPU Package Temp
Memory Clock
Memory Clock Ratio
Motherboard Temp
PCH (Chipset) Temp
Intel Raid Total Activity
GPU Temp

That is it.
Reply
#7
Well, then you will need to try to disable all sensors (best their headings one by one) and then check if you find the one causing these spikes.
Please let me know the result.
Reply
#8
All sensors disabled. Exited and restarted.

Spike is still there. What else can I disable in settings to test?

What's weird, is I have all settings disabled, but I can still effect the spike by adjusting the polling time. If all sensors are disabled, what is HWiNFO polling? Might point us in the right direction . . .
Reply
#9
Well, that's really strange because if you disable all sensors HWiNFO should not be polling anything.
Please attach the HWiNFO Debug File when all sensors are disabled and I will check internally if I can see anything there.
Reply
#10
(09-10-2017, 08:38 PM)Martin Wrote: Well, that's really strange because if you disable all sensors HWiNFO should not be polling anything.
Please attach the HWiNFO Debug File when all sensors are disabled and I will check internally if I can see anything there.

Ok, Let's see if this is what you want . . .


Attached Files
.dbg   HWiNFO64.DBG (Size: 684.88 KB / Downloads: 1)
Reply
#11
Thanks, that's what I needed.
Please enable back the "Bus Clock-based" option in HWiNFO. Any change ?
Reply
#12
Enabled it and the spike went away. The Periodic polling option brings the spike back.

So with Bus Clock Based polling check (without Periodic Polling) I re-enabled my temps. All seems well.

Martin, you rock. You have a brilliant application and to provide support on a Sunday?? Wow.

Thank you so very much.
Reply
#13
You're welcome and thanks for your feedback, I'm glad that we found a solution.
If you enable back EC Support and Drive scan while keeping "Periodic polling" off, is it OK then ?
But anyway, I'm still wondering why the "Periodic polling" option causes such spikes. This should not happen..
Reply
#14
(09-10-2017, 09:10 PM)Martin Wrote: You're welcome and thanks for your feedback, I'm glad that we found a solution.
If you enable back EC Support and Drive scan while keeping "Periodic polling" off, is it OK then ?
But anyway, I'm still wondering why the "Periodic polling" option causes such spikes. This should not happen..

I actually deleted the .ini file and restarted so I have a clean config.  

Leaving it as is, simply disabling periodic polling fixes the spike.  ECC Support and Drive Scan are fine.

If there is anything I can do to assist on the polling, let me know.  I'd be happy to help.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)