Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
After upgrading to Win8.1 can't get hwinfo to work

Recently upgraded to Windows 8.1.
All works fine. Except hwinfo64.
Other monitoring software do work(hwmonitor, aida..)

I am kinda stuck here.

When I open hwinfo, while it loads the sensors I get a nice BSOD.
My system seems to te stable, made 10 runs of IBT-avx on very high without a problem.

No crashes or errors whatsoever besides the hwinfo thingy.

I hope to solve this problem because I really do like your program.
Please submit the HWiNFO Debug File from the crash, so I can inspect it and provide guidance.
(09-05-2014, 11:54 AM)Martin Wrote: Please submit the HWiNFO Debug File from the crash, so I can inspect it and provide guidance.

I can't.
When the sensors load the whole system crashes. Windows says to make a dump but also stays at 0% so I have to hard-reset the system.

Any indeas what to try?
Already re-installed hwinfo.
I mean the HWiNFO Debug File, not Windows crash dump.
Check here about how to do that:
I can't do that...
The problem is the program crashes on startup. So I cannot even get into the settings.

System locks with either normal start, summary only or sensors only.
Are you able to disable autostart of HWiNFO to launch it manually, so you would be able to capture the BSOD in the Debug File ?

You might also check this about common issues known (it includes also suggestions for Windows 8):
I managed to enable debugging by editing the .ini file.
Somehow when I then tried to open the program, sensors-only, it worked but took pretty long to load all sensors(30+ sec.)
So I closed it and tried it again. That gave me a brief BSOD followed by a black screen. Had to shut down by holding the power-button(reset didn't work).

I uploaded the debug file here:
Thanks. According to the data, there seems to be an issue reading additional GPU sensors.
There are the following options to fix this:
- You can disable the entire "GPU I2C Support", that should fix it. But HWiNFO will not be able to detect additional GPU sensors if there are any.
- You might try to enable the "GPU I2C via ADL" option to see if that helps.
- You might just try to disable the bus #6 in the "GPU I2C Exclusion" list but checking the button for number 6.
Can you give me some more info on how to do that when editing through the .ini file.

I see the GPUI2CBusExclude=00000000 entry. Which value do I set? Just 6?

And when I try GPU I2C ADL I just put GPUI2CADL=1? While still having GPUI2C=1 also

Thanks for the info already.
I do hope to fix it. Because the real advantage of hwinfo64 I use IS the gpu monitoring.
To disable entire GPU I2C support use:

For excluding the bus #6, you should use:

For I2C via ADL use:
Excluding bus does #6 fixes it.
Sadly that disabled monitoring the vrm sensors.

Do you have any idea why I have to disable them?
I don't get it... when I was using Windows 7 I had no problem with hwinfo64, plus the sensor readings were loaded 10 times faster(which isn't a big problem, but still).

I don't know if it is related, but I noticed that when I use msi Afterburner to monitor the sensors it doesn't show the vrm's either.
But using gpu-z they do show.

I really would like to use the OSD option in hwinfo64 to display all gpu data in game.

On second note, I did install hwinfo64 on the SSD this time. I doubt that would make a difference?
Well, I'm not sure exactly why it crashes, but it obviously does it while trying to read the GPU VRMs. I think the difference might be because of different AMD Catalyst drivers used.
To speed-up the scan you might disable the other GPU I2C buses.
Instead of disabling bus #6 you might try to use I2C via ADL if that maybe works and will successfully access the VRMs.

Forum Jump:

Users browsing this thread: 1 Guest(s)