Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AutoStart won't work after editing TimeBrokerSvc start type
#1
Hello,
I am using:
- Windows 10, Version 1607, build 14393.82
- HWiNFO64, Version 5.34, build 2930

Some days ago I edited TimeBroker service start type (using regedit), as follows:

was:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBrokerSvc] "Start"=dword:00000003 (Manual)
now is:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBrokerSvc] "Start"=dword:00000004 (Disabled)

[OT]
I did this because Microsoft Download/Upload Host process was using my whole bandwidth in the wrong moments.
After the registry edit, I had no more "bandwidth theft".
[/OT]


However the problem that I am facing now, is that HWiNFO64 does not start when I login.
I have enabled Task history and the scheduled task for HWiNFO seems to not being executed at all when TimeBroker is disabled.
If I manually run the task, HWiNFO64 starts with no issues.

Of course, if I enable TimeBroker again, HWiNFO starts normally when I login.

Are TimeBroker and HWiNFO64's autostart somehow related?
If this behavior is right, I will search for another solution to my original problem.
However it seems weird to me (I have other scheduled task working fine on login).

Many thanks Smile
Reply
#2
HWiNFO is not directly related to that service. But it's started via Windows Task Scheduler (as a scheduled task) and it's possible that Task Scheduler depends on TimeBrokerSvc. If that's true I assume that any other scheduled tasks won't run.
So I guess that disabling the TimeBrokerSvc you disabled all scheduled tasks including HWiNFO and some task that was causing your bandwidth problem. So you have indirectly fixed your problem, but caused other issues with that. I suggest to enable the TimeBrokerSvc and check all tasks in Windows Task Scheduler to find the one that's causing your issues and then disable that task.
Reply
#3
(08-29-2016, 09:06 PM)Martin Wrote: (...) it's possible that Task Scheduler depends on TimeBrokerSvc. If that's true I assume that any other scheduled tasks won't run. (...)

Hello Martin, thanks for your reply Smile
Good guess, that's partially true.

I have solved my problem, at least regarding the HWiNFO part. Here what I've done:
as I wrote in my previous post, I have other scheduled tasks working fine on login.
And, since you have confirmed me that HWiNFO is not directly related to TimeBrokerSvc, I assumed that the problem must be "inside" the scheduled task.
So I did a deeper analysis on the other scheduled tasks (the ones that actually start on login).

After some tests I've found all the tasks that start without delay are working fine.
On the contrary, the ones that have some delay set are not working.

On my PC, HWiNFO's task had a 5 seconds delay. Removing the delay made the task working at login.
I think that Task Scheduler depends in some way on TimeBrokerSv, especially for tasks that need to keep track of time. Confused

(08-29-2016, 09:06 PM)Martin Wrote: (...) So I guess that disabling the TimeBrokerSvc you disabled all scheduled tasks including HWiNFO (...)
Not all of them, but most of, since almost every task uses some delay/repeat.

(08-29-2016, 09:06 PM)Martin Wrote: (...) I suggest to enable the TimeBrokerSvc and check all tasks in Windows Task Scheduler to find the one that's causing your issues and then disable that task.
That will be a long search, since there are a lots of Mircosoft's task.  Dodgy

Thanks for your help,
bye Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)