Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Catching Up With HWiNFO Updates
#1
Hi Martin, I haven't posted in your forum lately although I've been meaning to for a while to comment about some of the updates.

This is all related to my ASRock Z97 Extreme6 board, a Haswell system in which I recently added a Xeon E3-1276 v3 processor. The sensor chip is the Nuvoton NCT6791D.

Vcore reading: You have somehow managed to supply a Vcore reading that is otherwise not available from ASRock's own monitoring program, or in their UEFI/BIOS. ASRock only provides the core's VIDs.

Since Haswell processors have the voltage regulators for the core voltage internal to the processor, and a board only provides the CPU Input voltage and a DDR/memory voltage, the true Vcore is not directly available to monitoring programs as it has been in the past with any other platform. A couple other mother board manufactures seem to have added extra circuitry to provide the actual Vcore voltage to monitoring programs, while ASRock apparently hasn't done this, at least on the majority of their boards.

However, HWiNFO64 provides a Vcore reading for this board that seems accurate. It does not simply mirror a VID value, but apparently shows the ultra low Vcore when the C7 C State is active, as well as the small increase in Vcore above the VID when using Adaptive voltage and running CPU stress tests.

I don't know of any other monitoring program that can do this with my board. Fantastic!!

Processor Cache voltage: You've also added a voltage reading for the Haswell processor cache voltage, which is a separate voltage setting in the UEFI. I've never seen a VID for the cache voltage, but the HWiNFO64 cache voltage reading matches the setting in the UEFI, and the range of voltages when using the C State power saving options, including C7. Wow!!

Processor voltage regulator voltage and power reading: Just updated HWiNFO64 to v4.51-2415, and for the first time I see readings for the processor VRM input and output voltage, current, and power. They are titled Intersil ISL6367/ISL6379. Alas, no temperature reading. Wink Coincidentally, my use of v4.51-2415 happened on the same day I added the Xeon processor, are the two related? OMG, I better update to v4.51-2415 on my other boards and see if I get similar readings. I have VRM voltage and power readings on my ASRock Z87 OC Formula board when using earlier versions of HWiNFO64. Regardless, thanks so much for these readings!!

No other PC hardware monitoring program can do all the things that HWiNFO64 does, it is the best!!

Thanks so much Martin!!
ASRock Z97 Extreme6  Intel Xeon E3-1276 v3  Scythe Mugen 4
16GB Samsung M3V 2000MTs 1.35V
SanDisk Extreme Pro 256GB Windows 8.1 UEFI boot
Samsung 840 Pro 256GB x 2 RAID 0 Windows 10 TP UEFI boot
Samsung 830 256GB x 2 RAID 0
EVGA GTX 760
Dell P2714H
Dell U2312HM
ASUS VS24A
Seasonic X660 XP2 PSU
Fractal Define R4
Reply
#2
Thanks for your feedback. I have been able to gather some information for these boards with the help of a user at overclock.net (LostParticle). He also provided me with detailed test results. So thanks go to him as well Wink

It seems that reading actual Vcore is possible via a Vcore sense pin provided by the CPU, but only few vendors attach sensors to this pin. ASRock tools seem to be providing this value only for some boards and if they do, they display an average value (of 10 values measured). ASRock has confirmed this for certain boards and it seems that this value is available on more models, which you have confirmed too.

CPU Cache voltage - you can verify the current setting in HWiNFO too - in the main window (with a tree on the left side) under CPU / Overclocking.

ISL6379 - I added support of this digital PWM in the latest build only, so it's because of that Wink What I don't like about this chip is that it's not PMBus-compliant and several values act weird. They don't even seem to be working according to their own documentation. So I'd not fully rely on some of those values, especially current and power values.
Reply
#3
That all sounds good Martin, thanks.

More detailed feedback on the VCore and CPU Cache voltages, which to review are with a Xeon E3-1276 v3 processor in an ASRock Z97 Extreme6 board. The Xeon is not a K processor of course, and this board's UEFI removes the Haswell Adaptive voltage option, and only provides Override Voltage and Offset voltage options. That may be normal for a non-K Haswell processor, but I haven't been able to confirm that. All this information is based upon all the CPU and Cache voltage options set to Auto, with SpeedStep and all processor C States enabled.

The HWiNFO main window shows both the CPU core (IA Overclocking) and Cache (LLC/Ring Overclocking) voltage modes as Adaptive. I'm not saying that this is right or wrong, just what the facts are. Cool

I've used a Haswell i5-4670K with this board, and HWiNFO of course, using Adaptive voltage and the same CPU power saving options enabled, so I've seen what the core VID and Vcore readings are with that configuration. I'll compare them with the VID and Vcore readings I see when using the E3-1276 v3.

Both Haswell processors show a maximum and minimum VID value, the minimum VID being ~0.64V - 0.73V. The maximum VID depends upon several variables, and their exact values only important in comparison with the maximum Vcore reading.

The Vcore reading will have values well below the minimum VID, and go to a minimum of 0.0V. The maximum Vcore reading when running CPU stress tests, will be a bit above the maximum VID by several hundredths of a volt, up to ~0.1V. This is exactly what the Vcore readings should be for a Haswell processor using Adaptive voltage mode.

While we don't have a CPU Cache VID to compare with the CPU Cache Voltage reading, I see the same range of voltages, from 0.0V to the maximum Vcore reading. So that looks correct too. Actually, the maximum Cache Voltage is greater than the maximum Vcore voltage on the Xeon, by a significant amount. I don't recall that being the case with the 4670K, it's in another board now and I need to check that with the latest  version of HWiNFO. Not saying the reading is wrong, probably differences in the processors.

I suspect the processor VCore options in this board's UEFI when using a Xeon are not telling me what is really happening. That could be the nature of the Xeon itself, or a bug in the UEFI itself. Can't figure that out yet... Huh  The VIDs and Vcore behave like Adaptive voltage mode is being used, HWiNFO64 shows it as Adaptive, and the Intel Extreme Tuning Utility does not supply an Adaptive option, but shows Adaptive mode in the processor configuration data. Quite a puzzle. Dodgy

The Intersil ISL6367/ISL6379 current and power readings change along with the load on the processor. Compared to the VRM readings on my ASRock Z87 OC Formula board, they are generally higher and no power/current input readings. The ISL6367/ISL6379 voltage in and out readings seem good, but less accurate than the Z87 board, but it provides these readings by design. Nice work getting them displayed at all, glad to see them.

Keep up the great work!
ASRock Z97 Extreme6  Intel Xeon E3-1276 v3  Scythe Mugen 4
16GB Samsung M3V 2000MTs 1.35V
SanDisk Extreme Pro 256GB Windows 8.1 UEFI boot
Samsung 840 Pro 256GB x 2 RAID 0 Windows 10 TP UEFI boot
Samsung 830 256GB x 2 RAID 0
EVGA GTX 760
Dell P2714H
Dell U2312HM
ASUS VS24A
Seasonic X660 XP2 PSU
Fractal Define R4
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)