Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Custom dpi
#1
custom dpi wont work on hwinfomonitor add on.


values are blank


[Image: 47Te.png]
Reply
#2
(06-18-2014, 01:57 PM)DigDeep Wrote: custom dpi wont work on hwinfomonitor add on.

You sure you are not using black text and that HWiNFO is still reporting those same sensors? It was working properly before setting a custom dpi?

By custom dpi you mean you are setting Windows dpi setting to 125% or 150% to make everything larger? It seems like this could cause an issue for some gadgets as the sidebar engine does not scale them properly. There is a setting that may help. This setting is not currently in the gadget. Are you comfortable trying to add it per the instructions? If not, please email me a copy of your "C\Users\username\AppData\Local\HWiNFOMonitor" folder and "C\Users\username\AppData\Local\temp\HWiNFOMonitor.log" file?

But this setting will prevent it from getting larger as well. An alternative to dpi may be to just set your screen resolution to a lower value, ensuring the aspect ratio does not change. Everything will be larger, but running at native resolution with no custom dpi.
Reply
#3
No black text. Yes it still works if I change it back. Yes. It works with 125% 150% dpi, but not with user preset like 105% etc.
Reply
#4
OK, I can reproduce and have a fix.

The sidebar engine by default does NOT scale for custom DPI. There is a parameter that you can add to tell it to scale this gadget. When you do that, the text shows properly now (and the gadget gets larger).

1 - Close the gadget.
2 - Open "C:\Users\<username>\Local\Microsoft\Windows Sidebar\HWiNFOMonitor.gadget\gadget.xml" using a text editor like notepad.
3 - Add "<autoscaleDPI>true</autoscaleDPI>" after line 20. Save and close the file.
4 - Open the gadget

Here are the details on where that line gets added:
Code:
        <host name="sidebar">
            <base type="HTML" apiVersion="1.0.0.0" src="gadget.html" />
            <permissions>Full</permissions>
            <platform minPlatformVersion="1.0"/>
            <defaultImage src="icon.png" />
            <autoscaleDPI>true</autoscaleDPI>
        </host>

Let me know how you make out.
Reply
#5
thank you. It works that way
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)