Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DIMM incomplete info
#1
Exclamation 
Hi!

Using hwdinfo64 v4.10-1820

DIMM info issue. Can't choose dimm modules using drop down menu (menu is empty).
I have four Kingston KVR16R11D4/16 16Gb modules.

[Image: LvqIf.jpg]

Debug, report and dxdiag attached.


Attached Files
.zip   dimm_bug.zip (Size: 302.49 KB / Downloads: 2)
Reply
#2
There seems to be a conflict while HWiNFO tries to access the DIMM modules, so it can't read the information.
Are you maybe using some other system monitoring or management tool in parallel ? If yes, please try to disable it before running HWiNFO if that helps.
Reply
#3
(12-23-2012, 10:48 PM)Martin Wrote: Are you maybe using some other system monitoring or management tool in parallel ? If yes, please try to disable it before running HWiNFO if that helps.

NOP! There wasn't monitoring or management tool in parallel. I even reinstalled OS to double check. Fresh install. THE SAME. DIMM info is missing.

Maybe that important. but before i reinstalled os, i tried to launch hwinfo64 summary multiple times in row and 1x in module drop down list appeared several scrambled chars or symbols.
Reply
#4
Please check in the BIOS if there's maybe an option like DIMM Temperature or TSOD polling. If there's something like that, try to disable it and check if that maybe helps. Please let me know the result.
Reply
#5
Nothing suspicious in BIOS. Here is my bios menu and all sensor info in attachment.

[Image: VPih3.gif]

    _    
Reply
#6
Thanks for the additional information.
I see 2 entries in the Memory Configuration screen: "DRAM RAPL MODE" and "Thermal Throttling". Can you please try to change these and see if it has any effect on this problem in HWiNFO ? I'm not pursuing this as a solution, it's just to prove if my theory is correct.
Reply
#7
Thumbs Up 
Bingo! Problem solved. Changed Thermal Throttling to DISABLED. Previous state was CLTT (Closed Loop Thermal Throttling)

Thanks a lot Martin!

Pity that i need to sacrifice CLTT. Dodgy
Now four Temperature sensor readings from HWiNFO64 is gone (Intel CPU #0 section - Memory Channel 0, 1, 2, 3 Rank Max ~47.0C)

Info taken from xtremesystems forum:
Quote:TS ON DIMM
TS on DIMM is a closed-loop throttling technique that offers a more advanced approach to system thermal management through the use of a physical thermal sensor to further reduce guardband present in the existing methods. The reduction of guardband has a direct and positive impact on system performance.... Instead of using power prediction to estimate the temperature of the DRAM case, TS on DIMM uses a physical thermal sensor integrated on the DIMM module to monitor the temperature of DIMM...The SMBus master is inside the chipset. The sensor acts as a slave sitting on the SMBus with SPD on a module. Physically, the sensor and SPD [4] can be either integrated into one package as shown in Figure 3 or separated as two stand-alone parts on a module. However, the thermal sensor and the SPD are two separate logical functions using two different SMBus addresses. At power up, BIOS read data from the SPD and initiate the thermal sensor by programming its registers via SMBus, including setting the critical threshold value. When the initiation is complete, the thermal sensor will begin monitoring the temperatures and assert the Event# signal when the temperature of the sensor exceeds the critical trip point. Once the thermal sensor is initiated the system can also poll the thermal sensor via the SMBus at any time and monitor the temperatures real-time.

   
Reply
#8
Thanks for the feedback. I just wanted to know whether TSOD polling is the cause of this problem and it indeed is.
Now I need to find a solution how to get SPD info working together with active TSOD polling.
Will post an update here shortly when I have s solution that needs testing...
Reply
#9
Please enable Thermal Throttling back and try this build:
http://www.hwinfo.com/beta/hw64_411_1830.zip
if it works now. If it doesn't, then please attach a new Debug File.
Reply
#10
Enabled CLTT, but dimm info still empty.
Debug added.


Attached Files
.dbg   HWiNFO64.DBG (Size: 754.49 KB / Downloads: 2)
Reply
#11
Thanks for the feedback. It's not easy to get around that issue.
Please try this build: http://www.hwinfo.com/beta/hw64_411_1832.zip
and let me know the results.
Reply
#12
Sure Martin!



the same. No dimm info.


Attached Files
.dbg   HWiNFO64.DBG (Size: 603.02 KB / Downloads: 2)
Reply
#13
Thanks. It seems all my attempts to temporary disable CLTT (which causes TSOD polling that interfers with DIMM SPD readout) fail and are overriden back by system...
Please try this build: http://www.hwinfo.com/beta/hw64_411_1833.zip
and post a new debug file result.
Reply
#14
new debug


Attached Files
.dbg   HWiNFO64.DBG (Size: 668.64 KB / Downloads: 2)
Reply
#15
Thanks for the update.
Here's one more attempt - http://www.hwinfo.com/beta/hw64_411_1834.zip
Note that this build might cause HWiNFO to lockup. If that happens, wait a while, then try to close it via Task Manager.
Please attach a new debug file.
Reply
#16
this build caused lockup.


Attached Files
.zip   dbg.zip (Size: 54.67 KB / Downloads: 1)
Reply
#17
Then I'm sorry, but it seems the system doesn't allow me to switch TSOD polling off. I try that but it seems it's locked into this mode and that doesn't allow to read DIMM information. I'll make some more research, but currently the only workaround for this problem is to disable CLTT in BIOS.
If I find another way, I'll post an update here.
Thanks for all your feedback and testing.
Reply
#18
Update:
I have just tested a different Supermicro machine (X9DR6-F) which has CLTT enabled in BIOS too. HWiNFO had no problems to read SPD there.
The difference I found is that on the other machine HWiNFO was able to temporary disable TSOD polling (until DIMM SPD is read out), whereas on your machine the TSOD polling mode somehow can't be disabled and it causes HWiNFO to fail to read DIMM SPD information.
My understanding is that there might be a BIOS implementation difference (either somehow locking that mode, or constantly forcing it to be enabled).
Maybe a BIOS update might fix this ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)