Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dashboard
#1
Photo 
Hi,

I have previously used Speedfan in my skins which comes with a number of limitations and has required the use of registry values, a custom .exe to determine graphics card and so on, the prospect of removing this complexity as well as being able to monitor additional temperatures and so on makes HWInfo very interesting.

[Image: preview-82-210-280.jpg]

I have published a new Rainmeter suite called Dashboard which uses HWInfo and has gone from a test-bed to fully featured in the last couple of weeks. It is still evolving while I play with layouts and information, but the skeleton and majority of the meat are on its bones so to speak.

I have a couple of observations and queries which in no particular order are:
  • The example skin shows
    Code:
    Plugin=Plugins\HWiNFO.dll
    , you can simply use
    Code:
    Plugin=HWiNFO
    , saves a few keystrokes Cool
  • At PC startup HWInfo needs me to click OK on a UAC box. I can live with that but it doesn't always pop up and then I have to manually launch HWInfo (Win8 64-bit Angry )
  • Sensors are checked but don't seem to start, which means double clicking the tray icon clicking the sensors button, minimising all 3 screens that pop up and refreshing skins that show Device names due to
    Code:
    UpdateDivider=...

Anyhow, these queries aside, it's great piece of software and the plugin does the job and allows access to all sorts of system information in a customisable way via Rainmeter and no doubt it will go from strength to strength.

Well done Angel
Reply
#2
Thanks for your work, it looks very nice.
Yes, there's currently a limitation when you want HWiNFO to start automatically with UAC enabled. The best solution for this is to configure HWiNFO using Windows Task Scheduler.
Reply
#3
Yes, very nice. Thanks for creating and sharing it !!!

On the plugin name....probably just a carry over from my first RM skin back in v1.3 or something like that. If the short name works fine, great.

One the device names, its a race condition that I mention in this thread. HWiNFO needs to start first, or a RM refresh (manual or timed) is required.

- Nick
Reply
#4
(05-13-2013, 10:37 AM)stangowner Wrote: Yes, very nice. Thanks for creating and sharing it !!!

On the plugin name....probably just a carry over from my first RM skin back in v1.3 or something like that. If the short name works fine, great.

One the device names, its a race condition that I mention in this thread. HWiNFO needs to start first, or a RM refresh (manual or timed) is required.

- Nick

No worries, device names and UAC are not show-stoppers, although the need to manually open sensors seems both odd and painful.
Reply
#5
Have you tried to enable the Sensor-only mode ?
Reply
#6
(05-13-2013, 05:09 PM)Martin Wrote: Have you tried to enable the Sensor-only mode ?

Yep, solves that one too Wink

Version 1.4 of Dashboard is out Linkage.

[Image: preview-82-212-280.jpg]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)