Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ever Increasing System Memory Usage
#1
Using the latest Beta of HWINFO64 and the memory usage of the app keeps climbing and climbing. The other day i found it using near 4GB of system memory and it just keeps climbing and climbing. 

I have checked all my settings and to the best of my knowledge, there are no logging options enabled. I use the latest build of Rivatuner to run OSD overlays in my games.

I put my system to sleep every night and wake it the next morning. 

I have attached my DXDIAG, i would appreciate any troubleshooting suggestions you can offer. 

http://imgur.com/FC2NsZr


Attached Files
.txt   DxDiag.txt (Size: 138.47 KB / Downloads: 0)
Reply
#2
I've had the system on for around 10 hours. What started off at around 60MB usage is now at 3GB and rising by the minute.

http://imgur.com/J9Ftn7v
Reply
#3
Can you please try to disable sensors one by one (press Del key on the sensor heading) and see if you can catch which sensor is causing this.
Please let me know the result.
Reply
#4
I'll try, but this could take some time. I'll start tomorrow morning.
Reply
#5
Found the cause, it was Pro Duo GPUs 3 and 4. As soon as i disabled those two sensors, it stopped. It slowed after disabling the sensor for GPU3, and stopped after 4 was disabled.
http://imgur.com/Kke4DPx
Reply
#6
Thanks for the results, this is interesting. Now we should somehow get closer to why this happens...
Would you be able to determine if there's some particular sensor readout under those sensors that when disabled will also solve this ? So enable back the entire sensor headings and try to check particular readouts.
Reply
#7
Weird, I've deleted everything but the memory usage continues to climb.
Reply
#8
Can you please try another test?
If you're using Sensors-only mode, then uncheck that setting. Then run HWiNFO and you should get a summary window. Leave that window opened without opening the sensors window and watch memory usage. In the summary window you can also choose which GPU to show, so if the memory grows you should also know which GPU polling is causing it.
Reply
#9
How do i do that? Been using this config for ages.
Reply
#10
Just disable the "Sensors-only" check at HWiNFO startup, the rest should be easy then Wink
Reply
#11
(08-05-2017, 12:43 PM)Martin Wrote: Just disable the "Sensors-only" check at HWiNFO startup, the rest should be easy then Wink

Weirdly, i don't get that notification on startup. I used to.
Reply
#12
You might have disabled the welcome screen, or perhaps using auto-start ?
You can change these settings by right clicking on the HWiNFO tray icon.
Reply
#13
In the process of restoring sensors and trying (unsuccessfully) to restore that welcome screen, the issue has gone away. Not sure why or how, but it looks like memory consumption is peaked at around 100mb. I'll keep testing over the next few days and let you know.
Reply
#14
Well, that's interesting. Would be great if it would be resolved, but still wondering how that could have happened...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)