Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Frame skips, mouse lag, and random shut downs?
#1
Hi! I've had great luck with this product in the past, and recently installed it on my machine after doing a clean install.

However this time, as soon as I opened the program I noticed that my mouse would 'hang' every 5 second or so. I opened up a game that I had been trying to play (I was having framerate troubles, probably because of overheating so I downloaded the program for the fan control) and I also experienced audio stutter as well as framerate stutters. All happening at the same time as the mouse hangs as well.

What really disturbed me, was that after playing for not very long, my computer completely powered off. No shut down screen, or anything. Just shut off.

These shutdowns had happened to me before while using Hwinfo and playing games, so I'm not sure what that is.

Any insight would be absolutely lovely, and feel free to ask for any information you may require. Thanks!
Reply
#2
Bump?
Reply
#3
This might be caused by reading of certain sensors (EC especially) and had been discussed here several times.
Please attach your machine specification and a sensor screenshot.
Reply
#4
(09-02-2012, 08:07 AM)Martin Wrote: This might be caused by reading of certain sensors (EC especially) and had been discussed here several times.
Please attach your machine specification and a sensor screenshot.

Here is an imgur album displaying the System Summary page, and the sensor page. I hope that is enough to help you out. http://imgur.com/a/FecVI
Reply
#5
This is a known problem already discussed in the Alienware Fan Control thread here:
http://forum.techinferno.com/hwinfo32-64...ntrol.html

Some users claim that removing the battery from notebook fixes those problems.
As another alternative, disabling the "EC Support" in HWiNFO can fix it too, however the fan control won't be as flexible as with that option enabled.
The lags can be fixed by disabling monitoring of the EC (COMPAL EC) sensor.
Please check the above thread for more information.
Reply
#6
(09-02-2012, 08:04 PM)Martin Wrote: This is a known problem already discussed in the Alienware Fan Control thread here:
http://forum.techinferno.com/hwinfo32-64...ntrol.html

Some users claim that removing the battery from notebook fixes those problems.
As another alternative, disabling the "EC Support" in HWiNFO can fix it too, however the fan control won't be as flexible as with that option enabled.
The lags can be fixed by disabling monitoring of the EC (COMPAL EC) sensor.
Please check the above thread for more information.


Just to be clear. Removing the battery, and disabling EC Support could fix the shut-downs in games, while disabling the Compal EC sensor will help the lag?

I'm going to read that link now. Thanks!

Actually, I'm having a hard time finding where to disable the EC Support. And the lag appears to still be present after disabling monitoring of the Compal EC sensor (It prompts to to disable it as soon as I click 'sensors')

So after immediately opening the program, I click 'configure' and uncheck EC Support under the safety tab.

I then click Run, and Sensors. This time instead of asking me to disable reading from Compal EC, it asks that I stop the monitoring of DELL EC.

Lag is still present after disabling EC Support.
Reply
#7
(09-02-2012, 08:16 PM)TbanksIV Wrote: Just to be clear. Removing the battery, and disabling EC Support could fix the shut-downs in games, while disabling the Compal EC sensor will help the lag?

Yes, exactly. In case you use fan control too, there might still be a slight lag. That might be caused by another sensor causing it (SMART for example), or the fan control itself. You need to check other sensors, or try to disable the EC Support, if that helps to fix the lags (some users claim that it does)...

(09-02-2012, 08:16 PM)TbanksIV Wrote: Actually, I'm having a hard time finding where to disable the EC Support. And the lag appears to still be present after disabling monitoring of the Compal EC sensor (It prompts to to disable it as soon as I click 'sensors')

You can disable the "EC Support", from the welcome screen - press Configure and go to the Safety tab.
Reply
#8
In case the lag is present after disabling the EC Support, then try to deactivate Fan Control in HWiNFO if that's the cause. If that won't help, try to disable other sensors (SMART especially) to check if maybe another one can cause it...
Also, are you sure the lag is caused by HWiNFO ?
Reply
#9
(09-02-2012, 08:43 PM)Martin Wrote: In case the lag is present after disabling the EC Support, then try to deactivate Fan Control in HWiNFO if that's the cause. If that won't help, try to disable other sensors (SMART especially) to check if maybe another one can cause it...
Also, are you sure the lag is caused by HWiNFO ?

Disabling smart sensors stopped the lag completely. So that part is solved.

However I have both EC support off, and the battery removed, and the computer still shuts down during games. (Although it took slightly longer this time.)

I'm mainly trying to use HWinfo for the fan control. Is there anyway to disable everything else, and only use the fan control?
Reply
#10
So the lag was caused by the storage driver. I suppose you're using the Intel RST driver; certain versions of this driver are known to cause such problems.
With EC support disabled and battery removed there were no complications reported. Moreover even with EC support and battery inserted, such unexpected shutdowns were not observed, but different (not so fatal) issues instead.
Are you sure that the shutdown happens because of HWiNFO ? Such shutdown can happen as a thermal protection measure, so is it possible that there's something overheating ?
Reply
#11
(09-02-2012, 09:34 PM)Martin Wrote: So the lag was caused by the storage driver. I suppose you're using the Intel RST driver; certain versions of this driver are known to cause such problems.
With EC support disabled and battery removed there were no complications reported. Moreover even with EC support and battery inserted, such unexpected shutdowns were not observed, but different (not so fatal) issues instead.
Are you sure that the shutdown happens because of HWiNFO ? Such shutdown can happen as a thermal protection measure, so is it possible that there's something overheating ?

I will try running the game in question without hwinfo open to see how it goes. I'll respond tomorrow with the results, I have to go to work right now.
Reply
#12
Hello, Martin. I do hope you're still following this thread.

I ran the game today without Hwinfo running and there were no shutdowns. PLayed for around half an hour, shutdowns usually occur within the first 5-10 minutes.

However the reason why I want to take manual control of the fans is still present. The longer I play the game, the less frames I get. This is presumably because of my gpu getting hotter and hotter, and slowing down my performance.

With HWinfo active and fans blasting, the game runs perfectly, until the imminent shutdown.

Kind of stumped here.
Reply
#13
Yes, I'm following all threads.
Do the shutdowns occur with both "EC Support" disabled and enabled modes ? Do you use a custom fan speed table, or just manually set the fan speed at once ?
Can you please post a screenshot of the sensors and fan control screens ?
Reply
#14
Here is a screen shot of my sensors and Fan speed page, when EC Support is diabled and with disabled monitoring for SMART.: http://imgur.com/QiTDD

As I've said, for whatever reason, COMPAL EC has changed to DELL EC, now that I've disabled EC support. I assume that's just a name change and not an actual issue?

But yes, Shutdowns occur with both EC Support enabled and disabled. As far as customizing fan speeds, the most I ever do is slide the top fan to where I want it, (With EC Support disabled, this being the maximum I can slide it).
Reply
#15
The change to DELL EC is intentional - disabling the EC support forced HWiNFO to use a different method to access the Embedded Controller (now via the DELL EC method).

Do you have a Dual-GPU Crossfire system ? If yes, then ULPS might be causing the shutdowns. Check here for more info:
http://www.hwinfo.com/forum/Thread-IMPOR...own-Issues
Reply
#16
(09-04-2012, 08:48 PM)Martin Wrote: The change to DELL EC is intentional - disabling the EC support forced HWiNFO to use a different method to access the Embedded Controller (now via the DELL EC method).

Do you have a Dual-GPU Crossfire system ? If yes, then ULPS might be causing the shutdowns. Check here for more info:
http://www.hwinfo.com/forum/Thread-IMPOR...own-Issues

Unfortunately, I'm not very sure. I have an AMD Radeon HD 6900m. As well as embedded Intel graphics.

In that link it mentions a tool called Saphire Trixx to disable the use of ULPS.
Will doing so cause any system instability / Will it choose to use my High performance GPU over my embedded intel graphics?
Reply
#17
So you don't have a Crossfire system and I'm not sure if ULPS can be a cause in system using switchable graphics.
I don't think that disabling ULPS could cause instability, nor change the way how switchable graphics works.. It's used to put the secondary AMD GPU into lowest power state when not utilized in Crossfire systems. So it might have no impact on your system at all and maybe the problem is different...
Reply
#18
(09-04-2012, 09:34 PM)Martin Wrote: So you don't have a Crossfire system and I'm not sure if ULPS can be a cause in system using switchable graphics.
I don't think that disabling ULPS could cause instability, nor change the way how switchable graphics works.. It's used to put the secondary AMD GPU into lowest power state when not utilized in Crossfire systems. So it might have no impact on your system at all and maybe the problem is different...

Sigh

Well, I turned off HWinfo completely, and ran trixx, using it's fan control to mitigate the loss of framerates I see when playing games for over 10 minutes. And I still got shutdowns.

So it appears my system only shuts down when I use a program to take control over the fans. However when I don't take control over my fans, I get severely decreased framerates (Likely from overheating).

I realize this new information means that it's not your program that's causing these shutdowns for me. But would you mind pointing me in the right direction with this?

Completely stumped.
Reply
#19
I'm sorry, but I have no more ideas what might be causing those shutdowns.
Maybe the fans are not controlled properly, stop sometimes and the system overheats, so it shuts down as a protection measure? You might want to log your temperatures to prove this..
Or check at some notebook forums (Tech|Inferno for example) if there are other users with similar problems.
Reply
#20
Hello

Just read this thread and have a couple of things that may help you sort your problem out. Looking at your sensor screen shot and the contents of your posts I guess your running and Intel i7 cpu. Might be an idea to post the title of the game your having issues with too.

If it is an i7 try this out
1) disable hyper threading if its enabled (You probably wont notice the difference)
2) disable the Intel graphics in your bios.
3) more recent Catalyst drivers are missing some files Trixx needs to over-clock your video card (I know you don't want too),tipdl64.dll atipdlxx.dll these files are also needed to disable ulps. I think their is a third dll, will have a look when I get to go on my pc later. I have seen trixx report ulps disabled on my own system but it had not and caused me some issues including game crashes and bsod's.

I hope this helps you out.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)