Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HWINFO crashes and reboots my PC when idle (0x0000001e - KMODE_EXCEPTION_NOT_HANDLE)
#1
Hello  - My monitor sleep time is set to 15 minutes and PC sleep time is set to 1 hour. When I leave my PC in Idle state, my monitor goes to sleep as usual at 15 minutes and at approximately 20 minutes my PC reboots by itself, As soon as it reboots I can see that windows has created a DUMP file and when I run the dump file through analyzer it points directly to HWiNFO64.EXE as the cause for the crash causing windows to reboot itself . So I uninstalled HWINFO completely and then the issue is resolved and my PC no longer reboots by itself when in idle . I install HWinfo again and My PC reboots again when in idle. Attached the Windows Dump analyzer output and HWINFO debug and report files .

Please check and let me know what could be causing the issue .


Attached Files Thumbnail(s)
   

.txt   Win_Dump_Analysis_Report.txt (Size: 6.94 KB / Downloads: 3)
.dbg   HWiNFO64.DBG (Size: 1.65 MB / Downloads: 1)
.htm   DESKTOP-UCE455K.HTM (Size: 210.01 KB / Downloads: 2)
Reply
#2
(08-05-2018, 10:01 AM)madhan388 Wrote: Hello  - My monitor sleep time is set to 15 minutes and PC sleep time is set to 1 hour. When I leave my PC in Idle state, my monitor goes to sleep as usual at 15 minutes and at approximately 20 minutes my PC reboots by itself, As soon as it reboots I can see that windows has created a DUMP file and when I run the dump file through analyzer it points directly to HWiNFO64.EXE as the cause for the crash causing windows to reboot itself . So I uninstalled HWINFO completely and then the issue is resolved and my PC no longer reboots by itself when in idle . I install HWinfo again and My PC reboots again when in idle. Attached the Windows Dump analyzer output and HWINFO debug and report files .

Please check and let me know what could be causing the issue .

I have the same problem. Can't leave HWinfo running or the computer will reboot. I thought it was related to the issue with the polling setting, but the new versions have not fixed it. It seems to be related to Nvidia, but on the Nvidia forums they say it is not their fault. I have seen on this forum the suggestion to run previous nvidia drivers, but the issue is a couple months old now, so I can't say I want to roll back my drivers that far.
Reply
#3
We have seen several such issues with recent NVIDIA drivers.
And since HWiNFO (and other similar tools) make only use of their exposed API to monitor systems, it must be their fault. There's nothing we can change here, as we rely on their provided interface (NVAPI).
Reply
#4
(08-15-2018, 07:52 AM)Martin Wrote: We have seen several such issues with recent NVIDIA drivers.
And since HWiNFO (and other similar tools) make only use of their exposed API to monitor systems, it must be their fault. There's nothing we can change here, as we rely on their provided interface (NVAPI).

Martin, could the error named DRIVER_OVERRAN_STACK_BUFFER be caused by compatibility issue between HWInfo and Nvidia drivers as well? I've been facing reboots under idle state and, after checking the minidump with Windbg the report mentions nvlddmkm.sys and HWInfo.exe. nvlddmkm.sys is pointed as the probable cause, by the way.


Attached Files
.txt   hwinfo e nvidia crash.txt (Size: 6.72 KB / Downloads: 0)
Reply
#5
This is not a compatibility problem between NVIDIA drivers and other software like HWiNFO. This is a sole issue of their drivers as described above. And AFAIK other tools are affected by this problem as well.
Reply
#6
The issue that I started this thread for is no longer happening! PC goes to sleep perfectly fine now. Not sure what fixed it. Maybe Nvidia's latest driver?
Reply
#7
Thanks for the feedback. Have you also updated HWiNFO to v5.88 ?
Reply
#8
(09-05-2018, 06:58 AM)Martin Wrote: Thanks for the feedback. Have you also updated HWiNFO to v5.88 ?

yes. I am always on the latest version. But it was resolved even before I upgraded.
Reply
#9
Interesting.. which driver version you think resolved this?
Reply
#10
(09-05-2018, 08:44 AM)Martin Wrote: Interesting.. which driver version you think resolved this?

I take it back. The issue is not yet resolved. half of the time my pc goes to sleep successfully. rest half of the time it reboots by itself. it's occurring less frequently than before. but it's still there.
Reply
#11
Can you link this change in behavior (less frequent crashes) to the latest NVIDIA driver update?
Reply
#12
Hey Martin, is there any tick box in settings > safety that can disable the sensor causing KMODE issue for now? I've had to give up opening HWinfo because of all the BSOD issues, between the windows 1803 thing and this one.
Reply
#13
You might try to disable monitoring of the entire GPU sensor, but not sure if that will help..
Reply
#14
(09-06-2018, 06:57 AM)Martin Wrote: Can you link this change in behavior (less frequent crashes) to the latest NVIDIA driver update?

I will monitor it over a week and report back the findings next week.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)