Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HWINFO64 causes low bandwidth on RX480 when I change memory clock speed
#1
Hello,
I have found an important issue during overclocking my 2 Asus Strix RX480 Gaming OC 8GB cards. Changing the memory clock of my cards while HWINFO64 is open causes insanely low bandwidth. Bandwidth with stock memory clock(2000MHz) and timings is around 195-200GB/s, it drops significantly when I change the memory clock speed and keep HWINFO64 open during the process. Most of the time it drops from 195-200GB/s to 62GB/s, randomly to 80GB/s and 151GB/s. 

How to reproduce the issue:
Open Radeon settings
Open HWINFO64
Open OCL MemBench for bandwidth benchmarking
Run OCL MemBench before any overclocking attempt and note down the reported bandwidth(195-200GB/s in my case)
Add an offset of +25 or +50 to memory clock speed
Now the memory bandwidth of gpu drops down to 62GB/s(sometimes to 151GB/s or 80GB/s but those numbers were much rare than 62GB/s)

Memory bandwidth benchmarked with OCL MemBench(overclocked via Radeon Wattman-nothing else is running other than Wattman) can be found below:

2000MHz memory clock-bandwidth is around 195-200GB/s: https://prnt.sc/nh3r0c
2050MHz memory clock-bandwidth is around 200-205GB/s: https://prnt.sc/nh3rea
2100MHz memory clock-bandwidth is around 209-212GB/s: https://prnt.sc/nh3rf2
2150MHz memory clock-bandwidth is around 214-218GB/s: https://prnt.sc/nh3rfw
2200MHz memory clock-bandwidth is around 221-223GB/s: https://prnt.sc/nh3rhw
2250MHz memory clock-bandwidth is around 227-231GB/s: https://prnt.sc/nh3sri

Now I reset Wattman settings, open HWINFO64, overclock memory speed and benchmark again(only Wattman and HWINFO64 are open):

2000MHz memory clock-bandwidth is around 195-198GB/s: https://prnt.sc/nh47gh
2050MHz memory clock-bandwidth is around    61-63GB/s: https://prnt.sc/nh47yw
2100MHz memory clock-bandwidth is around    62-63GB/s: https://prnt.sc/nh487r
2150MHz memory clock-bandwidth is around    61-63GB/s: https://prnt.sc/nh48gv
2200MHz memory clock-bandwidth is around    61-63GB/s: https://prnt.sc/nh48qg
2250MHz memory clock-bandwidth is around    60-63GB/s: https://prnt.sc/nh48y2
Dropping the memory clock back down to 2000MHz doesn't resolve the issue: https://prnt.sc/nh49ho

Only full system restart resolves the problem but it is easily reproducable with the giving steps. I can confirm it is not a bug of OCL MemBench as my scores drop in various benchmarks like 3DMark Timespy, 3dMark Firestrike, Unigine Superposition, Unigine Heaven which clearly confirms the bandwidth drop.

Edit: Just noticed I haven't listed my system specs:

Ryzen 5 1600
Asus Strix RX480 Gaming OC 8GB(I am able to reproduce the issue on both of them and I have been benchmarking them one by one as my psu only has 1 6 pin and 1 8 pin PCI-E power connector.)
MSI X370 Gaming Pro Carbon(updated to latest BIOS)
Patriot Viper 4 3200MHz CL16 2x8GB(actually clocked at 3133MHz and my custom timings as XMP is not stable, my settings are 1000% HCI memtest stable)
1TB Seagate Barracuda
250GB Sandisk Ultra SSD
Reply
#2
This is an interesting issue and it could be a problem of drivers, which HWiNFO talks to in order to read certain parameters.
Does restarting HWiNFO perhaps solve this issue or only a system reboot? After rebooting the system, is the new memory clock retained ?
Can you also try some other tools like GPU-Z or MSI Afterburner if they cause the same issue ?
Reply
#3
(04-26-2019, 11:17 AM)Martin Wrote: This is an interesting issue and it could be a problem of drivers, which HWiNFO talks to in order to read certain parameters.
Does restarting HWiNFO perhaps solve this issue or only a system reboot? After rebooting the system, is the new memory clock retained ?
Can you also try some other tools like GPU-Z or MSI Afterburner if they cause the same issue ?

I have been benchmarking my card with Unigine Superposition using MSI Afterburner and GPU-Z for an hour, neither of them caused the issue I described so far. I have tested from 2000MHz all the way up to 2250MHz increasing memory clock by +25MHz for each testing(11 benchmark runs) and also benchmarked bandwidth with each +25MHz increase. So far so good, no issues at all so I am 100% sure it is HWINFO64 triggering the issue.

Just tried your suggestion, closing HWINFO64 doesn't resolve the issue. You have to restart the system to recover bandwidth and performance lose.

By the way I have created a post on amd subreddit and have got confirmations by other users.

https://www.reddit.com/r/Amd/comments/bh...ng_memory/
Reply
#4
Interesting.. Please go into main settings of HWiNFO and enable the "Prefer AMD ADL" option and let me know if that will make any difference.
Reply
#5
Not OP, but I already have "Prefer AMD ADL" option enabled, so it does not make any difference.
Reply
#6
(04-26-2019, 01:25 PM)Martin Wrote: Interesting.. Please go into main settings of HWiNFO and enable the "Prefer AMD ADL" option and let me know if that will make any difference.

Enabling "Prefer AMD ADL" didn't resolve the issue. I have noticed 2 things:

1)Opening sensors tab causes the issue, HWINFO64 without sensors tab running doesn't cause any bandwidth/performance decrease.


2)Changing memory clock before running sensors on HWINFO64 doesn't reproduce the issue but changing memory clock while sensors tab is open reproduces the issue every single time.

Edit: By the way I have tried various AMD drivers, even 17.7.1. It was occuring with all of them so I am probably sure it is not because of AMD drivers or it is also related to drivers but they haven't noticed and fixed in 2 years(which is less likely but something to consider)
Reply
#7
OK, thanks for the information.
Another things to try:
- Disable the "GPU I2C Support" option in the SMBus/I2C tab of main settings
- Try to disable the "GPU Memory Errors" sensor by hitting the Del key over its entry
Reply
#8
(04-26-2019, 01:51 PM)Martin Wrote: OK, thanks for the information.
Another things to try:
- Disable the "GPU I2C Support" option in the SMBus/I2C tab of main settings
- Try to disable the "GPU Memory Errors" sensor by hitting the Del key over its entry

Disabling "GPU I2C Support" didn't resolve the issue but disabling "GPU Memory Errors" RESOLVED it completely. Too bad I was using HWINFO64 mainly to monitor memory errors with my GPU overclocks. Thank you very much for taking your time and helping me out!
Reply
#9
Well, that explains something, also why other tools are not affected. AFAIK HWiNFO is the only software that can monitor this parameter.
Unfortunately I'm not sure how I could work around this. Perhaps the only solution would be to disable this sensor before making a change to GPU clock and re-enable it again after. Not sure if this would help though...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)