Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HWiNFO64 freezes after some time
#1
hello, i have an alienware m17x r3, the problem is that i only configured /messed with the fan speeds cuz i need them custom, but after some time, for ex i play a game with hwinfo in backround with custom fan speeds after i exit the game, i notice the program froze, cant close it even via task manager.. and cant shut down my pc, only force shut down by holding the power button 3-5 sec.. how do i make it not freeze anymore? and possibly not have to enter it everytime to set my custom fan speeds (if i exit the program my speed is locked , i have to keep it in background for it to work..


i am new to this forum Smile please help me and thank you in advance Smile.


Attached Files
.txt   hwinfo log.txt (Size: 117.14 KB / Downloads: 2)
Reply
#2
You might try to disable "EC Support" in HWiNFO to switch it into a safer fan control mode.
Please check the following thread for more information:
http://forum.techinferno.com/hwinfo32-64...ntrol.html
Reply
#3
ty for your help, this might work as it works so far. but the next thing is: i only got this program cuz i have a problem with gpu temperature, and i really liked when i set up the fan speed at 7000 when it goes above 60 c, so now the max speed is 4000??
Reply
#4
The 7000 RPM you saw in the previous mode didn't in fact set the fan speed to such level. It was just the limit of the slider scale, in reality the maximum fan speed depends on model and it was around 4000 RPM. You can check that if you switch back to that mode, set highest RPM and watch sensors window what fan speed is displayed (under the Compal EC sensor).
Reply
#5
my sensors seem to show 0 fan speed and i work with a bounch of programs ...so there might be a small hardware problem, but the whole point of me using souch software is cuz at 78c it throttles, aldough i cleaned everything i changed the thermal phaste it still throttled, but since this program, when it was at high speed it went way slower to 78 c than usual and then it got past that mark so somehow the throttling point of 78 c was off and that was jackpot, i think by the sound of the fan that its not at full speed, but this might be a placebo since i dont see 7000 and i see 4000 anyways thanks ALOT ! its working so far i disabled everything that has to do with ec. even the warning when you click on sensors.
Reply
#6
one more problem found.. so i disabled everything but sw smi and it works good, but when i listen to music or in game or anything that requires sound, i keep hearing those annoying beeps kind of thing in the speakers from time to time.. and when i close the program it doesent beep anymore..
Reply
#7
Yes, this is because in this mode the commands for fan speed monitoring and control run at very high priority, higher than audio.
Disable monitoring of the DELL EC sensor, also you might need to disable the respin in fan control (if used). That should improve the situation.
Reply
#8
i disabled respin period. this kindof improved, yea..it does that but not as much. if you somehow fix this bug/problem pls tell me, i WILL donate if this program does the same thing it does but without the buzzing sound. Smile
Reply
#9
Have you disabled monitoring of the DELL EC sensor too?
Reply
#10
yes it is disabled since it once asked me automaticly about disabling it plus i see it disabled in the sensor status, dell ec is with a red dot with a white cross in the middle in the sensor status.
Reply
#11
Try to disable other sensors to see which is causing it. Besides the DELL EC, certain storage drivers (Intel RST) might cause this too, so disabling the SMART sensor helps there.
Reply
#12
i have a hard time figuring out how to disable sensors.. here are 2 print screens , one with my disabled/enabled stuff at configure tab and one with the sensors that are disabled..



Edit: tipicly the buzzing sound is like a pop and i can only hear it when for ex it goes from 59c to 60c and the fan starts and same when it stops. and same to 69c to 70c etc.


Attached Files Thumbnail(s)
       
Reply
#13
To disable monitoring of a sensor, simply right-click on the sensor name in the sensors window and select Disable Monitoring.
However, looking at the settings you have set (your 2nd picture of the Configure screen) I suggest to enable the "From Bus Clock" and "Use HPET" options back. Disabling those items can cause stuttering on certain systems.
Reply
#14
something else happened. i\ve took all your advice, turned on everything that needs to pe turned on, tunrend off everything that need to be turned off. it happened to me once, and now it happened 2 times.. so i got a gadget with the gpu and i set the alarm to go off at 85 c. and after soome hours, pluggin into charger, unplugging, watching a movie, playing a game, then random surfing the internet (shouldnt stress) the fans apparently just stop and it gets hot. until the alarm goes off. the program is not froze, but i am not fast enough to close it and openit again to see if it works cuz im affraid to damage my pc due to heat, so i just turn it off.... up until this point since i last talked to you i had no problem. and in the last week i didnt modify any settings but for some reason this problem appeared out of nowhere, i'll update and see if this keeps happening
Reply
#15
Hi there,

I have the same problem where the GPU fan of my Alienware m17x R3 stops spinning. This problem has been there since I purchased the computer from Dell. As explained by nutzaalex, the fan eventually stops spinning after some random amount of time.

I found a way to make it spin again using HWiNFO64: just go to the HWiNFO Fan Control panel and click on System Auto. The fan will then be controlled by the system and will spin at the speed as directed by the system. This is really weird that although the automatic control of the fans is supposedly active, the GPU fan is turned off after some time and one has to click on System Auto to re-enable it. Note that the fact that the automatic control of the fans stops working has nothing to do with HWiNFO, the problem happens even HWiNFO was never installed.

So currently the GPU temperatures have to be monitored and when they got to high, one need to go to the Fan Control panel and click on System Auto. Which means that if one is not careful enough watching the temperatures then GPU can heat up dramatically. If that happens, the computer will normally shutdown to prevent damage to the components.

Martin, I have a suggestion that could fix this problem. I could see that the Respin period checkbox does nothing unless Set Manual or Custom Auto are used. My suggestion is that when the Respin period check box is checked and the fans are not under the control of Set Manual or Custom Auto, then the respin period could be used to automatically trigger a System Auto. That way, one can put for instance 10000 ms of respin period and be sure that the fans are put back to work every 10 seconds. Because System Auto is used, the fans will spin at the speed instructed by the system.

Thank you,

Fred
Alienware m17x R3 - ATI 6990m - 16GB RAM - I7 2760QM - HDD 750GB x 2 (RAID 0) - Killer Wireless-N 1103
Reply
#16
That would be feasible of course. However from my experience on certain systems applying the System Auto mode several times can cause the fans to stop spinning too. I'm not sure if that happens on your system, so could you please check that? I just want to avoid causing an even more serious problem.
Reply
#17
Hi Martin,

Indeed if both fans are initially spinning clicking on System Auto will stop them. But then if the temperatures are high enough, the system will make them spin again. With that said, during my tests I had the situation where both fans were spinning and clicking on System Auto made them stop. The temperature was very moderate so maybe they would have stopped a few seconds later. Anyway I understand your point and agree it's better to stay safe and not create more serious problems.

By the way from your experience, doesn't this problem (GPU fan doesn't spin anymore) indicate a hardware issue? Because if it's a defect in the hardware (motherboard?) then I can have Dell change it as my machine is still under warranty. Initially I though it was a hardware problem but because HWiNFO can make the fans spin again, I am not so sure anymore. Also when I reboot the machine and the GPU was hot, the GPU fans goes on at high speed.

Thank you,

Fred
Alienware m17x R3 - ATI 6990m - 16GB RAM - I7 2760QM - HDD 750GB x 2 (RAID 0) - Killer Wireless-N 1103
Reply
#18
I don't think that's a hardware issue, I rather believe it's a firmware problem - a bug in the Embedded Controller's firmware logic.
This might be fixed using a BIOS update (with EC), but it depends on DELL if they did that. Have you tried a BIOS update?
If nothing helps, I think you should consider to RMA. Many Alienware users have problems with cooling and the more users report it to DELL the bigger the chance they really start looking at solutions...
Reply
#19
Hi Martin,

Thank you for your comments. As for the BIOS update, I have the latest one. Eventually I got the motherboard and the video card replaced and the problem is now gone. Indeed it seems there it is a bug in the Embedded Controller firmware logic. I could see that AIDA64 disabled their Dell SMI Sensor for Alienware M17x R3 and R4 to prevent the fans from stopping.

Thanks again for your advice.

Fred
Alienware m17x R3 - ATI 6990m - 16GB RAM - I7 2760QM - HDD 750GB x 2 (RAID 0) - Killer Wireless-N 1103
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)