Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
High memory usage
#1
Hello!
I continuously ran HWiNFO for 1 month (maybe less... I'm not sure because i was away from my PC for 1 month), then my Windows 10 tells me "not enough memory. please close program HWiNFO." (I'm using Japanese environment so i don't know is this translation correct...) and I closed and restarted HWiNFO.

Now HWiNFO continuously ran 3 days and it used 4GB since before i start HWiNFO.

My system has 24GB of RAM.
Reply
#2
What settings in HWiNFO do you use, are you running with Sensors-only ?
Reply
#3
(10-05-2017, 06:28 PM)Martin Wrote: What settings in HWiNFO do you use, are you running with Sensors-only ?

These are my current settings.


Attached Files Thumbnail(s)
                   
Reply
#4
1 hour passed and HWiNFO is using 800000KB and increasing slowly...


Attached Files Thumbnail(s)
   
Reply
#5
Well, those settings look OK.
You'll need to try to disable monitoring of sensors one by one and see which of them is causing this by watching if memory usage still grows.
You can do this by hitting the Del key on the sensor heading. I propose to start with the SMART sensors.
If you find the one causing this, please let me know which is it.
Reply
#6
(10-05-2017, 08:01 PM)Martin Wrote: Well, those settings look OK.
You'll need to try to disable monitoring of sensors one by one and see which of them is causing this by watching if memory usage still grows.
You can do this by hitting the Del key on the sensor heading. I propose to start with the SMART sensors.
If you find the one causing this, please let me know which is it.

okay... i will do this weekend. Confused
Reply
#7
(10-05-2017, 08:01 PM)Martin Wrote: Well, those settings look OK.
You'll need to try to disable monitoring of sensors one by one and see which of them is causing this by watching if memory usage still grows.
You can do this by hitting the Del key on the sensor heading. I propose to start with the SMART sensors.
If you find the one causing this, please let me know which is it.

Look likes my second GPU is doing something. I'm using two R9 390X with crossfire enabled. Driver version is Radeon Software 17.9.3
After disabled these sensors, HWiNFO still grows my memory usage. But it is now less than before.


Attached Files Thumbnail(s)
   
Reply
#8
Well, memory usage should not be constantly growing at all. Which of the GPU sensors is causing it, the main one or the others (PMBus) ?
Reply
#9
(10-06-2017, 06:24 PM)Martin Wrote: Well, memory usage should not be constantly growing at all. Which of the GPU sensors is causing it, the main one or the others (PMBus) ?


All of these Sad
Reply
#10
And with them all disabled how is the memory usage growing ?
Reply
#11
(10-06-2017, 06:35 PM)Martin Wrote: And with them all disabled how is the memory usage growing ?

oh,
HWiNFO stopped growing memory now.
So that three sensors are doing something.
Reply
#12
This could be a driver problem. HWiNFO retrieves some information from AMD drivers and they could be causing the memory leak.
Can you try to enable only the heading of the first sensor and then check if memory usage start growing again ?
Reply
#13
(10-06-2017, 07:36 PM)Martin Wrote: This could be a driver problem. HWiNFO retrieves some information from AMD drivers and they could be causing the memory leak.
Can you try to enable only the heading of the first sensor and then check if memory usage start growing again ?
it started growing. it grows between 100~1000KB in 10 sec.
Reply
#14
Well, I think it's a driver problem. It might be due to CrossFire. Can you try to disable CrossFire and see if memory grows after enabling those sensors in HWiNFO ?
Reply
#15
(10-06-2017, 08:09 PM)Martin Wrote: Well, I think it's a driver problem. It might be due to CrossFire. Can you try to disable CrossFire and see if memory grows after enabling those sensors in HWiNFO ?

Disabled crossfire and no more growing.
Reply
#16
That confirms it's a driver problem. I will submit this bug to AMD and see if they can fix it in upcoming Crimson versions.
Reply
#17
(10-06-2017, 08:46 PM)Martin Wrote: That confirms it's a driver problem. I will submit this bug to AMD and see if they can fix it in upcoming Crimson versions.

Thanks!
Reply
#18
AMD is requesting more information about your system in order to reproduce this problem.
Can you please attach the HWiNFO Report File and Debug File ?
Reply
#19
(10-11-2017, 07:14 AM)Martin Wrote: AMD is requesting more information about your system in order to reproduce this problem.
Can you please attach the HWiNFO Report File and Debug File ?

Here it is.

Please use Shift-JIS for character encoding.(I'm using Japanese)


Attached Files
.rar   kenichiA380.rar (Size: 117.25 KB / Downloads: 1)
Reply
#20
Thanks. Was this done with Crossfire enabled ?
I also see that you upgraded to Crimson 17.10.1. Does the problem persist there ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)