Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to reduce HwInfo launch timings ? & Auto-start ?
#1
Okay,
I've this program for a few days now, i am loving it. I've even sent E-mail to Filehippo to add this app to their site.
Now to the point, is there any way to improve launching speeds ? I notice that it takes about 20 secs to read ATI GPU on my machine, is that normal ?

The following takes lot of time.
GPU #29
GPU #30
GPU #31

I tried disabling ATI/AMD monitoring & saved/quit it but it still scans my GPU.

Any workaround to resolve it ?

Second thing, i am unable to find " Run this program automatically when Windows starts " like option. After searching the forum, i found that this function is already available but i'm unable to locate it ? Where this option resides exactly ?

This is what i get in "CONFIGURE" menu.
General
Layout
System tray
OSD (RTSS)
Alerts
Logitech LCD
HWiNFO Gadget

Thanks!
Reply
#2
Yes, there is a way how to significantly improve the launching speed. It seems most of the time is spent during scanning of GPU I2C buses to detect additional GPU sensors. According to a screenshot you posted earlier, it seems your machine doesn't have any additional GPU sensors, so you can disable the entire GPU I2C scan: Configure -> SMBus/I2C -> uncheck "GPU I2C Support". I'm sure, this will significantly improve the launching speed.
In case your machine would have additional GPU I2C sensors, HWiNFO would no longer detect/report these sensors when disabling that option.

Regarding the Autorun during Windows start, you can find this option here: Configure -> General/User Interface -> Auto Start
Reply
#3
Oh, thats awesome!

I took me a while to notice that " General / User interface " is only available when you start the application then click "Configure" there instead of clicking configure when application is fully launched.

Anyway, i've disabled "GPU I2C support" and application is launching blazing fast now! Also ticked Auto-run option!

Thanks again Martin!
Reply
#4
Unchecking the "GPU I2C Support" changed my start up time on crossfired 7770's from 30seconds to 2 seconds...it works.
Reply
#5
(09-04-2013, 08:37 AM)ChairmanSaab Wrote: I took me a while to notice that " General / User interface " is only available when you start the application then click "Configure" there instead of clicking configure when application is fully launched.

This configuration menu with "General / User Interface" you can also access with right-click on the tray icon when the program is fully launched!
There are two different config screens:
One in the sensor screen and one with right click on tray icon.
Reply
#6
(09-04-2013, 07:18 AM)Martin Wrote: Yes, there is a way how to significantly improve the launching speed. It seems most of the time is spent during scanning of GPU I2C buses to detect additional GPU sensors. According to a screenshot you posted earlier, it seems your machine doesn't have any additional GPU sensors, so you can disable the entire GPU I2C scan: Configure -> SMBus/I2C -> uncheck "GPU I2C Support". I'm sure, this will significantly improve the launching speed.
In case your machine would have additional GPU I2C sensors, HWiNFO would no longer detect/report these sensors when disabling that option.

Regarding the Autorun during  Windows start, you can find this option here: Configure -> General/User Interface -> Auto Start


Hi Martin
I have an issue with the new version 4.48. Though the Auto start is checked, HWiNFO does not autorun during Windows start. Any ideas why?
Thanks
Reply
#7
(12-01-2014, 08:13 AM)SpyrosGeorge Wrote: Hi Martin
I have an issue with the new version 4.48. Though the Auto start is checked, HWiNFO does not autorun during Windows start. Any ideas why?
Thanks

Please try the following:
- Uncheck the Auto Start option and click OK
- Check the Auto Start option and click OK
Does it work now?
Reply
#8
(12-01-2014, 08:50 AM)Martin Wrote:
(12-01-2014, 08:13 AM)SpyrosGeorge Wrote: Hi Martin
I have an issue with the new version 4.48. Though the Auto start is checked, HWiNFO does not autorun during Windows start. Any ideas why?
Thanks

Please try the following:
- Uncheck the Auto Start option and click OK
- Check the Auto Start option and click OK
Does it work now?

Thanks, Martin, it works!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)