Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Label not found" - change description
#1
Hello, is there a possibility of changing the description of "Label not found" to another?
I mean exactly change it to two letter description. For example - NA, --, NF, ??.

I would like to make changes because when I start my computer and gtx970 operates in passive mode and fan speed are zero rpm smartie LCD displays the message "label not found". The result is that on the LCD gets literal mess and not see the rest of the data. When the fans spin for a moment and stop, lcd shown zero rpm, and then it's all right.
Wink
Reply
#2
Since this concerns LCD Smartie, I have moved it to the appropriate sub-forum. Better would be to contact the LCD Smartie author directly.
Reply
#3
Hmm that is an odd one. The only time you should see the message "Label not found" is if the sensor you are trying to display does not exist.
I guess it's possible that if the computer starts with the gpu in passive mode then HwINFO may not recognise the sensor until the gpu exits passive mode.
That's a little tricky to deal with since the LCD Smartie plugin can't differentiate between a non-existant sensor and one which has not yet loaded into HwINFO.

May I suggest an alternative work-around for your particular case:
There is a plugin by one of LCD Smarties developers Limbo called SearchAndReplace (sandr) which you can configure to replace any particular text with another user defined text.
Put something like this in sandr's omit.ini

[Search1]
1=Label not found

[Replace1]
1=NA

Then in LCD Smartie: $dll(sandr,1,$dll(hwinfo,1,YourSensorID,),)

..Seems Limbo's website is down. Lucky I have a copy of sandr, attached.


Attached Files
.zip   sandr.zip (Size: 8.47 KB / Downloads: 6)
Reply
#4
Thank You Hurley but not working. 
I have such an effect.

[Image: Capture010_zpsv5cjjcyu.png]

[Image: DSC_7694_zpslrytrwso.jpg]

Huh
Reply
#5
Works ok for me.
Make sure the sandr.dll is in the LCD Smartie\plugins folder and extract this omit.ini file to the root of C drive ie: C:\omit.ini
The readMe says that's the default ini path if not specified in the second parameter eg:

$dll(sandr,1,$dll(hwinfo,1,YourSensorID,), path to omit.ini)

Sorry I forgot that part. But easier to just drop the omit.ini in C:\
You may need to restart LCD Smartie too.


Attached Files
.zip   omit_ini.zip (Size: 278 bytes / Downloads: 4)
Reply
#6
Wink 
Works great - Thank You.  Heart

Cpu $dll(hwinfo,1,Core #0 Clock,-L|-U)MHz $dll(hwinfo,1,CPU Package ,-L|-U)W $Right($CPUUsage%%,$3%)
$dll(hwinfo,1,CPU IA Cores,-L|-U)°C $dll(hwinfo,1,Vcore,-L|-U)V $dll(hwinfo,1,FAN|CPU,-L|-U)RPM
Gpu $dll(hwinfo,1,GPU Clock,-L|-U)/$dll(hwinfo,1,GPU Memory Clock,-L|-U)MHz
$dll(hwinfo,1,GPU Temperature ,-L|-U)°C $dll(sandr,1,$dll(hwinfo,1,FAN|GPU,-L|-U),C:\Programy\lcd\LCD_Smartie_v5.4.2.92++ - Ariel2\plugins\omit.ini)RPM


[Search1]
1=Label not found



[Replace1]
1=...


Win7 x64 Idle
[Image: DSC_7703_zps9onhmkad.jpg]


Unigine Valley Benchmark
[Image: DSC_7706_zpsnqbl7wo2.jpg]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)