Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Missing VS2013 CRT Dll's
#1
Stangowner,

We have updated the development environment for Rainmeter 3.3 r2493 (release candidate 1) to VS2015, and this is causing a bit of an issue with the HWiNFO plugin for Rainmeter. 

The issue is that you are apparently dynamically linking to the VS2013 CRT runtime libraries, and we are no longer shipping any runtimes with Rainmeter. This is causing any user who does not have the VS2013 runtimes actually installed on their system to have to get it and install it from https://www.microsoft.com/en-us/download...x?id=40784 in order to use your plugin.

https://forum.rainmeter.net/viewtopic.ph...09#p118309

It would be much better if you statically linked to the CRT Dll's that you need, then separate installation would not be required on the user's computer.

https://msdn.microsoft.com/en-us/library/2kzt1wy3.aspx
You might want to use /MT for Release builds.

It wouldn't be enough to just start using VS2015 yourself, if you continue to dynamically link to the runtimes. We don't ship any runtimes at all with Rainmeter anymore, we statically link to what we need in the app and built-in plugins.

HWiNFO and the HWiNFO Rainmeter plugin are hugely popular with Rainmeter users, so I hope we can address this sometime soon. We plan on a "release" of Rainmeter 3.3 in about a week or so.

Jeffrey Morley
The Rainmeter Team
Reply
#2
Hi Jeff,

Thanks for the info on the update and changes in packaging.  I'll work on updating the plugin per your recommendations.  I'll try to have it ready before you do your release if possible.

Thanks,
Nick
Reply
#3
(12-27-2015, 11:29 PM)stangowner Wrote: Hi Jeff,

Thanks for the info on the update and changes in packaging.  I'll work on updating the plugin per your recommendations.  I'll try to have it ready before you do your release if possible.

Thanks,
Nick

That would be great. The important thing is to "statically link" to the CRT dlls. That way nobody has to "have them" on their system. We no longer include any at all in Rainmeter, and many if not most users are just not going to have the C++ runtimes installed for 2013, much less 2015.

Thanks,

Jeff
Reply
#4
Understood, thanks.
Reply
#5
Martin,

I know I'm asking a lot here.....but can you take a quick peek at the attached debug log file?

This is my new MacBook Pro which I dual boot with Windows 10.  I'm not looking for full support on this hardware.  I just need Sensors to run with a few basic values so I can develop on this machine instead of requiring me to use my desktop.  I've tried disabling everything I can, but the sensors scan window flies by and then it just hangs.  The summary and main windows seem fine and show quite a bit of info.

If its not s simple as the existing settings, don't worry and I'll use my desktop.

I would have PM'd you, but could not attach a file there.

Thanks,
Nick


Attached Files
.dbg   HWiNFO64.DBG (Size: 304.69 KB / Downloads: 1)
Reply
#6
Nick, while using Debug Mode, please open the sensors window, then after it hangs kill HWiNFO from task manager and attach the resulting DBG file.
Reply
#7
Hi Martin,

That is what I did.

I reset my ini and reran it.  It came out a tad bigger this time.

- Nick


Attached Files
.dbg   HWiNFO64.DBG (Size: 500.27 KB / Downloads: 2)
Reply
#8
Thanks for the data. It look like this bug will require a new build, but I don't have enough information about this yet.
Could you please repeat the previous procedure, but after launching the sensors window wait a few minutes before killing HWiNFO and attach the new DBG file ?
Reply
#9
Hmmmm, looks like it was not hung.

I let it run, and the sensors window did finally open.....it just took a bit over 8 minutes to do so.  Once it opened, no values updated at all, but I was able to access the shared memory so that is great.  And everything closed cleanly (no end task needed).

I've attached a new debug file in case you can tell what is causing the delay.


Attached Files
.dbg   HWiNFO64.DBG (Size: 777.11 KB / Downloads: 1)
Reply
#10
8 minutes is huuge. It seems the Apple SMC sensor takes too long to read the values out. This would be too difficult to diagnose without having direct access to the machine for debugging.
As a temporary workaround you might try to disable that sensor in HWiNFO, or try to disable the "Apple SMC device" in Device Manager to see if that helps.
Reply
#11
Hi.  Thanks, but those did not help.  Once I disabled the system sensor though, at least values starting updating every 2 seconds.  So I'll just wait the 8 min and monitor the CPU only for now.  If I need more I'll use my desktop.  Plus now I can test remote monitoring too.

Thanks for helping!
Reply
#12
I will release a new build soon that will give you an option to completely disable this sensor.
Reply
#13
Thanks Martin.  Sorry to be a pain.  I need to be able to do iOS development, so a dual booth Mac just makes the most sense for me.....
Reply
#14
No problem, I need to fix such issue anyway Wink
Reply
#15
One thing Nick, when you build this, be sure your .rc has a newer / higher version number than the existing one, or Rainmeter by default won't install it. We have instituted a check in the .rmskin installer that won't install plugins that are a lower or the same version number as one the user already has. I'm sure you would be doing that anyway, but can't hurt to remind...

Jeff
Reply
#16
Thanks Jeff.

Yes, version numbers have already been updated.

For a status update, I just finished adding remote monitoring capabilities to the SharedMemoryViewer.  I'll work on adding this to the plugin as well now.  Once all that tests out OK, I'll create an updated skin too.  So it will all have new versions.  I'll keep you updated once its ready for users.

Thanks,
Nick
Reply
#17
(12-29-2015, 05:01 PM)stangowner Wrote: Thanks Jeff.

Yes, version numbers have already been updated.

For a status update, I just finished adding remote monitoring capabilities to the SharedMemoryViewer.  I'll work on adding this to the plugin as well now.  Once all that tests out OK, I'll create an updated skin too.  So it will all have new versions.  I'll keep you updated once its ready for users.

Thanks,
Nick

Outstanding...
Reply
#18
Jeff,

Version 3 has been released.  It includes the changes we discussed.  You can get the details here:
http://www.hwinfo.com/forum/Thread-Rainm...HWiNFO-3-0
Reply
#19
(01-01-2016, 05:27 PM)stangowner Wrote: Jeff,

Version 3 has been released.  It includes the changes we discussed.  You can get the details here:
http://www.hwinfo.com/forum/Thread-Rainm...HWiNFO-3-0


Nick,

Thanks so much. I will edit / create some posts on our forums to point folks to the new plugin, and will update some .rmskins there to use it. 

When we release Rainmeter 3.3 (Likely this Sunday if we don't hit any issues) I will be sure the release notes on our site prominently features this change.

Thanks for all the hard work by you and Martin. We really appreciate it.

Jeff
Reply
#20
Thanks Jeff.  We appreciate your support !
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)