Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem With Sensor Entries Drag and Drop
#1
Hi Martin,

Noticed the new feature of dragging and dropping entries in the Sensor Status window, but I'm having difficulty with it. Some information and questions:

I do not have all the available sensor entries displayed, many are removed using the Layout feature.

I have not moved any entries around with the Order feature.

I add and remove drives from my PCs regularly, and occasionally see "ghost" entries of drives that are no longer in the PC. Those entries can also be associated with new drives for some reason. I only mention this as I now know you use the Windows registry, which probably explains this.

I have Fixed order checked in Configure Sensors. That's really the main reason or start of my problems, since if I uncheck it, the order of the entries is a mess. The same thing happens when I try to drag and drop one entry in the sensor screen, but that is caused by Fixed order automatically unchecking itself to allow the movement of the entry, correct?

Main question, should Fixed order be unchecked before any Layout editing is done? Any relationship between the two? What is the best way to configure things when I remove ~25 sensor entries, and want to move some around, to change their order?

Could HWiNFO registry entries cause this and other confusion such as I have with disk drive entries?

Thanks!
ASRock Z97 Extreme6  Intel Xeon E3-1276 v3  Scythe Mugen 4
16GB Samsung M3V 2000MTs 1.35V
SanDisk Extreme Pro 256GB Windows 8.1 UEFI boot
Samsung 840 Pro 256GB x 2 RAID 0 Windows 10 TP UEFI boot
Samsung 830 256GB x 2 RAID 0
EVGA GTX 760
Dell P2714H
Dell U2312HM
ASUS VS24A
Seasonic X660 XP2 PSU
Fractal Define R4
Reply
#2
Yes, when I implemented the drag-and-drop I asked myself what to do when Fixed Order is used. Not to allow drag-drop at all, or popup a dialog asking whether to disable it. I decided that the best option is to automatically disable Fixed Order when the user drops a sensor entry somewhere in the list, since this is probably what the user wants, so don't make more obstacles Smile

I believe the source of your issues is that you often add/remove drives which might after some time can cause a bit of mess. I suggest that you make some cleanup, the best would be to do a "Restore Original Order". If that doesn't help, do a Reset Preferences.
Then it doesn't matter much if Fixed Order is enabled or disabled when you want to move items around via drag and drop.
Reply
#3
Yes Martin, I know about using Restore Original Order, and I'll try the Reset Preferences.

Just noticed in another thread you found a bug in the drag and drop feature, which was after your post above. I assume that is new information and I'll wait for a fix, Thanks much.
ASRock Z97 Extreme6  Intel Xeon E3-1276 v3  Scythe Mugen 4
16GB Samsung M3V 2000MTs 1.35V
SanDisk Extreme Pro 256GB Windows 8.1 UEFI boot
Samsung 840 Pro 256GB x 2 RAID 0 Windows 10 TP UEFI boot
Samsung 830 256GB x 2 RAID 0
EVGA GTX 760
Dell P2714H
Dell U2312HM
ASUS VS24A
Seasonic X660 XP2 PSU
Fractal Define R4
Reply
#4
I'm not sure to which bug you refer to, but I suppose it's the one that was fixed in the new Beta build 2333 (changing order via Layout tab).
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)