Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Screen Resolution
#1
Hi,

First of all a huge Thanks for HWiNFO!

My system: HP 8540w 64bit , VideoCard: ATI 5800

I have no problem using only my laptop, but when I connect it via VGA, with my 1080p monitor I get a problem when starting HWiNFO.
The resolution is normally on 1080p (1920x1080), 60Hz, but when I start the program (64bit) the resolution just drops and the refresh rate drops to 30Hz.
It is possible to set the resolution back to 1080p manually, but this can't be done with the refresh rate. So I get this annoying flickering.

Hope someone can help me out,

Thanks in advance!
Reply
#2
Hi,
please try to go into HWiNFO32/64 Configure and disable some settings there (especially GPU I2C Support) and let me know if that helped.
Reply
#3
Thanks for your reply!

Unfortunately my problem has not been solved. I've almoast tried every possible way (checking/unchecking things), but the refresh rate keeps dropping to 30 Hz.

Maybe something interesting, If I set my laptop to sleep and I leave the program running, and start the laptop again, the refresh rate/screen resolution is perfect again. The program is running fine at that moment.
Reply
#4
That's pretty strange..
Please enable Debug Mode, then run completely with sensors until the refresh rate drops. Then close HWiNFO32/64 and send me the HWiNFO32/64.DBG file it created.
Reply
#5
Here is the Debug File.
<!-- m --><a class="postlink" href="http://www.sendspace.com/file/9h4b6v">http://www.sendspace.com/file/9h4b6v</a><!-- m -->

Thanks Again!

PS. So to make sure, This happens when the sensor etc are loaded, and the screens popup.
Not immediately after the program is started.
Reply
#6
Unfortunately I don't see anything suspicious in the debug data and it's very hard to diagnose such issue without having direct access to the machine.
Please try to disable the GPU sensors (right-click and Disable), then close Sensors and then open again to see if the problem happens again. If yes, please try to disable the rest of sensors the same way and check if there's a particular sensor which is causing it.
Reply
#7
Martin Wrote:Unfortunately I don't see anything suspicious in the debug data and it's very hard to diagnose such issue without having direct access to the machine.
Please try to disable the GPU sensors (right-click and Disable), then close Sensors and then open again to see if the problem happens again. If yes, please try to disable the rest of sensors the same way and check if there's a particular sensor which is causing it.

Thanks you very much. I will try that!
Reply
#8
I think I already know what the problem is.

My |Video Card isn't supported. It's a Ati Firepro M5800, but it's shows like a 5730..
Reply
#9
No, that's not the problem for sure Wink That's just a matter of ID/string and weird ATI/AMD branding methods (they assign many different model names to a single ID).

Sp0KI Wrote:I think I already know what the problem is.

My |Video Card isn't supported. It's a Ati Firepro M5800, but it's shows like a 5730..
Reply
#10
Oh alright.

I disabled the GPU/Others but it is still happening. A bummer really.

Well maybe, it will be solved after an other build, miraculously :p
Reply
#11
I don't think such miracles happen (at least in near time) ;-)
My only suspicion that could cause such issue was the "GPU I2C Support", but you say you tried to disable it and it didn't help...
The only idea I have now is to build a special version for you which during the sensor scan would require to press a key. That would allow you to watch closely which exact "Detecting Sensor ..." item causes this issue and then maybe I could look into this more deeply.
Reply
#12
Wow, that would be amazing!
If you have time in the future, so you can work on it, it would be Awesome!
Reply
#13
Ok, I have prepared a special version for this test. I have inserted a 3 second delay after each component detection during sensor scan. This should give you plenty of time needed to catch which was the component that caused the screen erratum.
Please get the special version here:
<!-- w --><a class="postlink" href="http://www.hwinfo.com/beta/hw64_383_1332_.zip">www.hwinfo.com/beta/hw64_383_1332_.zip</a><!-- w -->
The whole sensor detection process will now take quite long, so it will require a bit of patience Wink
Reply
#14
So I've done the test.

It did crash when it was Detecting Sensors, GPU ATI #29. It was done for almoast 80%.

PS. GPU 2IC in the Config was unchecked.
Reply
#15
Thanks. I made a fix to GPU I2C setting, so please get a new build:
<!-- w --><a class="postlink" href="http://www.hwinfo.com/beta/hw64_383_1333.zip">www.hwinfo.com/beta/hw64_383_1333.zip</a><!-- w -->
and keep the "GPU I2C Support" unchecked. That should fix the issue.
Reply
#16
Martin, Awesome job!

Thank you very very much.
Reply
#17
Thank you too for the feedback and patience Wink
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)