Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved Autostart with notebook on battery mode

on my Notebook I had the problem, that the autostart feature seemed not to work any more.

I checked different versions of HWinfo but this doesn't solve the problem.

Now I found in the task scheduler, where the autostart is defined, that the autostart feature is configured only to work on wired state - and I have been on battery!

Is this a bug or a feature? Wink
Or is it possible, that some of my other programs have changed this setting?
If it's a feature, it should be documented somewhere or give the user the choice with an extra checkbutton.

It's easy to change this in the task scheduler - but you have to know this!
HWiNFO, when creating its entry in Task Scheduler doesn't specify such setting. So I'm not sure how that could have happened.
So it perhaps was a special problem with my notebook.
I've tested so much the last days, so this may be possible.
I checked again and it's not your fault. The "Start the task only if the computer is on AC power" option seems to be enabled by default when creating a new task.
I'll check for a possible solution, so that this is always disabled when HWiNFO creates the task...
And there are three other issues (I checked the created task on my office Notebook):

I don't know the english text and try to translate because I have a german Windows 7 Enterprise (64bit) here.

1. On the 1st Tab (General) there is at the bottom a selectbox with "configurated for" and this is set to "Windows Vista, Windows Server 2008" but should be "Windows 7, Windows Server 2008 R2".
Don't know, if this matters. I see no differences in start behaviour.

2. On the 5th tab (Settings) there is an option, that deactivates the task if Windows runs for more than 3 Days (4th checkbox with 3 days selected).
I don't know exactly, but would understand it that way, that windows kills the task after a runtime of 3 days.
This shouldn't be set either!

3. Is it necessary to start the task with "highest privileges"? (1st tab "General", checkbox nearly at the bottom)
Thanks, I have also noticed some of those "default" settings, which need to be changed. The last one (Highest Privileges) is required in order to access hardware.
I'll fix this in the next build.
I'll also add a 5 second start delay after logon, which might fix the issues reported earlier by other users (longer startup).
Great! Smile
Check the new build just released (v4.23-1993) Wink
Everything is set correct now and works.
This Release sets nearly everything as I would do!
Just "configurated for" is set to "Windows Vista, Windows Server 2008" as before.
But as I mentioned, I don't see a problem here.
Thanks for the feedback.
I don't think that should cause any problems.

Forum Jump:

Users browsing this thread: 1 Guest(s)