Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved Cannot Update to new Version
#1
Good Day to you all,
I am an avid user of HWInfo and like the Info it gives,however it will not let me update to a new version ( from hw64_556 to hw64_558 ). I keep getting the failure message that I do not have the Rights to overwrite the data already there. I have Admin Rights as I am running the only Account on this Computer. I have tried to manually Delete the Folder, also with a Data Shredder.
The System is Windows 10.
Is there anything I am doing wrong?

Thanks for any help!
Triple-D
Reply
#2
Are you performing the update using the installer version ?
If you have HWiNFO running during the update, have you closed it ?
Reply
#3
(10-10-2017, 03:48 PM)Martin Wrote: Are you performing the update using the installer version ?
If you have HWiNFO running during the update, have you closed it ?

Thank you for replying,
Ihave indeed tried to install it with the installer, and yes, I have closed the Program also checking through the Task Manager to be sure that it is closed.
Reply
#4
Which files does it claim that it cannot overwrite ?
Also, before starting the install please make sure via Task Manager that HWiNFO is not running.
Reply
#5
(10-10-2017, 05:31 PM)Martin Wrote: Which files does it claim that it cannot overwrite ?
Also, before starting the install please make sure via Task Manager that HWiNFO is not running.

I have already stated that I have looked in the Task Manager.
I recieve the Fail message that a File cannot be moved, Fail Code 183.
The File that cannot be deleted or moved ist the .exe Data, also I cannot delete the Folder that this File is in.
Note: I was able to delete all the other Files in this Folder, I have also look at the hidden Data and the System Data in this Folder,nothing remains except the .exe Data.
Reply
#6
If you try to manually delete the EXE file, what error do you get ?
Reply
#7
(10-10-2017, 08:29 PM)Martin Wrote: If you try to manually delete the EXE file, what error do you get ?

I get an error that states I do not have Admin Authority to delete this File.
I am on the only Account on this Computer and definitely have Admin Rights.
Reply
#8
Try to run the setup by right-clicking on the installer and "Run as Administrator".
Reply
#9
(10-11-2017, 06:53 AM)Martin Wrote: Try to run the setup by right-clicking on the installer and "Run as Administrator".

Already tried that, I always get the same failure message, "unable to move File Code 183"
Everything I have tried I get this message, and believe me, I`ve already tried everything you have suggested.
That is why I am trying to get help here.
I really do appriecate all of your suggestions Martin,but none of them work as I have already tried them. Smile
Reply
#10
Is it possible that something else in the system might be blocking this? Perhaps some antivirus/antimalware or similar software ?
Reply
#11
(10-11-2017, 09:51 PM)Martin Wrote: Is it possible that something else in the system might be blocking this? Perhaps some antivirus/antimalware or similar software ?

Hi Martin,
Sorry for the delay in answering,I live in Germany and slept. Blush 

There was indeed something in the system that was blocking it, but not some type of antivir or anything like that. It was the Registry itself.I did a search in the Registry and deleted the entire folder out of the Registry, and Viola, it let me delete the EXE File and the folder, since then I am again enjoying HWiNFO to the fullest.I use HWiNFO on 3 Computers and 2 Laptops,so I really enjoy being able to see the Info at a glance whenever a member of my Family comes running with a problem.
Thank you very much for trying your best to help,People like you make the difference in a Forum like this where someone needs help.Your suggestions didn`t actually solve the problem, but they did get me to thinking about other possibilties.
again
Thanks Martin Smile
Reply
#12
No problem, I live in Slovakia, which is the same time zone Smile
The solution you found is really interesting and I'm wondering which keys you had to delete to solve it. Never heard about something like that...
Reply
#13
(10-12-2017, 07:14 AM)Martin Wrote: No problem, I live in Slovakia, which is the same time zone Smile
The solution you found is really interesting and I'm wondering which keys you had to delete to solve it. Never heard about something like that...

Hi Martin,
I went into regedit and did a search to be truthful,it showed quite a few things actually, but the only Folder I deleted was in HKEY_USERS : S-1-5-21-1235418357-1660617254-36058857100-1001 wich contains HWiNFO64. I deleted
that Folder and everything was allright after that. There were a whole lot of other entries, but I just left them alone, so I do not know if any other entries are relevant to the process.There were some entries in the same folder underneath with the ending of "_Classes" ans some in HKEY_CURRENT_CONFIG, but I left them alone as well.
I hope these entries may be of some help in the future to further your knowledge about any Bugs that may arise in this area.
Thanks again Martin
Triple-D

Note: There were also some entries in the Recycler as well, but I didn`t touch them.
Reply
#14
Thanks! Yes, this might be helpful to other users watching this forum and experiencing a similar issue.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)