Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved HWINFO64 causing stuttering in-game after MS Fall Creator's Update
#1
This seems to have happened coincidental with upgrade to Windows Fall Creator's Update to Windows 10 (Redstone 3). 

I have a top-end gaming PC (i7-6700K 4.2GHz, EVGA GTX 1080 Ti FTW3 Gaming, ASUS Z-170 Pro board) and I've been playing the game No Man's Sky for over a year. I get 60fps locked at 2560x1440 in game at nearly all times. Whenever that is not happening I can see the GPU load hitting 100% via the 8-inch display I purchased specifically to run 16 graph windows with HWINFO64 (a screenshot from a while back of that tiny display showing graphs is attached). I keep it running all the time.

Only two days ago did I finally say "go ahead" and let the Creator's Update install, despite it having come in October. I believe it was the first time playing the game since the update and I immediately noticed a brief stutter in the screen animation that recurred every 3-5 seconds. It was not there before -- playing this game glass smooth is the reason I built this PC, so I am extremely aware of the performance as I play. 

I looked to see if any crapware was running that I had not seen before, and it was not. I rebooted, when I loaded NMS, the stutter was gone. Just needed a reboot I thought, so I loaded HWINFO64 up and set out to play. Back was the stutter, the same as before. So, I quit HWINFO64 and the stutter was gone. I run HWINFO64 _constantly_ while playing anything (I like to see what the hardware is doing), and I've never seen it cause a stutter. 

I was running a non-beta version of HWINFO64 that was released within the last 3-4 months -- not the latest (5.58?). When I saw the stutter issue, I downloaded the latest beta (5.61-3290) and noted that it made no difference re: the stuttering. 

It seems that something about the change to Windows 10 with this update doesn't like HWINFO64. I do hope you can address this. Let me know what else I can provide as means of assistance. Thanks.


bp


Attached Files Thumbnail(s)
   
Reply
#2
It's possible that reading some of the sensors is causing this and this should be quite easy to determine.
Check all sensors in the list and start disabling their monitoring by hitting the Del key over a sensor heading in the list.
I propose to first try to disable the ASUS EC or Disk SMART sensors as these are known to sometimes cause such issues.
Let me know if you can find the guilty sensor.
Reply
#3
(11-22-2017, 11:09 PM)Martin Wrote: It's possible that reading some of the sensors is causing this and this should be quite easy to determine.
Check all sensors in the list and start disabling their monitoring by hitting the Del key over a sensor heading in the list.
I propose to first try to disable the ASUS EC or Disk SMART sensors as these are known to sometimes cause such issues.
Let me know if you can find the guilty sensor.

Actually -- I came back to update. I tried loading the frightening looking EVGA Overclock Monitor Suite or whatever it's called and turned on it's own set of system tracking graphs (it supports quote a few metrics), and what I saw in-game was basically the same that HWiNFO64 was doing -- the same kind of stutter. Exactly the same, I think. Quit the EVGA app and all was glass smooth again...

This would seem to backup your notion. I will go through the list and start disabling. 


bp
Reply
#4
If it's the GPU sensor causing this stutter, then the problem is in NVIDIA drivers.
Try to update them to the latest version, Version 388.31 fixes this bug:
"Micro-stuttering occurs in games when GPU monitoring tools are monitoring GPU power"
https://us.download.nvidia.com/Windows/3...-notes.pdf
Reply
#5
I disabled nearly everything on the list and the stutter was still there, then I disabled:

GPU [#0]: NVIDIA GeForce GTX 1080 Ti

and the stuttering was gone. It is the monitoring of the GPU that is causing this issue, it seems. And, again, I had HWiNFO64's CPU and GPU monitor graphs running constantly without any issues until the day I installed the Windows 10 Fall Creator's Update ("Redstone 3"). There has been no other notable change on that day with the system. I feel nearly 100% certain this must be due to the Windows update having changed something in this area in the system. 

I note I am running Nvidia GeForce drivers 388.13 and I am in the process of updating to 388.31 and will report back if that makes any difference.


bp
Reply
#6
(I hadn't seen your gfx card guess when I was making that last reply.) Unsurprisingly, the updated gfx drivers fixed the problem.

I will say again that I never saw this issue at all prior to the Fall Creator's Update installation. I'd been monitoring GPU metrics (incl voltage) for a year without issue.

Productive back and forth here. Thanks for the help.



bp
Reply
#7
You're welcome, I'm glad that it's solved.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)