Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved HWiNFO32 v4.61.2475 hangs in the analysis of the equipment at the time of launch.
#1
HWiNFO32 v4.61.2475 hangs in the analysis of the equipment at the time of the launch on the motherboard ASUS P5Q SE (Intel P45 (Eaglelake-P) + ICH10 Consumer). The equipment can be seen in the screenshot, additional controllers not established. Replacement HWiNFO32.INI on delivery option from the archives allowed to see the point of time hovering program - a survey of equipment, previously Nastron HWiNFO32.INI seen that trade TID4852 almost completely uses one CPU core, and judging by the call stack is pending events (?). Screenshots taken in Process Hacker v2.34 r5769 x86 under the account with administrative privileges and UAC off, and INI file attached.

On v4.61.2470 these phenomena do not watch.


Attached Files Thumbnail(s)
               

.zip   screenshots.zip (Size: 761.53 KB / Downloads: 1)
Reply
#2
Please attach the HWiNFO Debug File for more precise analysis.
Reply
#3
Already thinking about it. Try to create, but if you look at the call stack is possible that the reason for the survey becomes unresponsive driver ATK0110 ACPI UTILITY installed for ASUS Motherboard  based chipset's G41 / G43 / G45 / Q45 / P45 / X48 series - I think that there are developers boards use non-standard technical decision to support and which need this driver.

Debug log that I put probably not complete because the program hangs at the start with about the same in nature and call stack that previously applied and because I had to take over the task of Process Hacker :: Terminate Process after five minutes of waiting since its launch the program does not go to the output step of the main window.

File list on working copy HWiNFO32:

HWiNFO32.DBG
HWiNFO32.EXE
HWiNFO32.INI
HWiNFOMonitor.gadget
unins000.dat
unins000.exe


Attached Files
.dbg   HWiNFO32.DBG (Size: 259.21 KB / Downloads: 1)
Reply
#4
Thank you. I have just released a new Beta build 2476 that should fix it. Please let me know if it's OK now.
Reply
#5
Martin!

Big thanks! Startup hardware enumeration error found in v4.61.2475 is resolving. Version v4.61.2476 starting OK! w/o problem.
Reply
#6
Thank you for the feedback.
Reply
#7
Just FYI, I had the same issue and this latest beta corrected the problem. Whew... Had me going there for a minute! ;-)
Reply
#8
Thanks Smile It was caused by a change that I made in build 2475 to support CPUs with many cores (MIC). It seems that this didn't work well with some older CPUs. Build 2476 should fix that.
Reply
#9
Well, once the secret is out, then I confess - I myself is a place immediately suspected as alive as long as the CPU with such a large number of ALU not held, but I think that their appearance is not a long wait since increase productivity by increasing the clock frequency is nowhere - the mobility of carriers in semiconductor thing of course, but the transition from silicon, gallium arsenide which is significantly higher mean levels of the need for simultaneous translation and inversion of logic signals. Circuitry is possible, but this complication schemes again and will have to change the technology of manufacturing PCB - two and a stripe lines industry is unlikely to want to communicate because it will increase the cost of the final product - three.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)