Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved HWiNFO64 V4.34-2130 Causing = key to not function
#1
Hello everyone and thank you for taking the time to read my post...it is a peculiar one.

I recently encountered a strange issue with my PC, and it has taken me several days to pinpoint the issue. My = key would not function, but I could SHIFT and still type a + Huh

After a few hours of fiddling around with different USB ports, removing my extension cable, installing/removing Logitech gaming software, etc... I contacted Logitech to see if they could shine some light on this peculiar problem I was having with my G510. They sent me a response to remove any other USB devices, use a USB 2.0 port instead of 3.0, remove any hubs/extension cables, and lastly test in another computer.

The only thing that worked was moving the keyboard to another computer.

I then proceeded to test with my 3 other Logitech keyboards, Wireless Wave Pro, K360 and K400; all of which have the same problem...no = but + works. Had to be something with this machine.

This lead me to check device manager to make sure I didn't have any conflicts there, and there were 2 !'s for USB devices. I figured this was going to be an easy fix, so I re-downloaded, and re-installed USB drivers for my Z87 Gryphon; I know I was re-downloading because this made a duplicate RAR file. The installation must not have taken the first time around for whatever reason.

Reboot the computer and immediately test in the start menu search box, = is working! Big Grin I go to respond to Logitech that I have fixed the problem and now = is NOT working Huh

Check device manager and the !'s are gone now, so drivers were in fact NOT the issue.

What changed from just after boot, to 60 seconds later when I logged into e-mail and started responding to Logitech? Maybe there is a USB conflict of some sort now since all drivers are correct...I unplug my BIOS flashback flash drive, USB 3.0 hub and dock; leaving only my G510 and G700 plugged in...reboot.

= Is working without a hitch for about 60 seconds and then stops. As I'm holding down the = key I watch HWiNFO pop up and then the sensors monitoring box pops up as well. As soon as the sensors loading box disappeared, no more = key!

I exit HWiNFO, = key works. Load HWiNFO, = key works until real-time monitoring is loaded. I close only the sensors function and the = key starts working again...How strange!

I don't have any other brand of keyboard to test with to verify this is happening with others. My 4 different keyboards use 3 different connection methods however, so maybe it's a Logitech issue. The G510 is wired, the Wave Pro has the older 2.4Ghz dongle(~2in long) and only connects the Wave Pro M/K, and the K360/K400 utilize the Unifying Receiver.
Reply
#2
This is a really interesting problem Smile
I suggest you try the following: go through all sensors and right click on them, then select "Disable Monitoring". Watch the = key and I think when you hit the sensor which is causing this, the = should work. Please let me know which one it was, so I can check if there might be a better workaround for this...
Reply
#3
Thanks for responding.

That was next on my list of things to do. The only USB device that shows up on the sensors list is my 4GB BIOS flash drive, and I immediately turned off monitoring for it, but it didn't fix the problem. I'll run through and disable the groups first to find which area is causing the problem, then pinpoint from there. I am testing out a new router presently, and will give you an update when I can.
Reply
#4
I went through and disabled the large groups of items being monitored one by one; i.e. System, CPU[#0]: Intel Core i7-4770k, Nuvoton NCT6791D, etc.

I disabled each to see if the equals key would function, and when it didn't I enabled that group again and moved to the next. Disabling any group individually did not restore function to the equals key.

Disabling every group entirely still does not allow the equals key to function. All I need to do is close the sensors window and =============== works without a hitch.

**scratches head**
Reply
#5
Then I will need more information about your system.
Please enable Debug Mode in HWiNFO. Then continue, open the Sensors window, let it run for a few seconds. Then close the Sensors window and from the main HWiNFO window click "Save Report". Close HWiNFO and attach (or send me) both files created - the DBG file and Report file.
Reply
#6
(03-05-2014, 07:51 PM)Martin Wrote: This is a really interesting problem Smile
I suggest you try the following: go through all sensors and right click on them, then select "Disable Monitoring". Watch the = key and I think when you hit the sensor which is causing this, the = should work. Please let me know which one it was, so I can check if there might be a better workaround for this...

Here's the log report, did you need it in a format aside from HTML?


I also tried disabling all other startup programs like uTorrent, Logitech Gaming Software, Corsair Headset, etc. All I left was MS Security Essentials, CCC, and Realtek HD Audio.


Attached Files
.htm   log report.HTM (Size: 174.12 KB / Downloads: 1)
Reply
#7
HTML is OK, but the report doesn't contain sensor values. You'd need to enable the "Log all values for Report" option to include them.
What what I can see from the limited information posted, you might try to disable the "EC Support" option in HWiNFO if that maybe fixes the issue.
Reply
#8
(03-09-2014, 10:26 PM)Martin Wrote: HTML is OK, but the report doesn't contain sensor values. You'd need to enable the "Log all values for Report" option to include them.
What what I can see from the limited information posted, you might try to disable the "EC Support" option in HWiNFO if that maybe fixes the issue.

My apologies, not very familiar with the software yet. I did find the setting for 'log all values' though.

I tried disabling 'EC Support' and when I clicked the sensors button to see if it fixed the problem I lost video signal and my computer hard locked. No keyboard response at all, needed to flip PSU switch to restart. On reboot, HWiNFO is taking an abnormal amount of time to load; it is still loading now after a solid 2.5-3 minutes of being in Windows.

Disabling EC support did not fix the issue.

Thank you for your remarkably quick responses for such a miniscule conflict. I don't even use the = that often, but when it wasn't working in Excel it made me start thinking...and then I had to find out what was going on.


Attached Files
.csv   log report2.CSV (Size: 10.61 KB / Downloads: 1)
.htm   log report2.htm (Size: 271.44 KB / Downloads: 1)
Reply
#9
While disabling "EC Support", have you maybe enabled Debug Mode as well? That would explain the long starting time - in this mode HWiNFO performs a few more operations while storing a lot of internal data into the DBG file (for my analysis). This is normal.

You might also try to upgrade to the latest Beta build (v4.35-2140), which should improve the start time in default mode.
Reply
#10
Another idea would be to Disable Drive Scan, if that maybe has an influence..
Reply
#11
Disabled drive scan with no luck. Downloaded beta version, was holding down = key on the reply box for the forum here, as soon as sensors finished loading = stopped working but my desktop started filling up with log reports as I was holding the = key down?

Heading out for the evening, I'll tinker some more possibly tonight or during the week after work. It's not the end of the world as I can disable sensors when I am not playing a game. At least I know the cause of the problem and I know my fairly expensive keyboard is not broken.

Thank you for all your help thus far.
Reply
#12
You're welcome. This problem is so weird, that it makes me curious to find what might be causing it Wink
Another thing interesting to know would be if the = starts working again after you close the Sensors window, but have the main HWiNFO window open (so HWiNFO is still running). This assumes you don't use the "Sensors-only" option.
Reply
#13
(03-09-2014, 11:19 PM)Martin Wrote: You're welcome. This problem is so weird, that it makes me curious to find what might be causing it Wink
Another thing interesting to know would be if the = starts working again after you close the Sensors window, but have the main HWiNFO window open (so HWiNFO is still running). This assumes you don't use the "Sensors-only" option.

= does start working immediately after closing only the sensors window.
Reply
#14
I think I know what's the problem Smile
I believe you have (maybe accidentally) activated the Automatic logging via hot key function and used the = key as the hot key.
Please check the respective setting in HWiNFO and if enabled, disable it Wink
Reply
#15
(03-10-2014, 09:32 AM)Martin Wrote: I think I know what's the problem Smile
I believe you have (maybe accidentally) activated the Automatic logging via hot key function and used the = key as the hot key.
Please check the respective setting in HWiNFO and if enabled, disable it Wink

I don't recall changing any key bindings, but I will certainly check it out. It didn't put the logs on my desktop until I upgraded to the beta version. I'll let you know after I get home this evening.
Reply
#16
Spot on sir. Automatic logging was enabled and = was bound to it.

Thank you very much for your sagely advice 8)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)