Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved HWiNFO64 and MSI GX60 3BE 8970M
#1
Dear Friends

I use HWiNFO64 4.36 and I have also checked HWiNFO64 4.37.2165. I have got a problem with my MSI GX60 3BE with AMD Radeon HD 8970M and 8650G. When I have enabled option "Wake disabled GPUs", my 8970M starts with Sensor Status, but not goes back into off state. As far as I know 4.16 and later version should correct this problem, but it doesn't.

Quote:HWiNFO 32/64 v4.16 and later implement a method which wakes up the disabled DGPU during launch, then the DGPU goes back into off state, so HWiNFO will not report its parameters until another application wakes up the GPU. This behavior is intentional to save power and not influence the GPU's desired state.

Any solution, because I don't want my 8970M will be always on, even when I don't use it. I would like to monitor it, so I have checked option "Wake disabled GPUs", but it doesn't go sleep after waking.

Best regards.

Sincerely
Reply
#2
If you have the "Wake disabled GPUs" disabled, does HWiNFO recognize the GPU ?
It seems that the issue you're experiencing might be caused by drivers which don't put the GPU back into disabled state. You might try to update the Catalyst drivers to see if that maybe helps.
Also, it would be helpful for me if you'd attach the HWiNFO Debug Files for both situations - with "Wake disabled GPUs" disabled and enabled. Then I could check more precisely why that happens.
Reply
#3
Dear Martin

(04-19-2014, 08:52 AM)Martin Wrote: If you have the "Wake disabled GPUs" disabled, does HWiNFO recognize the GPU ?

No, in such case HWiNFO64 recognize only integrated GPU, which is 8650G.

(04-19-2014, 08:52 AM)Martin Wrote: It seems that the issue you're experiencing might be caused by drivers which don't put the GPU back into disabled state. You might try to update the Catalyst drivers to see if that maybe helps.

I have got fresh Windows 7 installation and Enduro from Catalyst Control Center works very well for other application without any problems at all. I have got the newest possible drivers 13.12 and I have also tested HWiNFO64 4.36 and the newest beta version as well with the same result, the GPU 8970M is monitored, but not going back to off state. I have even tried to create profile in Catalyst Control Center for HWiNFO64.exe file, to be using 8650G, but with the same result as your HWiNFO64 was overriding this settings when launched. When I close HWiNFO64 my 8970M goes back to off state without problem.

(04-19-2014, 08:52 AM)Martin Wrote: Also, it would be helpful for me if you'd attach the HWiNFO Debug Files for both situations - with "Wake disabled GPUs" disabled and enabled. Then I could check more precisely why that happens.

No problem, please give me some time and I will attach those files.

So here you are two debug files:
- 1_HWiNFO64.dbg - Wake disabled GPUs (disabled)
- 2_HWiNFO64.dbg - Wake disabled GPUs (enabled)

PS. I'm registered user, but I cannot add signature and define it, there is no such form to enter my signature in the User CP.

Best regards.

Sincerely


Attached Files
.dbg   1_HWiNFO64.DBG (Size: 459.22 KB / Downloads: 3)
.dbg   2_HWiNFO64.DBG (Size: 470.37 KB / Downloads: 2)
Reply
#4
Thanks for the data, I analyzed them.
It's strange, that the 8970M reports a 99% utilization. Was the GPU idle when you had HWiNFO running during that test ?

Please perform the following test:
If you use the Sensor-only mode in HWiNFO, please disable it and run HWiNFO. The main HWiNFO window (with a tree on the left side) will open. If the System Summary window pops-up as well, then close it. Now, only the main window should be visible. Please wait a while and tell me if the 8970M is in off state. Then open the sensors window (using the Sensors button in the menu), wait a while and close it, so you'll again see the main window only. Is now the 8970M in off state ?

Regarding forum signature - you need to have at least 3 posts in order to have a signature. This is an anti-spam countermeasure. When you reply to this post, you'll have 3 posts, so you should be able to create it Wink
Reply
#5
Dear Martin

(04-19-2014, 08:53 PM)Martin Wrote: Thanks for the data, I analyzed them.
It's strange, that the 8970M reports a 99% utilization. Was the GPU idle when you had HWiNFO running during that test ?

Yes, I have rebooted my OS before the test, nothing else was active during test.

(04-19-2014, 08:53 PM)Martin Wrote: Please perform the following test:
If you use the Sensor-only mode in HWiNFO, please disable it and run HWiNFO. The main HWiNFO window (with a tree on the left side) will open. If the System Summary window pops-up as well, then close it. Now, only the main window should be visible. Please wait a while and tell me if the 8970M is in off state.

Checked and no success to this point. Still using 8970M.

(04-19-2014, 08:53 PM)Martin Wrote: Then open the sensors window (using the Sensors button in the menu), wait a while and close it, so you'll again see the main window only. Is now the 8970M in off state ?

Done and no off state mode, still the same result.

I have installed Catalyst Control Center 14.3 beta, to check if it's the problem with the newest 13.12 drivers, but with no success with HWiNFO64. But my games now run a little bit better with greater FPS. I have tried every possible solution with HWiNFO64 and always 8970M are not going off state. I have GPU-Z, MSI Afterburner, CPU-Z none of this applications have the same problem, but maybe there are meant to be for other purpose. Any idea Martin?

(04-19-2014, 08:53 PM)Martin Wrote: Regarding forum signature - you need to have at least 3 posts in order to have a signature. This is an anti-spam countermeasure. When you reply to this post, you'll have 3 posts, so you should be able to create it Wink

I understand Smile OK, thank you for your information. Third post and no sign of form to enter my signature Smile

Best regards.

Sincerely
Reply
#6
Thanks for the results.. That's interesting, since it means, that the polling of GPU by HWiNFO (sensors or summary) doesn't cause the GPU to stay active.
When the "Wake disabled GPUs" option is enabled in HWiNFO, it performs a short OpenCL sequence during the start, which causes the GPU to wake up. But it immediately closes the OpenCL instance and should put the GPU back into off state. This normally works for a lot of AMD GPUs, I don't know why it doesn't for yours. The behavior however indicates, this is a problem of the AMD drivers.
You might also try the following. Start HWiNFO again, so that only the main window is active (no summary, no sensors). In this mode, HWiNFO doesn't communicate with any hardware. Then launch another tool (or CCC) and check the GPU usage. What does it report ?

Please check again your User CP / Profile if you see the option to specify a signature.
Reply
#7
Dear Martin

(04-19-2014, 10:46 PM)Martin Wrote: Thanks for the results.. That's interesting, since it means, that the polling of GPU by HWiNFO (sensors or summary) doesn't cause the GPU to stay active.
When the "Wake disabled GPUs" option is enabled in HWiNFO, it performs a short OpenCL sequence during the start, which causes the GPU to wake up. But it immediately closes the OpenCL instance and should put the GPU back into off state.

Yes, I realize how it should work.

(04-19-2014, 10:46 PM)Martin Wrote: This normally works for a lot of AMD GPUs, I don't know why it doesn't for yours. The behavior however indicates, this is a problem of the AMD drivers.

Yes and that is the reason I have updated to 14.3 beta to check if it's a problem with drivers, but the result is the same.

(04-19-2014, 10:46 PM)Martin Wrote: You might also try the following. Start HWiNFO again, so that only the main window is active (no summary, no sensors). In this mode, HWiNFO doesn't communicate with any hardware. Then launch another tool (or CCC) and check the GPU usage. What does it report ?

When I launch HWiNFO64 and it shows a little window "Welcome" with options Sensors-only and Summary-only, Run and Settings button, my 8970M is off state mode. When I click Run or check Sensors-only or Summary-only and click Run my 8970M automaticaly is enabled but will not go to off state mode after that.

(04-19-2014, 10:46 PM)Martin Wrote: Please check again your User CP / Profile if you see the option to specify a signature.

I don't see any place in my User CP to enter signature, may you provide me with the direct link? Maybe I don't know, where to look.

Best regards.

Sincerely
Reply
#8
Sorry, when I asked for the latest test, I meant to check using other tools (i.e. CCC) what GPU usage (in %) they report for the 8970M after you launch HWiNFO and only the main window (with tree) is shown.

If you click User CP, then on the left side you see "Your Profile", at the bottom of this list, you should see "Change Signature". The link is: http://www.hwinfo.com/forum/usercp.php?action=editsig
Reply
#9
Dear Martin

(04-19-2014, 11:20 PM)Martin Wrote: Sorry, when I asked for the latest test, I meant to check using other tools (i.e. CCC) what GPU usage (in %) they report for the 8970M after you launch HWiNFO and only the main window (with tree) is shown.

Hmm, GPU-Z shows 0% load for 8970M, when Catalyst Control Center shows that Enduro switch to high performance GPU for HWiNFO64 and power led indicate that 8970M is working as well. Strange.

(04-19-2014, 11:20 PM)Martin Wrote: If you click User CP, then on the left side you see "Your Profile", at the bottom of this list, you should see "Change Signature". The link is: http://www.hwinfo.com/forum/usercp.php?action=editsig

Yes, now I see such option in my User CP. Thank you.

Best regards.

Sincerely
Reply
#10
I'm trying some workaround, please try this build: http://www.hwinfo.com/beta/hw64_437_2173.zip
and let me know if you see a difference.
Also, please attach a new Debug File from this build as well.
Reply
#11
Dear Martin

Happy Easter! Smile

(04-20-2014, 08:24 AM)Martin Wrote: I'm trying some workaround, please try this build: http://www.hwinfo.com/beta/hw64_437_2173.zip
and let me know if you see a difference.
Also, please attach a new Debug File from this build as well.

Please check attached files:
- 1_HWiNFO64.DBG - Wake disabled GPUs (disabled)
- 2_HWiNFO64.DBG - Wake disabled GPUs (enabled)

Sincerely


Attached Files
.dbg   1_HWiNFO64.DBG (Size: 345.08 KB / Downloads: 1)
.dbg   2_HWiNFO64.DBG (Size: 350.95 KB / Downloads: 1)
Reply
#12
Happy Easter too Wink

No change in this build, still the GPU is not going to off ?
Reply
#13
Dear Martin

(04-20-2014, 03:51 PM)Martin Wrote: Happy Easter too Wink

Thank you very much.

(04-20-2014, 03:51 PM)Martin Wrote: No change in this build, still the GPU is not going to off ?

Nope, sorry... Sad

Sincerely
Reply
#14
Then I'm afraid there's not much I can do about that Sad
It seems the AMD drivers keep the GPU enabled even after the OpenCL has been closed.. Maybe there's something still kept until the launching process (HWiNFO) is terminated.
Reply
#15
Dear Martin

(04-20-2014, 05:18 PM)Martin Wrote: Then I'm afraid there's not much I can do about that Sad
It seems the AMD drivers keep the GPU enabled even after the OpenCL has been closed.. Maybe there's something still kept until the launching process (HWiNFO) is terminated.

I understand, anyway thank you very much for your time and support, maybe you will find a solution in the future, how to workaround it. Maybe not today or tomorrow, but you will find, I wish you that.

Thank you once more.

Best regards.

Sincerely
Reply
#16
You're welcome. Thanks too for the testing you have done.
I'll keep looking for a solution, maybe AMD fixes this in their drivers meanwhile...
Reply
#17
Dear Martin

(04-20-2014, 08:17 PM)Martin Wrote: You're welcome. Thanks too for the testing you have done.
I'll keep looking for a solution, maybe AMD fixes this in their drivers meanwhile...

New AMD Catalyst 14.4 RC 1.0 installed and 99% usage of 8970M during HWiNFO64. I have debug files for you as always.

- 1_HWiNFO64.DBG - Wake disabled GPUs (disabled)
- 2_HWiNFO64.DBG - Wake disabled GPUs (enabled)

Maybe this is the right time for a workaround and solution? Smile

AMD Catalyst 14.4 WHQL will be available after 1-2 weeks.

Best regards.

Sincerely


Attached Files
.dbg   1_HWiNFO64.DBG (Size: 347.52 KB / Downloads: 1)
.dbg   2_HWiNFO64.DBG (Size: 353.28 KB / Downloads: 1)
Reply
#18
Hm, that's interesting.. Was that high usage measured when you had the Sensors or System Summary window open, or just the main window (with the tree).
I'd be interested to know the usage when both Sensors and System Summary and not open.
Reply
#19
Dear Martin

(04-22-2014, 06:55 AM)Martin Wrote: Hm, that's interesting.. Was that high usage measured when you had the Sensors or System Summary window open, or just the main window (with the tree).
I'd be interested to know the usage when both Sensors and System Summary and not open.

I don't have a good informations, because in HWiNFO64 4.37.2173 we have:
- Sensors Only - Load 99% of AMD 8970M
- Summary Only - Load 99% of AMD 8970M
- Main Window Only (with tree on the left) - Load 99% of AMD 8970M
- Everything - Load 99% of AMD 8970M

Best regards.

Sincerely
Reply
#20
If there's 99% load and HWiNFO has only the main window open (no sensors, no summary active), then this is definitively a bug in the AMD drivers.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)