Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[solved]  HWiNFOMonitor Gadget will not work (but Rainmeter OK)
#1
I've tried Rainmeter and HWInfo Monitor Gadget, and appreciate both of them. Rainmeter is much more flexible and you can create far more satisfyingly beautiful displays with it, but I find that tweaking it is pretty time consuming and it takes longer to achieve a nice effect. 

And so, I still like the old school Gadget, and still run it on my main Windows 10 Workstation

Below is what it looks like when Idle. CPU will go up to 4.8Ghz @ 1.2Vcore, tops out around 76 Watts, which is pretty modest. It's much more efficient than my other box...
[Image: lb0ywQh.jpg]

I also have a Server box that I want to monitor Temps and CPU utilisation on, and set about setting up something similar. The box runs the Desktop-Experience variant of Server 2019 (I might otherwise have used Server Core but there are still just a handful of things I want to keep that GUI for, and it's got plenty of spare resources)

It's older hardware, but still has good support in HWInfo; a Tyan S7012 with Twin Quad Core Xeon L5630, for a total of 8 Cores, 16 Threads, at around 2.3Ghz. Less overall performance than the i7 and draws more Power both when idle, and under load. Still a decent old workhorse, plus it's loaded with 18 (yes, 18) lots of 4GB ECC RAM (because DDR3 ECC is cheap and board has 18 slots) so it has its uses.

Anyway, back to the point; I cannot get the gadget to work properly on this server. Shared Memory is enabled, Sensors are running. I have Rainmeter+ModernGadgets running and it can read the sensors just fine so long as I don't untick shared memory or close Sensors instead of minimising, so I know that the shared mem stuff is working, and can break/fix this easily at will.

I'd rather use the Gadget if I can. I prefer my way around the config (when it works)


But the HWInfo Gadget, won't detect HWInfo running at all. It's behaving as if I had not enabled Shared Mem / Not running Sensors, even though I know I am as Rainmeter's talking to it OK.

[Image: gpuXIZC.jpg]


Does anyone have any idea why Gadget might be failing here? Is there something about Sever 2019 that might handle access tot he shared mem differently, in some way? I just can't work it out.

Any other ideas?
Reply
#2
Well, really not sure why it happens, but it's quite possible that Server 2019 has some additional security restriction.
The first idea that came to my mind was whether you launch the monitor as Administrator.
Reply
#3
(02-22-2019, 10:57 PM)Martin Wrote: Well, really not sure why it happens, but it's quite possible that Server 2019 has some additional security restriction.
The first idea that came to my mind was whether you launch the monitor as Administrator.

Although I wouldn't normally and don't really intend to keep using it that way if possible, I am actually currently logged in as the Local Administrator, and HWiNFO is running as that user. HWiNFO64.exe, HWiNFOMonitor.exe, rainmeter.exe and sidebar.exe are all running as the Local Administrator account. So that probably won't be it ?


I had another thought; the Network sharing feature. I've not tried this before but set it up, got Workstation's HWiNFO connected to the Xeon Server's HWiNFO (after enabling it it in the Windows Firewall) and so now the Sensors list in HWiNFO on the workstation shows the sensors on the server too.

But in the Gadget on the Workstation, it too cannot see the sensors on the server (although perhaps that's normal).


And likewise the other way around Xeon Server can connect to the i7 Workstation and see its' sensors in HWiNFO's sensors' list but the Gadget still can't connect;
"Error - HWiNFO Hardware Monitor Data not found"


I feel like this must be an error with HWiNFOMonitor.exe ?
Reply
#4
Running under a local Admin account doesn't mean the UAC is triggered as long as it's not requested by application.
Try to execute the HWiNFOMonitor by Right-click and Run as Administrator.
Reply
#5
Yeah...that's got it - Thank you. I had set the .exe to "Run as Administrator" and relaunched several times and nothing but the right-click "Run as Administrator" option sparked the thing to life.

Thank you for your quick help with this, Martin.
Reply
#6
Great Smile Glad that it's solved.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)