Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved HWinfo64 blocks Truecrypt to mount a device.
#1
Hi there.

as first sorry for my english. :-)

Since few weeks i have the problem that the HWiFO process blocks truecrypt so i cannot mount a HDD. If i kill the process in the task manager (or close the programm) i cann mount a truecrypt encrypted HDD.
Please see below for the error from truecrypt while HFinfo process is running an i try to mount a HDD
and the settings of my HWinfo.
Also in the "Sensor" settings i have disabled monitoring for all HDD

Please let me know what i can do in this case.

Best regards
Roman


Attached Files Thumbnail(s)
                   
Reply
#2
Hmm, this is an interesting problem. I'm too using TrueCrypt and haven't seen any problems with that.
Are you running HWiNFO in Sensor-only mode ?
Is there some sensor which when disabled will allow to mount the drive ?
Also, attaching the HWiNFO Debug File might shed more light on issue...
Reply
#3
Hi there
thanks for your answer

I run it "sensors only" and i only monitoring sensors for CPU,GPU,Fans and voltages
sensors.jpg

there is a copy of my debug file
HWiNFO64_2.DBG
Reply
#4
Thanks for the additional information.
Which drive are you trying to mount, your primary hard disk primary partition ?
From which drive do you run HWiNFO ?
Reply
#5
HWinfo is running with admin rights (installed 4.38-2200) from system windows drive C: and the drive which i try to mount (if HWinfO is already running) is a secondary drive Z: with backups, movies, mp3 and so on...
and also physically it is another drive (C: is a SSD and Z: an normal HDD)

btw: i´m a lazy guy and HWinfo is running at windows autostart and i don´t want to close every time this tool to mount my drive Z: ;-)
Reply
#6
Thanks. I have an idea what might be causing that..
I'll try to fix this in the next version, which will be released soon Wink
Reply
#7
Hello Martin
thanks for your help.
i will try the next version ;-)

beste regards
Roman
Reply
#8
v 4.40 has been released. Please let me know the result.
Reply
#9
hello Martin

it seems to work *thumbsup*
thanks for your great support.

best regards
Roman
Reply
#10
Thanks for the feedback Smile
Reply
#11
oh god YES!!!!!!! finally i can use sensor mode again without having to exit hwinfo to mount a drive , this was a fix that needed to be done ever since the last 6 updates , 4.4 ftw! , thanks


btw maybe you could tell us how exactly youve fixed this , since id like to know how this ever was introduced in the first place since i remember a couple versions back that this bug didnt exist
Reply
#12
If you would report this issue earlier, the fix could already be done Wink
The issue was that HWiNFO was holding a handle to a disk for the disk activity sensor during the whole runtime. Even though I opened the disk with sharing enabled, it didn't work somehow with TC. Now I open the disk handle everytime the sensor is reading disk activity data and then close it again.
Reply
#13
yeah well now i know when ever i have an issue again xD , again thanks alot for this much needed fix and the explanation on the bug , helped alot , keep up the great work , lovin hwinfo
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)