Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved How to use Windows Task Scheduler for Auto Start HWiNFO
#1
Information 
Every Time i install HWiNFO on another Computer, i need to figure out how to start HWiNFO via Windows Taskscheduler 'cause Autostart doesn't work. So i did some research and created this.
Please, add this to HWiNFO, maybe as a hint in the Readme, Batch File or (yay!) as a button in HWiNFO itself with automatic path-to-exe.

tl;dr:

copy-paste schtasks /create /SC ONLOGON /TN "HW-Info Autostart" /TR "'C:\Program Files\HWiNFO64\HWiNFO64.exe'" /RL HIGHEST into Command Prompt with Admin Privilegues, enjoy!

Longer Description:
select and copy above string, click Windows-Button, then "cmd", rightclick run as Admin, rightclick anywhere in the dark field, paste, Enter. Now you just added HWInfo in Windows Taskplaner. Of course you should have been installed HWiNFO64 to default path. For HWiNFO32, use this instead:
schtasks /create /SC ONLOGON /TN "HW-Info Autostart" /TR "'C:\Program Files (x86)\HWiNFO64\HWiNFO32.exe'" /RL HIGHEST

I tested this Procedure on Windows 7 64-Bit, but it should work at Vista and Windows 8 too.

Have fun, burninghey
Reply
#2
Thanks for the hint, I'll add this into HWiNFO in the next build released. It will be done automatically using the "Auto Start" option.
And by the way - rude behavior is not tolerated here, so I have edited your post and removed certain phrases. You have been warned.
Reply
#3
Thank you, Martin!
Reply
#4
The new Beta Build 1963 released has this feature implemented. Please check if it works properly...
Reply
#5
It works, even if de-zipped to a random location.

Then I tried to relocate the hwinfo.exe to another place, but the auto start option didnt recognize that. Thus i'm not sure what happens, if the User tries to update to a newer version, and the path changes. it is possible to check with schtasks if a task exists and to change the path, but it asks for User Password.
Unchecking the Auto Start Checkbox deleted HWiNFO from task scheduler. After Re-checking the Auto-Start Option, it didnt work anymore. after several resets i discovered that the path in task scheduler was wrong (without "").
After unchecking Auto-Start, quit HWiNFO, start HWiNFO, check Auto-Start again, it worked as it should.
Reply
#6
Yes, when relocating HWiNFO it's required that the Auto Start function be disabled/enabled again to make it work with the new path.
Unfortunately I don't know how to properly query the status of schtasks from other program (to parse and examine the output), so this will remain as is until a better solution is found. Anyway, I believe such situation doesn't happen often.
The problem with path without the "" will need to be checked. Can you please post more details about this - original path and the invalid one placed in Task Scheduler ?
Reply
#7
(07-04-2013, 07:04 AM)Martin Wrote: The problem with path without the "" will need to be checked. Can you please post more details about this - original path and the invalid one placed in Task Scheduler ?

It seems you have missed the little '
/TR "C:\Program Files\HWiNFO64\HWiNFO64.exe"
will make an entry like this: path: C:\Program argument: Files\HWiNFO64\HWiNFO64.exe

If using
/TR "'C:\Program Files\HWiNFO64\HWiNFO64.exe'"
it creates path: "C:\Program Files\HWiNFO64\HWiNFO64.exe"

However, when watching the "actions" tab from HWiNFO Task at taskscheduler, details does not show which of the two possibilites are given until trying to edit.
Reply
#8
Thanks, you're right. I haven't noticed this. I'll update it...
Reply
#9
Let me know if you need a new build with fix urgently (sooner than the next beta is released). I can give you such...
Reply
#10
Nah, i can wait for next beta Smile thanks for the offer, mate
Reply
#11
You might check this build if it's ok now: http://www.hwinfo.com/beta/hw64_421_1964.zip
Please let me know...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)