Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved Incorrect GPU clock for AMD Radeon R9 290
#1
Hello.

I'm using HWiNFO64 4.27-2035 and sensors show incorrect GPU frequency.
The card is idling at 300MHz (shown in CCC, GPU-Z, Afterburner) but HWiNFO is showing 825MHz.

Here is screenshot (with GPU-Z for comparison):
   


Attached Files
.zip   HWiNFO64_DBG.zip (Size: 88.88 KB / Downloads: 2)
Reply
#2
Thanks for the report. I'll try to fix this in the next build released.
Reply
#3
This should be fixed in the new v4.27-2040 Beta released a while ago.
Please let me know if it's OK now.
Reply
#4
Thank you. Now it shows proper values.

I have few more issues related to HWiNFO and my 290, if you are interested.
It takes about 17s to detect sensors (Sensors button). Most of time it displays:

Detecting sensors ...
GPU ATI #29

(then #30 and #31)
With my old 5870 it was rather quick, just few seconds to display sensor values.

The other issue is some weird temperatures listed under GPU VRAM. See attached sshot:
   
They usually read 0.0, but there are random spikes over 100°C.
Reply
#5
The slow startup is mostly caused by scanning of additional GPU I2C devices (like the VRM sensors).
I think you might reduce the time by disabling the GPU I2C bus #7. Launch HWiNFO, press the Settings button, select the "SMBus / I2C" tab and in the "GPU I2C Bus Exclusion" part tick the box belonging to #7 (last one). That will disable scanning of this bus and might improve HWiNFO startup time.

As for the additional temperatures (Temp2 and Temp5), these seem to be bogus values coming from not connected sensor inputs. Moreover, they should belong to a different sensor (not the GPU VRM), but because they appear sporadically, they are not properly ordered.
In Sensors / Settings, go to the "Layout" tab and press the "Restore Original Order". That should order them correctly.
Reply
#6
Great Wink
Sensors now start in about 2 seconds.

About those weird temps. I've reset the layout and it temporarily fixed the issue. After some time they were back.

For now I've just disabled monitoring of them.
Reply
#7
Thanks for the feedback.

You might also completely remove those temperatures, so they don't disturb.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)