Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved NVidia optimus & newer versions of HWInfo.
#1
Greetings,
it looks like in version 4.16 you implemented NVidia optimus GPU discovery even when the GPU is disabled. Though it's great in many ways, this approach has one significant downside: it makes laptop to consume significantly more power (up to 6-12 W more) when running on battery; it polls discrete gpu every second and doesn't allow it to "sleep" properly. For example, hwinfo 4.10 (which doesn't "discover" optimus gpu when it's disabled) reports less than 12W power usage when laptop is idle & running on battery, and with hwinfo 4.16 that value doesn't drop below 22W. With some programs like Visual Studio running, power consumption with hwinfo 4.10 is ~16W, and with 4.16 ~26W, which is more than 1.5 times greater, and is unacceptable. (of course, the only difference is the version of hwinfo; all the programs running / devices connected are the same)
So, it would be great if you implement some kind of option which would disable that "forced" optimus gpu discovery.


Attached Files Thumbnail(s)
       

.htm   y570_optimus.HTM (Size: 140.53 KB / Downloads: 2)
.zip   HWiNFO32dbg.zip (Size: 63.26 KB / Downloads: 2)
Reply
#2
I understand your concerns, thus I can implement such an option. So if you would not allow HWiNFO to wake-up a GPU disabled by Optimus you would not be able to see any of its parameters, even when it's woken up by another application during HWiNFO run-time. You would need to start HWiNFO again. Would that be OK ?
Reply
#3
(04-25-2013, 04:34 PM)Martin Wrote: I understand your concerns, thus I can implement such an option. So if you would not allow HWiNFO to wake-up a GPU disabled by Optimus you would not be able to see any of its parameters, even when it's woken up by another application during HWiNFO run-time. You would need to start HWiNFO again. Would that be OK ?

Yes, I understand it, I'm used to it because older versions of the application behaved in exactly the same way and it's ok for me.
Reply
#4
OK. The next build will feature such option, which by default will be enabled.
Reply
#5
(04-25-2013, 04:39 PM)Sfairat Wrote:
(04-25-2013, 04:34 PM)Martin Wrote: I understand your concerns, thus I can implement such an option. So if you would not allow HWiNFO to wake-up a GPU disabled by Optimus you would not be able to see any of its parameters, even when it's woken up by another application during HWiNFO run-time. You would need to start HWiNFO again. Would that be OK ?

Yes, I understand it, I'm used to it because older versions of the application behaved in exactly the same way and it's ok for me.
Two comments. First, @Martin this is an absolutely indispensable product and I love it.

Second, @Sfairat I noticed on Sunday when I updated to v4.16 that my core temps increased by 10C. This is a Samsung NP700Z5C, by the way. In any case, I've also noticed the GPU polling (NVIDIA GT640m) and suspect that the increase in heat is another symptom -- as I've toggled HWiNFO64 on and off I can see the change in temperature. It's interesting that there's no correlated change in CPU activity, but the increase in heat is pretty apparent.

Thanks again to both of you. I think the "default-off" option is probably the best coice, though I also do imagine that some users will wonder "HEY where did my GPU go?!?!?!" I'm personally used to it not showing up by default, and typically run GPU-Z for that purpose.

-Matt
Reply
#6
Thanks for your feedback. I still think that the amount of users wondering "where is the Optimus GPU ?!" is larger than those who care about increased power consumption. There's probably no ideal solution, though the 10 C you have experienced is quite huge. So when you disable the new Optimus wake-up setting you no longer see such increase in core temperatures ?
Reply
#7
(05-03-2013, 07:55 PM)Martin Wrote: Thanks for your feedback. I still think that the amount of users wondering "where is the Optimus GPU ?!" is larger than those who care about increased power consumption. There's probably no ideal solution, though the 10 C you have experienced is quite huge. So when you disable the new Optimus wake-up setting you no longer see such increase in core temperatures ?

Forgive my ignorance but is the "disable" option in v4.16, or the v4.17 beta (which I haven't tried)?

(04-25-2013, 04:46 PM)Martin Wrote: OK. The next build will feature such option, which by default will be enabled.

EDIT: ah, I see, it must be the newer beta. Hmm, I've installed and don't see the option yet. Perhaps I'm not looking in the right place.
EDIT2: I've disabled monitoring of the GPU in the Sensor window, and see the same thing -- CPU drops from 65C to 55C.

-Matt
Reply
#8
Oh, I'm sorry, I haven't yet released a Beta with this feature..
Guess it's time for a new Beta release? Wink OK, give me few minutes Wink
Reply
#9
Build 1912 is released Wink
The new option is implemented there.
Reply
#10
(05-03-2013, 09:10 PM)Martin Wrote: Build 1912 is released Wink
The new option is implemented there.
Thanks Martin, it works perfectly. You've preserved my sanity -- I was about to wipe and reinstall Windows (I was sure the GPU was involved, somehow), and how ironic, one of the first utilities I would have reinstalled would be HWiNFO64. After a week of trouble-shooting I was at my wit's end.

Regarding whether the option should default to off or on: I'm a new member of the forum, so I don't know the history of the "Log all values for Report" option in the Sensor settings, but I have to confess that defaulting to "on" confused me at first -- but after digging through the interface I managed to discover the option. In the case of the "Wake GPU on/off" option, it's surely right there in plain sight. Maybe you should count the number of "Where is my GPU???" threads for a week and reevaluate!

Thanks again!

-Matt
Reply
#11
If you run HWiNFO in Sensor-only mode, then "Log all values for Report" option is set to OFF by default. It's ON only in standard mode, where I expected users to be interested in other information than monitoring as well and so they can store all values into the report file. In Sensor-only mode users are preferring only monitoring, so there's no need to keep all values in memory.
I'll listen to user feedback and if there's a larger demand for changing these options, I'll do that.
Reply
#12
I absolutely second the original post!

Martin, just to let you know, some other programs don't cause the nvidia cards that use optimus to run at full clock, for example, gpu-z: when I run it explicitly on nvidia, the clocks displayed are initially high (835 Mhz) and then drop to 135 Mhz. If I run it without telling which gpu to use, it runs on intel hd4000 by default and the clocks max out and hold, which heats the nvidia gpu up.

See the screenshots:

running on intel hd4000
[Image: running_on_hd4000.jpg]

running on nvidia gt650m
[Image: running_on_gt650.jpg]

I tried the same with hwinfo, but in both cases it would max out & hold.

If you'd hopefully manage to join the dots and figure out why is this the case, there'd be no need to implement the option Sfairat asked you to. If hwinfo would behave like gpu-z does, we (optimus users) would then just set the hwinfo to always run on nvidia gpu. Although it would require some kind of a warning on a download page.

Meanwhile I'm sticking to 417-1912 as well.
Reply
#13
Please try to disable the nvidia sensor values in HWiNFO one by one (right-click and "Disable Monitoring") to see if maybe one of those values is causing the GPU to run at full clock. In case you find such, please let me know which it is. Maybe then I can check if there's something to do...
Reply
#14
Martin, I've just tried, to no avail... Funny thing is that if I run gpu-z after hwinfo (both on nvidia), the frequencies would drop, then close gpu-z, and they jump up back again!
Reply
#15
I'll check this, but it will require some time to determine how to fix this. Moreover, I don't have a laptop with Optimus, so it's a bit hard to diagnose this remotely...
Reply
#16
(05-06-2013, 10:11 AM)Martin Wrote: I'll check this, but it will require some time to determine how to fix this. Moreover, I don't have a laptop with Optimus, so it's a bit hard to diagnose this remotely...

I'm happy to be a guinea pig too -- just let me know what I can do to help.

-Matt
Reply
#17
Matt,

I develop SIV and have been talking with Matrin about how to slove this. I have just uploaded SIV V4.37 Beta-39 which implements my solution.

Please will you try the SIV V4.36 release and confirm that has the same issue and then the Beta to see if it's resolved. To get the Beta release from SIV do Menu->File->Download->SIV Beta.

I expect that with the Beta just running SIV should leave the GPU offline, but the Menu->Hardware->GPU Info page will still foce it back on-line.

BTW how are you getting the power usage information please?

Regards, Ray
Reply
#18
(05-06-2013, 03:48 PM)red-ray Wrote: Matt,

I develop SIV and have been talking with Matrin about how to slove this. I have just uploaded SIV V4.37 Beta-39 which implements my solution.

Please will you try the SIV V4.36 release and confirm that has the same issue and then the Beta to see if it's resolved. To get the Beta release from SIV do Menu->File->Download->SIV Beta.

I expect that with the Beta just running SIV should leave the GPU offline, but the Menu->Hardware->GPU Info page will still foce it back on-line.

BTW how are you getting the power usage information please?

Regards, Ray

Ray, SIV is a BEAST! Wow, I'm really impressed with your work.

Running v4.36, and yep, I can confirm it's polling the GPU -- I see the NVIDIA system tray icon blinking on/off every second -- and I've now moved from 50C to 60C.

...gonna try the beta next...

OK, ran the beta and the NVIDIA tray icon stays off. Indeed, when I pulled up the GPU info (in SIV) the light turned on and remained on, and the CPU immediately climbed back up to 60C. Closing the GPU info window returned the GPU to the off state.

RE: your question about power usage, refer back up to the OP and his screen shots. In my case I've been reporting temps, but haven't looked at power consumption so far.

Thanks to both you and Martin!

-Matt
Reply
#19
OK, so here's a new build of HWiNFO64:
http://www.hwinfo.com/beta/hw64_417_1913.zip

Please run it in Sensor-only mode (since the Summary screen when active will probably still poll the GPU) and verify if the GPU switches back off. If you have the "Wake GPUs disabled..." option enabled, the GPU should wake for a short while during HWiNFO start (to recognize it) and then switch back to off state.
Ray, can you please check on your side too?
Reply
#20
(05-06-2013, 04:26 PM)Martin Wrote: OK, so here's a new build of HWiNFO64:
http://www.hwinfo.com/beta/hw64_417_1913.zip

Please run it in Sensor-only mode (since the Summary screen when active will probably still poll the GPU) and verify if the GPU switches back off. If you have the "Wake GPUs disabled..." option enabled, the GPU should wake for a short while during HWiNFO start (to recognize it) and then switch back to off state.
Ray, can you please check on your side too?

Thanks Martin -- I ran it "as is" (without configuring any options) in sensor-only mode and everything looks fine. The NVIDIA 640m shows up in the sensor list, but all the attributes have the RED x and the readings are listed as "-". Absolutely no indication that the GPU is being polled, other than during start-up as you noted.

-Matt
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)