Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved Sensor Module and Intel DZ77RE-75K MB
#1
Intel DZ77RE-75-K motherboard (newest firmware), i7 2600K CPU (not overclocked), GeForce GTX 660 Video Card, Windows 8 Pro 64bit and newest and beta version of HWiNFO64 (both portable versions).

This problem only happens when running the Sensor Module of HWiNFO, just running the summary modules do not cause any problems. I have tried 2 other programs, HWmonitor 64bit version and AIDA64 Extreme that show/monitor sensor information and they do not cause any problems.

The Intel motherboard has some Status LEDs at the bottom of the motherboard. Most of them remain on (green in color) once the system has booted. If I run the sensor module of HWiNFO (and most of the information it shows is correct), then exit the program and restart Windows (soft boot), when the computer restarts all of the Status LEDs go off and stay off even though the computer reboots fine and goes back into Windows. When rebooting the computer the Status LEDs should go off, but they should come back on. Now if I turn the off (cold or hard boot) then back on, the computer gives the 3 beeps (like a memory error), the POST reader that is one the motherboard shows 22 (which isn't even listed on the sheet of POST codes that came with the motherboard) and one of the Status LEDs shows that either the CPU overheated or the VR overheated (not sure which one). But the board has none of these problems. Only way to get the computer to come back on is to unplug the power supply from the wall socket (so the board can do a complete reset).

Best way I can describe it is that the Sensor Module of HWiNFO is some how scrambling the sensor chip on the motherboard.

Hope I explained it right and thanks for your time......


Attached Files
.htm   ZENMOTA.HTM (Size: 244.53 KB / Downloads: 2)
Reply
#2
Thanks for the report, this is really an interesting issue.
As first for a more detailed analysis, please attach the HWiNFO Debug File with sensor data. I can then see more details.

What comes to my mind in the 1st place is to try to disable SMBus support in HWiNFO. In this case you can loose some information displayed (like memory modules, sensors), but it's just to prove is SMBus accesses could be the cause of your problem.
If you prove that SMBus is causing it, then you can enable it back and go to the SMBus Device Exclusion list to find which exact address might cause this. You might try to select an entire line in the list and then see if a device on that line causes it. Then repeatedly you should be able to determine which address is causing it and leave it disabled - this shouldn't cause the loss of other SMBus-dependant information in HWiNFO. This way takes some time and might be speeded up by choosing larger chunks of addresses.
If SMBus is not a cause at all, then I'll have to see the Debug File and think about other ways...
Please let me know your results.
Reply
#3
(01-07-2013, 05:09 PM)Martin Wrote: Thanks for the report, this is really an interesting issue.
As first for a more detailed analysis, please attach the HWiNFO Debug File with sensor data. I can then see more details.

What comes to my mind in the 1st place is to try to disable SMBus support in HWiNFO. In this case you can loose some information displayed (like memory modules, sensors), but it's just to prove is SMBus accesses could be the cause of your problem.
If you prove that SMBus is causing it, then you can enable it back and go to the SMBus Device Exclusion list to find which exact address might cause this. You might try to select an entire line in the list and then see if a device on that line causes it. Then repeatedly you should be able to determine which address is causing it and leave it disabled - this shouldn't cause the loss of other SMBus-dependant information in HWiNFO. This way takes some time and might be speeded up by choosing larger chunks of addresses.
If SMBus is not a cause at all, then I'll have to see the Debug File and think about other ways...
Please let me know your results.

Disabling SMBus Support fixed the problem. Strange, but I seem to get just as much information and it is correct with SMBus disabled as I do with it enabled.

I have attached the debug file. I only ran the Sensor Module for debug.

I have also attached an image of the SMBus list just in case. Thank..


Attached Files Thumbnail(s)
   

.dbg   HWiNFO64.DBG (Size: 432.71 KB / Downloads: 3)
Reply
#4
So it seems a certain device on SMBus is causing the problem. In order to determine which, could you please try the procedure with SMBus Device Exclusion list ?
First enable SMBus support back.
Then for example start with the last line and check all boxes there. That means all devices with address 7x will not be accessed. Then run HWiNFO and check if the problem occurs. If not, proceed with next line. If yes, then enable boxes in half of the line that seems to cause the problem. So you should come to a result where only one certain box when checked is no longer causing the problem. This is then the problematic address and I can put this one into the exclusion list automatically to not cause problems on other such systems.
Reply
#5
(01-07-2013, 08:03 PM)Martin Wrote: So it seems a certain device on SMBus is causing the problem. In order to determine which, could you please try the procedure with SMBus Device Exclusion list ?
First enable SMBus support back.
Then for example start with the last line and check all boxes there. That means all devices with address 7x will not be accessed. Then run HWiNFO and check if the problem occurs. If not, proceed with next line. If yes, then enable boxes in half of the line that seems to cause the problem. So you should come to a result where only one certain box when checked is no longer causing the problem. This is then the problematic address and I can put this one into the exclusion list automatically to not cause problems on other such systems.

When I exclude SMBus address 0x60 that fixes the problem. I have also attached a picture of the exclusion list to make sure you see what I have excluded. If you need another debug file, let me know.

Thanks for the help in solving this problem and great program.....


Attached Files Thumbnail(s)
   
Reply
#6
Thanks for the feedback!
I'll add excluding this address by default for this mainboard, so there will be no need anymore to change settings.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)