Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved Unable to download - redirected
When I try to update my HWiNFO64, after I click download I get a page that wants to download an unzipper (which I don't need) or something for safe browsing (which I don't need, being well-protected) or MyPony (which is dubious and unwanted). How do I get a download without any unwanted stuff?

And shame on you for foisting this stuff.
You probably were confused by an advertisement and clicked that one. Some advertisers are too invasive.
Please check a bit below that Ad and you should see 2 buttons: "DOWNLOAD INSTALLER" (green) and "DOWNLOAD PORTABLE" (blue).
I am always very wary of inviting-looking download buttons and looked carefully before I clicked.

I was at
Under 64-bit, I clicked the green button labeled "Start Download free Version"
The URL of the button image is
The link URL of that button is this obvious redirection:

So how do I download the update? Can you give me a clean link, please?
You clicked on the Google Ad. I don't choose which ads are displayed there, I only offer space for them and the ads come thru Google network.
Just look below that and you'll see the two other buttons.
Here is a picture of the button I clicked.

Edit: The other two buttons are for DOWNLOAD INSTALLER and DOWNLOAD PORTABLE.
.. and those other two are the right ones.
I'm sorry for this confusion, but I don't feel guilty, since I don't choose which which Ads are displayed there.
Why would I want to download a DOWNLOAD INSTALLER? Specially since it is labeled Safe Browsing?

That has now changed to clearly mark advertisement - but it wasn't that way before.

I still don't understand why I should click DOWNLOAD INSTALLER, but will do so.

Be advised that Google keeps changing the layout of your page..
The text "BrowserSafeGuard" you posted belongs to the Ad. Google can change only their dedicated region, which is the space between the text above and the download buttons - this can be clearly seen on the second screenshot you posted.
The last screenshot is how it should look, certainly. But the other screenshots I posted were seen on previous screen refreshes..
Yes, I have configured the ad styles to have a border like on your last screenshot (so they are easier to distinguish), but it seems not all of them keep this rule.
I don't see any of those ads. Good reason to use Firefox with DoNotTrack & AdBlock Extensions.

Forum Jump:

Users browsing this thread: 1 Guest(s)