Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved Windows 8 RP & IRST v11.5 on Z77
#1
Question 
I realise that Windows 8 is not finalised and neither are the Intel Rapid Storage Technology Drivers but as I am unable to start HWINFO64 I thought it couldn't hurt to post my issue...

Getting a BSOD when HWiNFO attempts to scan my hard drives/controllers with the message;

Driver IRQL Not Less Or Equal (IAStorA.sys)

I am using the following;

IRST Option ROM v11.5.0.1347 (in my BIOS)
IRST Driver v11.5.0.1171 Beta is installed
ASRock Z77 Fatal1ty Pro Motherboard (C216 chipset)
4 x Intel X25-m G2 80GB SSD's in RAID0 (on the four Intel SATA-2 Ports)

I can't generate a report so I can only include the debug text file;

HWiNFO64_v3.96-1640_debug.rar

It seems that the new IRST mounts the drives as SCSI devices, HWiNFO stops scanning with;

Code:
[SCSI5] Get IntelRAID_ID(7) -

I can't seem to bypass the SATA controller detection in the settings. I tried various options but it always goes to a BSOD at the same point in the scanning process.

If you want more info (or if you are waiting for Windows 8 to go gold and don't wish to spend time on this) just let me know.
Reply
#2
Your assumption is almost correct. The Intel RST drivers had many bugs in the past, but Intel is aware of them and working on fixing them.
So I'd suggest to wait for a new version of RST..
Have you also tried to switch the IDE Drive Scan to Low-level IO mode ?
If that doesn't help, then I'll have to add an option to entirely disable the drive scan.
Reply
#3
(06-07-2012, 07:19 PM)Martin Wrote: Your assumption is almost correct. The Intel RST drivers had many bugs in the past, but Intel is aware of them and working on fixing them.
So I'd suggest to wait for a new version of RST..
Have you also tried to switch the IDE Drive Scan to Low-level IO mode ?
If that doesn't help, then I'll have to add an option to entirely disable the drive scan.

Hi Martin, I will sit tight and hope the Intel IRST bugs are ironed out soon. I tried the IDE Scan on Low-level IO only to get the same result.

If you could implement an option to disable the drive scan I would be very greatful (if you're busy with higher priority issues I understand completely), as I just wanted to monitor turbo boost on my CPU. Thankyou for your quick response.
Reply
#4
I have implemented the new option. Please get this build: http://www.hwinfo.com/beta/hw64_396_1661.zip
The Configure menu is a bit revamped from now on, so you can find that option in the second tab: Disable Drive Scan
I hope this workaround will allow you to run HWiNFO.
Reply
#5
Thumbs Up 
Thankyou so much!

I'm amazed at how quickly you implement changes and respond to people's concerns.

Thankyou also for your valuable time, I will make good use of the beta version Big Grin.

[Edit] Well it looks like the CPU overclocking and voltage/temp monitoring software that came with my motherboard (F-Stream) has implemented a new power plan (F-Stream Tuning) that keeps my CPU at full turbo all the time.

I thought something funny was going on - CPU-Z said the CPU was clocking down but HWiNFO confirmed that turbo was constantly on.

Changed power plan back to balanced and now my CPU has clocked down Smile.

Thanks again Martin - I would not have worked that out without HiNFO!
Reply
#6
In case of certain CPUs (Nehalem/Westmere mostly), the method HWiNFO uses to measure clock frequency can itself cause triggering of Turbo mode. This usually happens if your CPU is set to high performance mode, so it's very sensitive to load and triggers Turbo quickly.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)