Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved crucial mx500 TBW not accurate
#1
hello,

i have 2x crucial mx500 ssd (same exact model), but for 1 of them TBW is not accurate.
crucial's own tool (storage executive) shows accurate TBW.
looks like data for smart 0xF6 attribute is read or interpreted incorrectly.

oh and thank you for this wonderfual software Smile
regards


Attached Files Thumbnail(s)
           

.dbg   HWiNFO64.DBG (Size: 1.06 MB / Downloads: 2)
.htm   report.HTM (Size: 220.86 KB / Downloads: 4)
Reply
#2
remaining attachments


Attached Files Thumbnail(s)
       
Reply
#3
This looks like the drive doesn't properly report information via ATA Statistics standard and truncates the number of reported sectors written.
Try to disable "ATA Statistics Support" in HWiNFO if you'll get correct numbers then.
Reply
#4
(09-18-2018, 01:05 PM)Martin Wrote: This looks like the drive doesn't properly report information via ATA Statistics standard and truncates the number of reported sectors written.
Try to disable "ATA Statistics Support" in HWiNFO if you'll get correct numbers then.

if i disable that both "total host writes" and "total host reads" disappear from sensors window.
why do you think the drive truncates the data when manufacturer's tool can read correct value (screenshots)?
Reply
#5
The problem I described earlier is true, the difference is that HWiNFO relies primarily on ATA Statistics, which is a standard unlike SMART. And AFAIK all other tools rely on SMART.
I will add a workaround for this issue in the next Beta build.
Reply
#6
thank you for the explanation.
long shot: is it explained anywhere what is the difference between "smart support" and "ata statistics support" in hwinfo's behavior?
i assume ata statistics take precedence if a counter is supported by both APIs?
Reply
#7
Yes, ATA Statistics values take precedence. This is because it's completely standardized, unlike SMART.
Reply
#8
Please try new version 5.89-3515 Beta if it reports correct numbers now.
Reply
#9
(09-20-2018, 08:02 AM)Martin Wrote: Please try new version 5.89-3515 Beta if it reports correct numbers now.

yes, thank you kind sir, donated Smile
minor nitpick: total host reads disappeared for these drives (but are still visible for nvme boot drive)
Reply
#10
Thank you, also for the donation.
Try to activate ATA Statistics support again, that might show Total Host Reads.
Reply
#11
doesn't show, regardless of "ata statistics" setting
Reply
#12
Can you please attach a new screenshot of the sensors and ATA details window?
Reply
#13
is this what you needed?


Attached Files Thumbnail(s)
       
Reply
#14
Thanks, I think I found the bug Smile Shall be fixed in the next build.
Reply
#15
everything's good with beta 3520, thank you!
Reply
#16
Thanks for the feedback, happy to hear that all is well now Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)