Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved nVidia Optimus: Discrete GPU always enabled
#1
In the latest update (including the beta 2110) my nvidia discrete gpu is always enabled, it should be enabled only when needed (in my case only in some aplications that I chose) or just for a few seconds while hwinfo is initializing. I have "Wake disabled GPUs" set to true, but it is not turning off the gpu after the startup.

*It was working before the update.


Attached Files
.zip   HWiNFO64.zip (Size: 38.21 KB / Downloads: 1)
Reply
#2
That might be because I implemented another method to wake AMD GPUs during startup as well (via OpenCL) and it seems NVIDIA drivers keep the GPU enabled even after I close OpenCL. That seems to be a glitch in their drivers, but I'll try to implement a workaround for this in the next build.
Reply
#3
Please try the newly released Beta v4.33-2115. It should fix this issue.
Reply
#4
Working perfectly, thank you Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)