Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Support of RTSS - Displaying HWiNFO32 sensor values in Games
#41
(06-26-2017, 07:50 PM)Martin Wrote:
(06-26-2017, 04:09 PM)kevindd992002 Wrote:
(06-26-2017, 03:43 PM)Martin Wrote: "Sensors-only" and "Summary-only" settings are kept in the INI file.

Ok. Any comment on the RTSS show own statistics setting?

This is a RTSS setting, not HWiNFO. If enabled it shows own stats like FPS counter in OSD.

I get that but I was asking about its compatibility with your program. What if it is enabled and then you still display the RTSS monitor in HWiNFO? Wouldn't they conflict with each other?
Reply
#42
No, they won't conflict.
Reply
#43
Ok. Have you tried using Ctrl- for the hotkey and see if it is also problematic?
Reply
#44
(06-27-2017, 06:22 PM)kevindd992002 Wrote: Ok. Have you tried using Ctrl- for the hotkey and see if it is also problematic?

Ctrl works for me, is it possible that your combination was already assigned to another action ?
Reply
#45
FYI - v5.53-3190 Beta just released should fix the hot key combinations and also adds support of new RTSS features like custom colors (RTSS v2.11 or later) and graphs (RTSS v2.12 or later).
Reply
#46
(06-27-2017, 08:08 PM)Martin Wrote:
(06-27-2017, 06:22 PM)kevindd992002 Wrote: Ok. Have you tried using Ctrl- for the hotkey and see if it is also problematic?

Ctrl works for me, is it possible that your combination was already assigned to another action ?

Hmm, that's a possibility. I can try other combinations and report back.

(06-28-2017, 10:05 AM)Martin Wrote: FYI - v5.53-3190 Beta just released should fix the hot key combinations and also adds support of new RTSS features like custom colors (RTSS v2.11 or later) and graphs (RTSS v2.12 or later).

Are those RTSS versions recent? The one I have now is 7.0 Beta 19 and that version is far from 2.12.

And by the way, what do we lose if we don't install the HWiNFO driver? Why isn't it being installed by default in the first place?
Reply
#47
Sorry, what I mentioned are RTSS internal structure versions.
So for custom colors you need RTSS 7.0.0 and for graphs you need RTSS 7.0.0 beta 24 (http://forums.guru3d.com/showpost.php?p=...tcount=474)
I will update this in release notes.
Reply
#48
(06-28-2017, 10:31 AM)Martin Wrote: Sorry, what I mentioned are RTSS internal structure versions.
So for custom colors you need RTSS 7.0.0 and for graphs you need RTSS 7.0.0 beta 24 (http://forums.guru3d.com/showpost.php?p=...tcount=474)
I will update this in release notes.

Ok. With the portable BETA, when I choose Auto startup it does create a scheduled task but still references the executable file to the default "install" folder of C:\Program Files\hwinfo64\ . Is this normal behavior? Why doesn't it create a scheduled task that points to wherever the exe is placed if it is portable?
Reply
#49
Hey Martin, i use Hwinfo to add disk read/write activity monitoring to RTSS in game. My problem than Hwinfo digits dont keep fixed, it create new digit space when reader increase from 1 digit to 2 digit, and that keep causing the layout OSD from RTSS to change position in horizontal space. Is there a way to keep the total digit spaces alignned to avoid this motion in OSD?

The size of MB/s is too big too in OSD, can Hwinfo text be changed to small text like new RTSS mhz, mb, °c etc?
Reply
#50
(06-28-2017, 09:14 PM)chumanga Wrote: Hey Martin, i use Hwinfo to add disk read/write activity monitoring to RTSS in game. My problem than Hwinfo digits dont keep fixed, it create new digit space when reader increase from 1 digit to 2 digit, and that keep causing the layout OSD from RTSS to change position in horizontal space. Is there a way to keep the total digit spaces alignned to avoid this motion in OSD?

The size of MB/s is too big too in OSD, can Hwinfo text be changed to small text like new RTSS mhz, mb, °c etc?

Yes, use the "Align number" option.
Reply
#51
(06-28-2017, 09:21 PM)Martin Wrote:
(06-28-2017, 09:14 PM)chumanga Wrote: Hey Martin, i use Hwinfo to add disk read/write activity monitoring to RTSS in game. My problem than Hwinfo digits dont keep fixed, it create new digit space when reader increase from 1 digit to 2 digit, and that keep causing the layout OSD from RTSS to change position in horizontal space. Is there a way to keep the total digit spaces alignned to avoid this motion in OSD?

The size of MB/s is too big too in OSD, can Hwinfo text be changed to small text like new RTSS mhz, mb, °c etc?

Yes, use the "Align number" option.

It dont work, take a look: https://youtu.be/vwVzzCaOFSQ
Reply
#52
(06-28-2017, 11:40 AM)kevindd992002 Wrote:
(06-28-2017, 10:31 AM)Martin Wrote: Sorry, what I mentioned are RTSS internal structure versions.
So for custom colors you need RTSS 7.0.0 and for graphs you need RTSS 7.0.0 beta 24 (http://forums.guru3d.com/showpost.php?p=...tcount=474)
I will update this in release notes.

Ok. With the portable BETA, when I choose Auto startup it does create a scheduled task but still references the executable file to the default "install" folder of C:\Program Files\hwinfo64\ . Is this normal behavior? Why doesn't it create a scheduled task that points to wherever the exe is placed if it is portable?

Bump!
Reply
#53
(06-28-2017, 11:40 AM)kevindd992002 Wrote:
(06-28-2017, 10:31 AM)Martin Wrote: Sorry, what I mentioned are RTSS internal structure versions.
So for custom colors you need RTSS 7.0.0 and for graphs you need RTSS 7.0.0 beta 24 (http://forums.guru3d.com/showpost.php?p=...tcount=474)
I will update this in release notes.

Ok. With the portable BETA, when I choose Auto startup it does create a scheduled task but still references the executable file to the default "install" folder of C:\Program Files\hwinfo64\ . Is this normal behavior? Why doesn't it create a scheduled task that points to wherever the exe is placed if it is portable?

This might be a remain of the setting done by the installer version. Try to disable Auto-start, click OK and then enable it again with the portable version.
Reply
#54
(06-29-2017, 06:55 AM)Martin Wrote:
(06-28-2017, 11:40 AM)kevindd992002 Wrote:
(06-28-2017, 10:31 AM)Martin Wrote: Sorry, what I mentioned are RTSS internal structure versions.
So for custom colors you need RTSS 7.0.0 and for graphs you need RTSS 7.0.0 beta 24 (http://forums.guru3d.com/showpost.php?p=...tcount=474)
I will update this in release notes.

Ok. With the portable BETA, when I choose Auto startup it does create a scheduled task but still references the executable file to the default "install" folder of C:\Program Files\hwinfo64\ . Is this normal behavior? Why doesn't it create a scheduled task that points to wherever the exe is placed if it is portable?

This might be a remain of the setting done by the installer version. Try to disable Auto-start, click OK and then enable it again with the portable version.

Ok. I manually changed the path of the scheduled task but I'll see if I can test this more. The portable version is designed to change the path accordingly, right?
Reply
#55
(06-28-2017, 10:48 PM)chumanga Wrote:
(06-28-2017, 09:21 PM)Martin Wrote:
(06-28-2017, 09:14 PM)chumanga Wrote: Hey Martin, i use Hwinfo to add disk read/write activity monitoring to RTSS in game. My problem than Hwinfo digits dont keep fixed, it create new digit space when reader increase from 1 digit to 2 digit, and that keep causing the layout OSD from RTSS to change position in horizontal space. Is there a way to keep the total digit spaces alignned to avoid this motion in OSD?

The size of MB/s is too big too in OSD, can Hwinfo text be changed to small text like new RTSS mhz, mb, °c etc?

Yes, use the "Align number" option.

It dont work, take a look: https://youtu.be/vwVzzCaOFSQ

I will improve the alignment setting in the next build, so you will be able to precisely specify the number of digits to align.
Reply
#56
(06-29-2017, 08:32 AM)kevindd992002 Wrote:
(06-29-2017, 06:55 AM)Martin Wrote:
(06-28-2017, 11:40 AM)kevindd992002 Wrote:
(06-28-2017, 10:31 AM)Martin Wrote: Sorry, what I mentioned are RTSS internal structure versions.
So for custom colors you need RTSS 7.0.0 and for graphs you need RTSS 7.0.0 beta 24 (http://forums.guru3d.com/showpost.php?p=...tcount=474)
I will update this in release notes.

Ok. With the portable BETA, when I choose Auto startup it does create a scheduled task but still references the executable file to the default "install" folder of C:\Program Files\hwinfo64\ . Is this normal behavior? Why doesn't it create a scheduled task that points to wherever the exe is placed if it is portable?

This might be a remain of the setting done by the installer version. Try to disable Auto-start, click OK and then enable it again with the portable version.

Ok. I manually changed the path of the scheduled task but I'll see if I can test this more. The portable version is designed to change the path accordingly, right?

Each version portable or not should put the correct actual path into the scheduled task.
Reply
#57
(06-29-2017, 08:42 AM)Martin Wrote: I will improve the alignment setting in the next build, so you will be able to precisely specify the number of digits to align.

Martin like i asked before, can you provide smaller text for MB/s like new RTSS does for mhz, °C etc. That woulde help to save space for numbers.
Reply
#58
Another "issue" to ask. With AB 4.3.0+RTSS6.6.0 HWinfo OSD works properly but with newest Beta it keep causing HWinfo OSD to disappear sometimes. Unwinder says there is no problem in new RTSS, so can be HWinfo causing the issue with newest RTSS?

I have no clue anymore of the cause. Firstly i thought it was refresh period from RTSS causing issue, because the lower i marked looked like more frequently HWinfo OSD blinked, but i dont know if it's correctly.

It disappear for a single frame then comeback, take variable time to happen. After 3 seconds or even 1 minute. If you need i can upload a video to show.
Reply
#59
(07-01-2017, 09:03 PM)chumanga Wrote: Another "issue" to ask. With AB 4.3.0+RTSS6.6.0 HWinfo OSD works properly but with newest Beta it keep causing HWinfo OSD to disappear sometimes. Unwinder says there is no problem in new RTSS, so can be HWinfo causing the issue with newest RTSS?

I have no clue anymore of the cause. Firstly i thought it was refresh period from RTSS causing issue, because the lower i marked looked like more frequently HWinfo OSD blinked, but i dont know if it's correctly.

It disappear for a single frame then comeback, take variable time to happen. After 3 seconds or even 1 minute. If you need i can upload a video to show.

This is really strange and not easy to diagnose what exactly is causing this.
Can you please try to change OSD settings in HWiNFO (i.e. remove some sensors from OSD, change their settings) and see if you can find which setting does cause the problem ?
Reply
#60
There is no doubt, RTSS framerate refresh period and Video recording is the main issue for it. HWinfo is at 1000ms refresh period, by default RTSS is 1000ms for framerate too. If i keep RTSS at default then no blink for HWinfo. If i decrease RTSS framerate refresh period to 500, 200, 100 or 0ms then HWinfo blinking start. Low values for RTSS refresh period intensifies HWinfo blinking.


If i keep RTSS 1000ms but i start video recording then HWinfo blinking occur with high rate like every few seconds.


I uninstalled AB 4.4.0 and installed 4.3.0 and keep same HWinfo version, i make RTSS refresh period to 100ms in AB 4.3.0 and there was no blinking.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)