Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
System "hiccups" when "respin period" is active.
#1
Hello there, I recently discovered HWiNFO and decided to test it on my DELL XPS L502X. So far the program works quite fine.

The only problem I'm experiencing is on the fan control tool, for the most part, it works fine, although the system sometimes takes control again and turns off the fan even when the CPU is working, this is not a big problem, the fan works fine when playing games and no overheating has occured, it only happens when I'm performing regular task such as web browsing, watching videos, using design programs, etc, but I digress, I checked "respin period" and left the default setting at 5000 ms, but every 5 seconds the system "hiccups".

Is it a way to fix this issue? the whole program works fine for me except that part, is there a way to just enable the respin period only when the fan(s) are overtaken by the system and not checking every 5 seconds or whatever time period I set on it?

I attached a .zip file containing the system report and the debug file. Thanks in advance.

PS. Sorry for my bad english, its not my first language.


Attached Files
.zip   HWiNFO64.zip (Size: 109.72 KB / Downloads: 0)
Reply
#2
I'm afraid, there's no workaround for this. The hiccup is caused by the set fan speed command that HWiNFO sends and the system (BIOS+EC) takes too much time to process it at very high priority. So the only fix would be if the BIOS would somehow fix this in a new update, but I doubt DELL would do that.
Changing the respin so that the fan speed would be changed only if system takes control wouldn't solve this problem, since HWiNFO would have to periodically measure fan speed using a very similar command which I believe would cause similar hiccups.
You might try to enlarge the respin period so that it doesn't happen too frequent...
Reply
#3
Thank you very much for the answer Martin, I was afraid that would be the case, DELL BIOSs are a pain in the a$% Angry, anyway, I use the "respin period" only when I do stuff that may trigger the system taking over the fan control, I set the timer to check every 3-4 minutes so the "hiccups" won't become a nuisance allowing me to work fine.

Overall, HWiNFO is a really good program, I'll keep using it and see how it will be improved in future updates. Keep up the good work!

Peace.
Reply
#4
Hi again, Martin, it is a REALLY late reply, but I think it is important to point it out in case someone else with the same laptop model has the same issue. I managed to find a workaround for it a couple of days after your response, by lowering a little the maximum processor state (90% - 75% with no performance loss) option on energy settings, it stopped happening. So I guess it's safe to mark it as solved.

By the way, I've been using the latest version and no problems so far, performance has been enhanced, I manage to keep my laptop at 24°C to 32°C (depending on room temperatures, 42°C on exceptionally hot summer days) when idle and fans working at medium speed; 2800 RPM, again, its a very useful tool, thanks!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)