Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Win10 BSOD scanning HighPoint (RR3740)
#1
I had been running on this system without issue until I installed the driver for the HighPoint card.  Once I did, any and every attempt to run hwinfo64 ends with a blue-screen indicating that rr3740.sys (rocket raid driver) encountered an "IRQL_NOT_LESS_OR_EQUAL" issue. 

.DBG is attached - it appears it died in the middle of scanning the SSDs attached to the raid card (there are 8 attached).


Attached Files
.dbg   HWiNFO64.DBG (Size: 989.3 KB / Downloads: 2)
Reply
#2
This indeed seems to be some problem in the RocketRaid driver since certain functions work there, while attempting to start SMART leads to a BSOD.
Currently you have the following options to avoid the BSOD:
- Replace the RocketRaid driver; does the generic Microsoft driver for for it ?
- Disable S.M.A.R.T. support in HWiNFO Safety options
- Disable the entire Drive Scan in HWiNFO Safety options
Reply
#3
(07-16-2017, 08:53 AM)Martin Wrote: This indeed seems to be some problem in the RocketRaid driver since certain functions work there, while attempting to start SMART leads to a BSOD.
Currently you have the following options to avoid the BSOD:
- Replace the RocketRaid driver; does the generic Microsoft driver for for it ?
- Disable S.M.A.R.T. support in HWiNFO Safety options
- Disable the entire Drive Scan in HWiNFO Safety options

No MSFT driver was found automatically, but full-disclosure: this card does not appear to initialize correctly in UEFI boot mode (it is not seen by the bios unless legacy CSM is enabled which causes problems in my system).  So, the RR card only functions with HighPoint's driver loaded. 

I'll try the SMART disable and double check any interaction with SMART pass-through on the RR card.  Its running in JBOD mode as a simple HBA, so I believe it will pass-through SMART, but I may have to enable that in the HighPoint client.

EDIT: SMART disable was sufficient to get past the BSOD.
Reply
#4
Thanks for the feedback. Disabling SMART will help, however in this case you will loose SMART data from all drives.
I will try to find a better workaround if there's no other option available how to fix SMART pass-through there.
Reply
#5
(07-16-2017, 10:07 AM)Martin Wrote: Thanks for the feedback. Disabling SMART will help, however in this case you will loose SMART data from all drives.
I will try to find a better workaround if there's no other option available how to fix SMART pass-through there.

I double checked and SMART pass-through was already enabled on the controller.  In fact, at least in linux it behaves as you'd expect for an HBA (transparent):
% smartctl --all /dev/sdc
=== START OF INFORMATION SECTION ===

Device Model:     Samsung SSD 850 PRO 512GB
Serial Number:   XXXXXXXXXXXXXXXXXXXXX
LU WWN Device Id: XXXXXXXXXXXXXXXXXXXXXXXXXX
Firmware Version: EXM03B6Q
User Capacity:    512,110,190,592 bytes [512 GB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    Solid State Device
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ACS-2, ATA8-ACS T13/1699-D revision 4c
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Sun Jul 16 08:06:48 2017 EDT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

.....
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)