Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
hp 2740p fan control speed mistery- hit and miss
#1
hi
after updating hp 2740p into win 8.1 it works.

However, for life of me, cannot figure out how you select certain speed for fan. It is hit and miss.

When I start the app, after reboot/or wake after sleep it is in automatic mode.

I change to manual. But no matter how much I move the cursor left of right, speed moves only in certain range: 0, 967, 2300, sometime 2800, 3400, and over.

I played with LUT table. No help.
Here is what I need:
1. to run on starup with fan control on.
2. Have one speed locked for good, 967-1500 rpm would be good, it is quite and still keeps the guts cool.


** if you see the screenshot working speed, let say if speed is 4000, then I click lower than that particular location, it won't do anything, ONLY if I click at that location, it will drop the speed between 1800 - 2400, it is mistery to me, how decided about the speed.

So it is hit and miss all the time.
Any help?


Attached Files Thumbnail(s)
               
Reply
#2
You might want to check this about more details: http://forum.techinferno.com/hwinfo32-64...nfo32.html
Reply
#3
(06-28-2014, 08:06 PM)Martin Wrote: You might want to check this about more details: http://forum.techinferno.com/hwinfo32-64...nfo32.html

thanks for reply Martin.

what I am looking for is very simple: 967 rpm, not matter what temp. So I changed LUT to match that, regardless of temp 1/2/3/4 it should be 967, right?
But it is not, it goes to some randon number i.e 2400 etc, but in that range on 2300 - 2800/2900.

I would like to lock it at 967 and I am good. No noise, and still runnning.

thx for your help


Attached Files Thumbnail(s)
       
Reply
#4
On the 1st screenshot I see that it's in Auto mode. You need to switch to Manual mode.
After you configure the LUT with 967 RPM and click "Apply and Save" doesn't the speed stay at that level?
Reply
#5
(06-28-2014, 09:23 PM)Martin Wrote: On the 1st screenshot I see that it's in Auto mode. You need to switch to Manual mode.
After you configure the LUT with 967 RPM and click "Apply and Save" doesn't the speed stay at that level?

nope, it, i did that, and it goes to 2469 rpm, which is very odd. how comes when none of items in LUT point to a speec of 2469 rpm, everything is 967 rpm.

One question though: When you change the LUT table i.e. to 967, what do I do with scroller for manual speed? Do I leave it in Min or max or where? Cause I think that might drive the speed of the fan, despite of apply and save of LUT table to act on automatic mode.

the other thing, is if I put my pc into hibernation, does BIOS keeps fan settings? I know shutting down/ sleep does not . but what about hibernation?

(06-28-2014, 09:45 PM)edlu Wrote:
(06-28-2014, 09:23 PM)Martin Wrote: On the 1st screenshot I see that it's in Auto mode. You need to switch to Manual mode.
After you configure the LUT with 967 RPM and click "Apply and Save" doesn't the speed stay at that level?

nope, it, i did that, and it goes to 2469 rpm, which is very odd. how comes when none of items in LUT point to a speec of 2469 rpm, everything is 967 rpm.

One question though: When you change the LUT table i.e. to 967, what do I do with scroller for manual speed? Do I leave it in Min or max or where? Cause I think that might drive the speed of the fan, despite of apply and save of LUT table to act on automatic mode.

the other thing, is if I put my pc into hibernation, does BIOS keeps fan settings? I know shutting down/ sleep does not . but what about hibernation?


here is a screenshot after reboot: all LUT point to 967, while the speed in 44xx rpm


Attached Files Thumbnail(s)
   
Reply
#6
This is indeed very strange and I'm afraid I don't have an explanation for it. Maybe your notebook has some additional fan override implemented in the firmware.
Reply
#7
(06-28-2014, 10:56 PM)Martin Wrote: This is indeed very strange and I'm afraid I don't have an explanation for it. Maybe your notebook has some additional fan override implemented in the firmware.

Up to now, still HWinfo fan control is my only hope to get me to use this hps 2740p, otherwise, I should throw in garbage. I had hp 3 times change the fan, nothing helps.
Even in boot fan goes to over 4000 rpm, which is crazy. No need for it.

I can put it to zero (0 rpm), in which case in gets very hot, even though I am using SSD.

So if notebook has something somewhere else to overide, then technically, I should not be able to bring it to zero.
Reply
#8
So defining any LUT values and then switching to Auto mode has no effect on the final fan speed ?
And using the manual mode, you're able to change to certain speeds only? Though this speed is not retained by HWiNFO during reset, suspend, etc..
Is that all correct ?
Reply
#9
(06-29-2014, 08:41 AM)Martin Wrote: So defining any LUT values and then switching to Auto mode has no effect on the final fan speed ?
And using the manual mode, you're able to change to certain speeds only? Though this speed is not retained by HWiNFO during reset, suspend, etc..
Is that all correct ?

that is right, the only way to control the speed is through manual cursor, and even that only at certain locations, other locations do not impact at all.

after standby/sleep I have to do it again, cause it forgets the speed rpm, however, the LUT table still maintains the all values, they just do not take effect.
Reply
#10
(06-29-2014, 11:29 PM)edlu Wrote:
(06-29-2014, 08:41 AM)Martin Wrote: So defining any LUT values and then switching to Auto mode has no effect on the final fan speed ?
And using the manual mode, you're able to change to certain speeds only? Though this speed is not retained by HWiNFO during reset, suspend, etc..
Is that all correct ?

that is right, the only way to control the speed is through manual cursor, and even that only at certain locations, other locations do not impact at all.

after standby/sleep I have to do it again, cause it forgets the speed rpm, however, the LUT table still maintains the all values, they just do not take effect.

Here is GOOD NEWS.
The Beta Version 4.41 2255 version is working. I can pick a rpm #, for all temp, and it works to lock the fan at that rpm.

Thanks a lot.

I am afraid to play with it, even to look at it for too long.

It it wooooorking.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)