Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
hwinfo64 problems with msi z170 gaming pro
#1
Hi,

Ive been using hwinfo64 for a long time and just upgraded my pc to the following

i7 6700k
16GB DDR4 ram
Msi z170 gaming pro motherboard
Corsair H110i Gtx cooler

Now my problem is and its only starting happening since the upgrade is that whenever I open hwinfo64 sensors my system wont restart when I request it.  If i boot my system without opening sensors and then restart it it restarts fine. When I open sensors and restart my system I just get a black screen.   Ive tried a fresh install of windows 10 pro and it does the exact same thing so Im thinking it cant be a software issue and something somewhere is conflicting?

Any ideas?

Thanks
Reply
#2
Well, this is a really odd issue, that will be difficult to find.
Please attach the HWiNFO Debug File (with sensor data) for analysis.
You might also try to disable some options in the Safety menu of HWiNFO to see if that makes a difference.
Reply
#3
A little more info.

when i start hwinfo64 it increases the fan speeds on my h110i gtx and if i run the corsair link software it then lowers the speeds.  My motherboard has 3 debug lights and when the machine refuses to restart the debug light stays on ram. So Ive disabled sensors for the ram and also turned off smbus scanning and it seems to work ok now??


Attached Files
.dbg   HWiNFO64.DBG (Size: 1.89 MB / Downloads: 3)
Reply
#4
The attached Debug File was created when SMBus is disabled, so I can't say for sure, but I assume there's some sensitive device on SMBus that caused the problem and disabling the support solved the problem.
Reply
#5
Hi, so I actually joined the forum because of this post.
I have exactly the same issue with HWinfo64 as above. I've been using the program for some while now and never had issues.
After I upgraded to my new system I started to have problems.
When I install HWinfo64, my PC will not restart from Windows. My keyboard and screen would go dead and the PC would just
stay on and not go back to Windows.
I also have the MSI Z170 Gaming Pro board.

Msi Z170 Gaming Pro
Core I5 6600K
16 gig DDR4 ram
Win 10 Pro.  

How do I go about disabling the RAM sensor and SMBus as above post to see if it also works for me.

Thanks in advance,
Robin
Reply
#6
Do you mean when you start HWiNFO64 then it does freeze ? Or have you configured HWiNFO64 to autostart with Windows and are now unable to get into Windows ?
You can disable those options right after starting HWiNFO64 - before hitting Run press Settings...
Reply
#7
I've configured it to start with windows.
Windows starts fine, but when I restart my PC, the screen goes black and the PC stays on but never goes back into windows.
Reply
#8
I have to then switch off the PC and back on again...
Reply
#9
Then right-click on the HWiNFO icon in tray, select Settings and in the Safety tab try to disable SMBus support to see if that fixes it.
Reply
#10
I did that and it did fix the problem. But I also had to disable the RAM sensors.
What does it mean when SMBus is disabled.?.
Thanks.
Reply
#11
SMBus is an interface that connects components like parts of RAM that are used to identify the memory modules, some sensors, etc. So when you disable SMBus support, HWiNFO will not query such components and you loose that information.
I believe the problem is just at a certain address and it might be possible to go with SMBus support enabled while excluding a certain address using the "SMBus Device Exclusion". This would require to perform more testing (trial/error exercise). If you're willing to do this, I can give you the instructions..
Reply
#12
(12-23-2015, 03:06 PM)Martin Wrote: SMBus is an interface that connects components like parts of RAM that are used to identify the memory modules, some sensors, etc. So when you disable SMBus support, HWiNFO will not query such components and you loose that information.
I believe the problem is just at a certain address and it might be possible to go with SMBus support enabled while excluding a certain address using the "SMBus Device Exclusion". This would require to perform more testing (trial/error exercise). If you're willing to do this, I can give you the instructions..

Thanks for the info so far.
If you can guide me step by step, I am willing to give it a go.
Reply
#13
OK. You need to find which address is causing the problem - the goal is to find which check-box when checked in the "SMBus Device Exclusion" table fixes the issue.
So first please enable SMBus support again.
Then try to select all boxes on an entire row and test if the problem persists by running HWiNFO. If it does persist, then uncheck all boxes back and try a different row until you find the one which is causing it. If you have found such row, then you should go one by one by unchecking the boxes and testing again (to get it faster you might divide it into halves).
This way you should find one box (maybe more?) which when checked doesn't cause the issue. I'd like to know which one is it, so that I can then automatically add this into HWiNFO.
Note, that when a box is checked, it means that address is skipped.
I suggest to start with the 6x row (this is usually the problematic one), then you might try 3x.
Please let me know your results.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)