Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
support for mobility hardware
#1
Hi community,

I want to display system-stats with an OSD during intensive rendering processes.
I dislike Nvidia SystemTools, or MSI Afterburner and Rivatuner is to old. So I was
very happy to read about your support for GT520m and GT540m videocards.

I started the RTSS (RivaTuner StatsServer) first an HWinfo64 after that.
I can see everything relating the cpu / mainboard / igpHD3000 with the OSD.
But I cant gather any information about the discrete graphic card GT540m.

I forced the nvidia driver via control panel to be always used and uncheck
intel sandybridge igpHD3000. But HWinfo64 only recognizes the igp.

Because H264 transcoding with the fermi shader cores heaten the system up,
I have the need to care about my notebook temps. Can you help me, by reading
the gpu-temp, please.

Bye
Tom
Reply
#2
Since you haven't provided any additional details (report file or debug file), I can only assume that the DGPU is turned off by the system when idle.
Try to put some load on the Discrete GPU before starting HWiNFO, then it should show up.
Let me know if that helped, if not, please supply the additional information.
Reply
#3
(02-14-2012, 11:22 AM)Martin Wrote: Since you haven't provided any additional details (report file or debug file), I can only assume that the DGPU is turned off by the system when idle.
Try to put some load on the Discrete GPU before starting HWiNFO, then it should show up.
Let me know if that helped, if not, please supply the additional information.

Hi Martin,
thanks for the suggestions.
I enabled the discrete gpu in nvidia control panel.
I also enabled the GT540m when the RTSS.exe is a process in taskmanager.
The card ist running in 2D mode 270MHz/400MHz of max 540/800 (3D peak).
But it wont be recognized by HWinfo64. There is no problem with 64bit signed drivers? Should I bypass "software triggering" in HWinfo64 and force low level hardware?

bye
Tom

Reply
#4
No, there should be no problem with the driver.
Do you have Optimus enabled? That causes the DGPU not to enumerate on bus if it's in idle state.
Please also atatch the HWiNFO Report and Debug File.
Reply
#5
Hi Martin,

because of your great assistance, this is my last post relating this problem.
You are right. Forcing the dGPU with the *.exe files isnt enought.
I run a benchmark and forced the dGPU to produce some load.
And...thats it. HWinfo recognizes everything immediately.
Now I display 10x stats in the OSD and only have a drop in fps of ~5%.

One last question. Where can I name the label für the fps line?
Its the only value I found no label for.

Thanks alot.
Tom
Reply
#6
FPS is reported by the RivaTuner/Afterburner, so HWiNFO has no influence on this.
If you want to reduce the FPS drop even more, you might try to disable some sensor values that you don't need (using right-click), that might cause some system load (like SMART, EC, etc.). Just try and you'll surely be able to get an improvement...
Btw, a new HWiNFO32/64 release will be available in a minute Wink
Reply
#7
Hi Martin,

I will try your suggestion to remove fps drop.
Yesterday I tested a little bit - S.M.A.R.T. is really a ressource hungry option.
But Rivatuner itself isnt running. I only use the RTSS (StatServer) + HWinfo.
I cleaned up the RTSS so its empty and dont use any program template.
The fps must be provided by the server itself?!?!

Bye
Tom
Reply
#8
Yes, it's provided by the RTSS. It should allow you to enable/disable FPS reporting.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)