Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 2,776
» Latest member: RCH83199
» Forum threads: 1,900
» Forum posts: 11,934

Full Statistics

Online Users
There are currently 29 online users.
» 0 Member(s) | 29 Guest(s)

Latest Threads
drive temp 10540C!?
Forum: HWiNFO32 & HWiNFO64 Bug Reports
Last Post: Martin
12-01-2016, 09:30 PM
» Replies: 1
» Views: 29
Units Not Being Displayed
Forum: HWiNFOMonitor
Last Post: stangowner
12-01-2016, 12:42 PM
» Replies: 17
» Views: 1,471
My GPU VR temps disappear...
Forum: General Discussion
Last Post: Martin
11-30-2016, 11:37 PM
» Replies: 1
» Views: 28
HWiNFO32 and HWiNFO64 v5....
Forum: Announcements
Last Post: Martin
11-30-2016, 09:58 AM
» Replies: 0
» Views: 112
INTEL NVME SHOWING UP AS ...
Forum: HWiNFO32 & HWiNFO64 Bug Reports
Last Post: Martin
11-28-2016, 10:07 PM
» Replies: 6
» Views: 59
HWiNFOMonitor 2.0
Forum: HWiNFOMonitor
Last Post: leveltrauma
11-25-2016, 01:24 PM
» Replies: 18
» Views: 18,096
Thermal throttling, no va...
Forum: General Discussion
Last Post: wolf88
11-24-2016, 08:25 PM
» Replies: 2
» Views: 85
Custom 6 Channel USB FanC...
Forum: 3rd Party Extensions, Plug-ins, Gadgets
Last Post: pingo
11-24-2016, 03:25 PM
» Replies: 2
» Views: 1,425
SW SMI option
Forum: HWiNFO32 & HWiNFO64 Bug Reports
Last Post: Martin
11-24-2016, 10:52 AM
» Replies: 3
» Views: 115
BAD CPU AND FSB READINGS ...
Forum: HWiNFO32 & HWiNFO64 Bug Reports
Last Post: Martin
11-23-2016, 08:29 PM
» Replies: 23
» Views: 4,601