3-8C A8-5600k CPU

Hi I'm new here and after reformatting Windows 7 on these specs

AMD A8-5600K 3.6ghz Quadcore
Gigabyte F2A75M D3H
4GB DDR3 RAM
PowerColor HD7750 1GB
1.75 TB HDDs

and installing latest HWinfo64 4.26, the temps for A8-5600k are 3 to 9 degrees C, how do I deal with this? Gigabyte's easy tune says 18C when it's idle and not 3-9
 

Martin

HWiNFO Author
Staff member
What Gigabyte reports is probably the "Temperature 3" value seen in HWiNFO, which is most probably the value from a sensor near the CPU socket.
The "CPU 0" value which is so low, comes from internal CPU sensor. This sensor doesn't work properly in most later AMD CPU generations, which is also acknowledged by AMD. When the temperature is in the lower range (idle, below ~50 C) the sensor provides erratic values. When the temperature gets close to upper limits, the value should be more precise. Unfortunately AMD has not provided any solution for this.
 
Martin said:
What Gigabyte reports is probably the "Temperature 3" value seen in HWiNFO, which is most probably the value from a sensor near the CPU socket.
The "CPU 0" value which is so low, comes from internal CPU sensor. This sensor doesn't work properly in most later AMD CPU generations, which is also acknowledged by AMD. When the temperature is in the lower range (idle, below ~50 C) the sensor provides erratic values. When the temperature gets close to upper limits, the value should be more precise. Unfortunately AMD has not provided any solution for this.
This 18-23 C can be seen in BIOS, Speedfan, Gigabyte's Easy tune also

but in HWMonitor there's an additional 'Package' under AMD A8-5600K that says it's around 49-57 C


What is that "package" anyway?

and also in Speccy, it displays the same temp as what is seen in 'package' but right next to CPU AMD A8-5600K as if that's actually its temp, you think those are right?

Also whenever I run a prime95 blend test, both the 'Package' 49-57 C (max at 57) and the 18-23(max 23) change
 

Martin

HWiNFO Author
Staff member
I believe that "Package" temperature is not correct as well. While sometimes it can provide values which seem reasonable, in other cases I believe it's pretty off the expected values. I'm afraid, this is a hardware problem of the sensor in the CPU and it seems to me that AMD tries to apply various workarounds for this, which don't work properly either.
Try to run a high load CPU stress test for a few minutes and then check the value of "Package" temperature ;)
 
Martin said:
I believe that "Package" temperature is not correct as well. While sometimes it can provide values which seem reasonable, in other cases I believe it's pretty off the expected values. I'm afraid, this is a hardware problem of the sensor in the CPU and it seems to me that AMD tries to apply various workarounds for this, which don't work properly either.
Try to run a high load CPU stress test for a few minutes and then check the value of "Package" temperature ;)
where does package from? how does hwmonitor derive it?
 

Martin

HWiNFO Author
Staff member
That value comes from the SB-TSI interface and not even 'HWMonitor' knows exactly where it comes from thru this interface.
I could add the same value into HWiNFO, but I believe it might cause even more confusion among users.
 
Martin said:
That value comes from the SB-TSI interface and not even 'HWMonitor' knows exactly where it comes from thru this interface.
I could add the same value into HWiNFO, but I believe it might cause even more confusion among users.
Where does sb tsi come from? How is it derived?
There's gotta be a reason speccy also hhas that temp value
 

Martin

HWiNFO Author
Staff member
Speccy is most probably using the exactly same method as HWMonitor does.
SBI-TS is an AMD proprietary interface that can interconnect various temperature sensors. I was trying to determine which exact value is read there, but this is not well documented/disclosed by AMD. Not even in advanced documents that require an NDA.
I also discussed this with Franck (author of CPU-Z and HWMonitor) and he doesn't know either where this value really comes from. Moreover he confirmed that this value is not correct in many cases.
 
Martin said:
Speccy is most probably using the exactly same method as HWMonitor does.
SBI-TS is an AMD proprietary interface that can interconnect various temperature sensors. I was trying to determine which exact value is read there, but this is not well documented/disclosed by AMD. Not even in advanced documents that require an NDA.
I also discussed this with Franck (author of CPU-Z and HWMonitor) and he doesn't know either where this value really comes from. Moreover he confirmed that this value is not correct in many cases.
Is it true however that when the temp is high enough or under enough load the 14-20 C will become more and more accurate and I will see an accurate value when it's very near 74C(max operating)?
edit: or maybe the 3-8c
 

Martin

HWiNFO Author
Staff member
Have you tried the high load test for few minutes as I suggested before? Please try that and let me know what "Package" value will be reported then.
 
Martin said:
Have you tried the high load test for few minutes as I suggested before? Please try that and let me know what "Package" value will be reported then.
If you mean prime95 blend test I already did
[hr]
Oh hey by the way someone suggested using GPU-Z and viewing the HD7560D temp and that it it seems to give an accurate temperature reading for the entire chip. I tried it and it shows 44 C right now, different from Package and the 16-20C previously reported. Do you think this could be correct? given I base the a8-5600k APU temp on its GPU using this?
 

Martin

HWiNFO Author
Staff member
So what Package temperature has been reported after few minutes run with Prime95 ?

I'm afraid, but the APU/GPU temperature sensor seems to be providing erratic values in many cases as well.
 
Martin said:
So what Package temperature has been reported after few minutes run with Prime95 ?

I'm afraid, but the APU/GPU temperature sensor seems to be providing erratic values in many cases as well.
The 57 C but strangely both that and the 16-22C change when its' under that test
 

Martin

HWiNFO Author
Staff member
OK, I can add that "Package" value into HWiNFO, but don't expect it to provide miracles ;)
 
Martin said:
OK, I can add that "Package" value into HWiNFO, but don't expect it provide miracles ;)
Oh hey by the way someone suggested using GPU-Z and viewing the HD7560D temp and that it it seems to give an accurate temperature reading for the entire chip. I tried it and it shows 44 C right now, different from Package and the 16-20C previously reported. Do you think this could be correct? given I base the a8-5600k APU temp on its GPU using this?
 

Martin

HWiNFO Author
Staff member
The new v4.27-2040 Beta released a while ago should display the "Package" temperature too.
You might need to press the "Restore Original Order" button in Sensors/Layout for the new item to reordered under particular sensor.
 
Top