64_444 Freezes Windows on sensor scan

Martin

HWiNFO Author
Staff member
Hmm... This is very strange. It seems to crash on random placed. This is very hard to track.
If it crashes again, please post also the crash report information from Windows.
 

cc2001

Member
Problem signature:
Problem Event Name: APPCRASH
Application Name: HWiNFO64.exe
Application Version: 4.4.5.0
Application Timestamp: 54119f1e
Fault Module Name: StackHash_d561
Fault Module Version: 6.1.7601.18247
Fault Module Timestamp: 521eaf24
Exception Code: c0000374
Exception Offset: 00000000000c4102
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: d561
Additional Information 2: d5617e705c4497492dfc0097c35685ac
Additional Information 3: 9b3e
Additional Information 4: 9b3e437865b687c1c415112bf48cee9d


Also attaching a screenshot of something that popped up this last time right before the crash.
 

Attachments

Martin

HWiNFO Author
Staff member
How long does it take to crash, is it somehow deterministic, i.e. say always after ~10 minutes ?
What settings do you use (i.e. Sensor-only, minimized, export to Auqasuite) ?
 

cc2001

Member
Time doesn't seem to be consistent, but I'll try to gauge it more closely.

Settings:

General:
Show System Summary on Startup
Show Sensors on Startup
Minimize Main Window on Startup
Minimize Sensors on Startup
Wake disabled GPUs
Automatic Update
Remember Preferences
Shared Memory Support
Flush Buffers on Start
Auto Start

Safety:
IDE/(S)ATA Drive Scan: Safe Mode
CPU Clock Measurement: Bus Clock-based, Periodic polling, Use HPET
EC Support
Evaluate ACPI Methods
SW SMI
Audio Codec Check
Intel ME Support
Debug Mode
Debug Write Direct

SMBus/I2C
SMBus Support
SMBus Device Exclusion:
Y0,X0- Y0,XF; Y6,X9
GPUI2C Support
GPU I2C via NVAPI
GPU I2C Caching

Driver Management:
Current Status: Installed

Aquasuite (version 2014 2.3) has 6 software sensors enabled using HWiNFO as the data source:
-CPU [#0]:Intel Core i7-5820K:DTS -> Core Max
-CPU [#0]:Intel Core i7-5820K -> Memory Ambient
-GPU [#0]: NVIDIA GeForce GTX 660 Ti: -> GPU Temperature (HW) [2 temperature options appear here one with and without (HW)]
-GPU [#1]: NVIDIA GeForce GTX 660 Ti: -> GPU Temperature (HW) [2 temperature options appear here one with and without (HW)]
-S.M.A.R.T -> Samsung...
-S.M.A.R.T -> WDC...

Crashed again as I was typing up the post so this time less than 5 min:

Problem signature:
Problem Event Name: APPCRASH
Application Name: HWiNFO64.exe
Application Version: 4.4.5.0
Application Timestamp: 54119f1e
Fault Module Name: StackHash_9e28
Fault Module Version: 6.1.7601.18247
Fault Module Timestamp: 521eaf24
Exception Code: c0000374
Exception Offset: 00000000000c4102
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 9e28
Additional Information 2: 9e2884d655c88465dd71cbc373d6fed5
Additional Information 3: 0ff0
Additional Information 4: 0ff04a194f34eda980685ba7097927f0

after ~7 mins this time the MS C++ runtime error popped up again as well:
Problem signature:
Problem Event Name: APPCRASH
Application Name: HWiNFO64.exe
Application Version: 4.4.5.0
Application Timestamp: 54119f1e
Fault Module Name: HWiNFO64.exe
Fault Module Version: 4.4.5.0
Fault Module Timestamp: 54119f1e
Exception Code: 40000015
Exception Offset: 0000000000176c3a
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 855e
Additional Information 2: 855e9353a78ccca4ad69f0ce071ddbcd
Additional Information 3: 1aeb
Additional Information 4: 1aeb028efc10379355d8478cf1a73bda

Thanks
[hr]
Trying changing the settings unchecking the following since last crash:
Show System Summary on Startup
Minimize Main Window on Startup

Also changed some windows power settings (not sure if this'll make a difference but wanted to note it):
-Changed turn off hard disk after to Never
-Allow Hybrid Sleep to off
-USB selective suspend to Disabled
-PCI Express Link State Power Management to off

running so far for ~18min
 

Attachments

Martin

HWiNFO Author
Staff member
Thanks for the additional information !
Please try to run with the System Summary only (without the sensors) for a while if it crashes.
Then please try again with sensors and disable the following options to see if that maybe has an effect:
- GPU I2C Support
- SMBus support
- If after disabling SMBus it doesn't crash anymore, please enable it back, but under "SMBus Device Exclusion" check all boxes in the row for "7x"
This will probably take longer to test, but it might help me to understand a bit more why it happens.
 

cc2001

Member
Still running with no crashes ~ 8.5 hrs later, but if it does crash I'll make those changes you mentioned. Thanks.
 
Top