Asus and WMI issue

Hello guys,

I have never experienced a problem with the Asus WMI and yesterday out of no where some sensors started reporting very rarely(CPU fans, Dram Voltage, CPU VRM Tremp, CPU Core Voltage, etc.).
Here is an example next to the voltage graph. CPU fan reports form time to time:

1588225369351.png

and the AsusWMI section goes on random - disappears, shows grayed out values or looks normal.

1588230854595.png

1588230913041.png

So what I have tried:
- Rebuild of the WMI repository (used WMI Fixer Tool)
- Bios Reset (CMOS Clear)
- Reflash the bios - with 2 different version (7704, 7403 - ROG CROSSHAIR VI HERO)
- Tested out with 4 HWinfo versions
- Stopped all other HW monitoring software
- AsusWMI=0 in the ini file - this fixes the reporting, but the CPU OPT fan and some other sensors disappear.
- AsusWMI=1,2,3,7,8,9 - no effect
- Reinstall the latest Chipset drivers for - x370 / 2.04.04.111
- Did a "sfc /scannow" -> Windows Resource Protection did not find any integrity violations.
- Get-WmiObject -query "select * from Win32_fan" -namespace "root\cimv2" -> returns nothing, not sure if this is the correct WMI that HWinfo uses

Any ideas will be appreciated, I am stuck :)

Edit: added a screenshot of the Asus WMI section.
 
Last edited:

Martin

HWiNFO Author
Staff member
Haven't seen such an issue yet, but it looks like you already tried what I'd suggest in first place.
Really not sure what else might be causing this.. Recent Windows Update perhaps or some other monitoring tool?
 
I manually update Windows. also tested:
- updated windows to the latest cumulative - no effect
- did a restore point - this is usually my silver bullet, no effect :(
- Aida64 for some bloody reason manages to read that asus WMI. Maybe they use some kind of a custom driver.

Will post if I manage to find the root cause.

Edit:
Manage to find the CPU FAN value in the WMI and it seems to be properly updated. The Asus WMI works, so there is somekind of communication issue between HWinfo and Windows WMI.
Here are the WMI details if anyone is comes across this post in the future:

WMI Path and object: \\<computername>\ROOT\wmi:ASUSHW
Method: sensor_get_value
Id: 13 (CPU Fan) and 24 (CPU_FAN Optional)

Edit 2:
After 2 days of poking, the
Embedded Controller update rate is the problem, even though the EC support is disabled. Not sure how this was changed in the first place and were it was saved.

1588251604337.png
 
Last edited:
No I haven't, I am going to add that to a human error (me misclicking it).
In general does the embedded control mean WMI?
 
Top