Automatically start HWiNFO when windows starts

John_82

Member
Hello,

I attach the selected settings.
However, when windows starts, HWiNFO does not automatically start.
I need to start it manually.

How can I correct it ?

Thank you for your time
automatic start.png
 

Martin

HWiNFO Author
Staff member
Try to disable the Auto Start option, click OK, then again enable and OK.
 

John_82

Member
Thank you for the reply.

I checked the above settings,
tried the "disable the Auto Start option, click OK, then again enable and OK.", and
then "run".

I restarted the laptop, but the issue remains.

So, while the program is running, I tried once more your suggestions, and I did one last restart, but the issue remains.

If you have any further thoughts, I would be glad to hear them.
This program is better that the other 2 that I have tried, but I can not install it every time I restart my laptop
 

Martin

HWiNFO Author
Staff member
Is the HWiNFO task still not present in Task Scheduler?
Are you running with sufficient (Administrative) rights?
 

Martin

HWiNFO Author
Staff member
Check if it's Last Run Result is reporting OK or some error. You might also try to manually run the task if it will work.
 

John_82

Member
Thank you for the ideas.

Where can I find "Last Run Result " ?

I checked the "main" and the "sensors", and I couldn't find this option.

Thank you for your time
 

Martin

HWiNFO Author
Staff member
In Task Scheduler. Auto Start of HWiNFO is completely managed by Windows Task Scheduler, so if there's an issue, you should check the HWiNFO entry there.
 

John_82

Member
I do not see any issue.

Obviously, it is not going to happen.

Anyway, thank you for your time and your support

Best regards
 

Bekarfel

Member
I'm having this issue as well, but I don't see an HWiNFO entry in Task Scheduler.
I have disabled the auto-start option and clicked OK, and I enabled the auto-start option and clicked OK, and still no entry in the windows task scheduler.
 

Martin

HWiNFO Author
Staff member
Are you using the portable or installer HWiNFO version?
Can you look in your TEMP folder if there's a file called HWiNFO-Sch.xml ?
 

Bekarfel

Member
Hello Martin, Apologies for the late response but I had an unrelated hardware failure and just got around to reinstalling HWiNFO.

The new installation also does not start up automatically, and does not have a HWiNFO entry in the Task Scheduler.

I'm using the installer version of HWiNFO ( downloaded this: https://www.fosshub.com/HWiNFO.html?dwl=hwi_706.exe ), and I don't see a file called HWiNFO-Sch.xml in my %temp% folder.
 

Martin

HWiNFO Author
Staff member
Are you perhaps running some antivirus or antimalware software that could be preventing HWiNFO from creating the task in Task Scheduler?
 

Bekarfel

Member
The only antivirus/antimalware software I have running is Windows Defender.

Would installing HWiNFO to a 'non-standard' location (for example if Windows says my programs folder is on C:\Program Files, but I have installed HWiNFO to D:\Program Files) cause it to install as a portable edition?
 

Martin

HWiNFO Author
Staff member
That should not be an issue.
If you don't see the "HWiNFO-Sch.xml" file in your %temp% folder even after disabling/enabling Auto Start, it could mean something is preventing HWiNFO64 from accessing the %temp% folder.
 

Bekarfel

Member
This might be a heisenbug? Last night it did not create a HWiNFO-Sch.xml file in %temp%, but today, when you mentioned that something could be preventing HWiNFO from accessing the %temp% folder I couldn't think of a thing that would cause that. So I went to make a Procmon log of the operation to see if there was something in that, and it worked during the logging. I haven't restarted yet, but there is a HWiNFO-Sch.xml file in %temp% and there is an entry for HWiNFO in Task Scheduler.
 

Almighty1

New Member
Thanks to this thread, I got the AutoStart working with the new beta as it was basically what post #4 said and then checking task scheduler to confirm the HWinfo entry and then rebooting to make sure it works after manually running the task before rebooting.
 
Top