BSOD random on laptop Lenovo Legion 5


Hi, I wanted to report a problem that HWiNFO64 causes to my Legion 5 laptop, for a few months now my laptop had random bsods with Driver Power State Failure error, while I was using it in battery mode with HWiNFO64 always running (it was set by automatic start) and in the end I discovered that the cause was precisely the HWiNFO64 software because since I closed it there have been no more blue screens and strange freezes, so at the moment I have not used it anymore.
I was wondering if by any chance you already know about this and if there is a possible fix or is it a new bug happening on Legion laptops.
Try to disable "EC Support" in HWiNFO settings if that solve the problem and please let me know the result.
Try to disable "EC Support" in HWiNFO settings if that solve the problem and please let me know the result.

Hi Martin, I tried to disable that option but as soon as I unplugged the laptop from the power supply the system crashed and after a few minutes blue screen with the usual error :( I specify that this it only happens when the laptop is in battery mode
Would you be able to attach the HWiNFO Debug File of the crash so I can see more precisely what's going on there.
Something similar also appears to be happening on my Legion 5 17ACH6 when running on USB-PD power. The keyboard stops responding, then quickly a BSOD happens. Driver_Power_State_Failure, bug check=0x9f, parameter1=3, faulting module=ACPI. USBHUB3 and HidUsb might also be involved.

I just disabled "EC Support" and "Evaluate ACPI Methods" and will report back on whether it helps or not.
The same thing still happened after disabling EC Support and Evaluate ACPI Methods. This was in sleep mode while plugged into USB-PD power. I don't get this blue screen with HWiNFO off or with the AC adapter plugged in. I'll try it with disabling SMBus Support next. Here is the dump file analysis:

A driver has failed to complete a power IRP within a specific time.
Arg1: 0000000000000003, A device object has been blocking an IRP for too long a time
Arg2: ffff968bb04e1cd0, Physical Device Object of the stack
Arg3: fffff887964bf790, nt!TRIAGE_9F_POWER on Win7 and higher, otherwise the Functional Device Object of the stack
Arg4: ffff968bb702a010, The blocked IRP

Debugging Details:


Key : Analysis.CPU.mSec
Value: 2217

Key : Analysis.DebugAnalysisManager
Value: Create

Key : Analysis.Elapsed.mSec
Value: 11479

Key : Analysis.Init.CPU.mSec
Value: 499

Key : Analysis.Init.Elapsed.mSec
Value: 37969

Key : Analysis.Memory.CommitPeak.Mb
Value: 102

Key : Bugcheck.Code.DumpHeader
Value: 0x9f

Key : Bugcheck.Code.Register
Value: 0x9f

Key : WER.OS.Branch
Value: co_release

Key : WER.OS.Timestamp
Value: 2021-06-04T16:28:00Z

Key : WER.OS.Version
Value: 10.0.22000.1

FILE_IN_CAB: 081122-15515-01.dmp

TAG_NOT_DEFINED_202b: *** Unknown TAG in analysis list 202b



BUGCHECK_P2: ffff968bb04e1cd0

BUGCHECK_P3: fffff887964bf790

BUGCHECK_P4: ffff968bb702a010


DRIVER_OBJECT: ffff968bb0bd9e30



FAULTING_MODULE: fffff80310e10000 ACPI

BLACKBOXACPI: 1 (!blackboxacpi)

BLACKBOXBSD: 1 (!blackboxbsd)

BLACKBOXNTFS: 1 (!blackboxntfs)

BLACKBOXPNP: 1 (!blackboxpnp)




fffff887`964bf758 fffff803`0e9c2d47 : 00000000`0000009f 00000000`00000003 ffff968b`b04e1cd0 fffff887`964bf790 : nt!KeBugCheckEx
fffff887`964bf760 fffff803`0e9c2c61 : ffff968b`b5eef208 00000000`00000080 fffff887`964bfab8 fffff887`964bfab0 : nt!PopIrpWatchdogBugcheck+0xdf
fffff887`964bf7d0 fffff803`0e6a8324 : 00000000`00000000 00000000`00000001 fffff887`00000000 00000000`00000002 : nt!PopIrpWatchdog+0x31
fffff887`964bf820 fffff803`0e6a6914 : 00000000`00000000 00000000`00000000 00000000`00000000 fffff803`0aaf3d28 : nt!KiProcessExpiredTimerList+0x204
fffff887`964bf950 fffff803`0e81bcbe : 00000000`00000000 ffffd701`f3200180 ffffd701`f320c340 ffff968b`c90d4080 : nt!KiRetireDpcList+0x714
fffff887`964bfc00 00000000`00000000 : fffff887`964c0000 fffff887`964b9000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x9e

IMAGE_VERSION: 10.0.22000.778

STACK_COMMAND: .cxr; .ecxr ; kb


OS_VERSION: 10.0.22000.1

BUILDLAB_STR: co_release


OSNAME: Windows 10

FAILURE_ID_HASH: {4a47bf2d-33a2-c37b-edc8-078440157129}

Followup: MachineOwner

10: kd> !drvobj ffff968bb0bd9e30 f
fffff8030f024e38: Unable to get value of ObpRootDirectoryObject
fffff8030f024e38: Unable to get value of ObpRootDirectoryObject
Driver object (ffff968bb0bd9e30) is for:

Driver Extension List: (id , addr)

Device Object list:
ffff968bc58cee10 ffff968bbe69bde0 ffff968bbdf31e00: Could not read device object

DriverEntry: fffff80310ecb010 ACPI!GsDriverEntry
DriverStartIo: 00000000
DriverUnload: fffff80310e624c0 ACPI!ACPIUnload
AddDevice: fffff80310e36d30 ACPI!ACPIDispatchAddDevice

Dispatch routines:
[00] IRP_MJ_CREATE fffff80310e11010 ACPI!ACPIDispatchIrp
[01] IRP_MJ_CREATE_NAMED_PIPE fffff80310e11010 ACPI!ACPIDispatchIrp
[02] IRP_MJ_CLOSE fffff80310e11010 ACPI!ACPIDispatchIrp
[03] IRP_MJ_READ fffff80310e11010 ACPI!ACPIDispatchIrp
[04] IRP_MJ_WRITE fffff80310e11010 ACPI!ACPIDispatchIrp
[05] IRP_MJ_QUERY_INFORMATION fffff80310e11010 ACPI!ACPIDispatchIrp
[06] IRP_MJ_SET_INFORMATION fffff80310e11010 ACPI!ACPIDispatchIrp
[07] IRP_MJ_QUERY_EA fffff80310e11010 ACPI!ACPIDispatchIrp
[08] IRP_MJ_SET_EA fffff80310e11010 ACPI!ACPIDispatchIrp
[09] IRP_MJ_FLUSH_BUFFERS fffff80310e11010 ACPI!ACPIDispatchIrp
[0a] IRP_MJ_QUERY_VOLUME_INFORMATION fffff80310e11010 ACPI!ACPIDispatchIrp
[0b] IRP_MJ_SET_VOLUME_INFORMATION fffff80310e11010 ACPI!ACPIDispatchIrp
[0c] IRP_MJ_DIRECTORY_CONTROL fffff80310e11010 ACPI!ACPIDispatchIrp
[0d] IRP_MJ_FILE_SYSTEM_CONTROL fffff80310e11010 ACPI!ACPIDispatchIrp
[0e] IRP_MJ_DEVICE_CONTROL fffff80310e11010 ACPI!ACPIDispatchIrp
[0f] IRP_MJ_INTERNAL_DEVICE_CONTROL fffff80310e11010 ACPI!ACPIDispatchIrp
[10] IRP_MJ_SHUTDOWN fffff80310e11010 ACPI!ACPIDispatchIrp
[11] IRP_MJ_LOCK_CONTROL fffff80310e11010 ACPI!ACPIDispatchIrp
[12] IRP_MJ_CLEANUP fffff80310e11010 ACPI!ACPIDispatchIrp
[13] IRP_MJ_CREATE_MAILSLOT fffff80310e11010 ACPI!ACPIDispatchIrp
[14] IRP_MJ_QUERY_SECURITY fffff80310e11010 ACPI!ACPIDispatchIrp
[15] IRP_MJ_SET_SECURITY fffff80310e11010 ACPI!ACPIDispatchIrp
[16] IRP_MJ_POWER fffff80310e11010 ACPI!ACPIDispatchIrp
[17] IRP_MJ_SYSTEM_CONTROL fffff80310e11010 ACPI!ACPIDispatchIrp
[18] IRP_MJ_DEVICE_CHANGE fffff80310e11010 ACPI!ACPIDispatchIrp
[19] IRP_MJ_QUERY_QUOTA fffff80310e11010 ACPI!ACPIDispatchIrp
[1a] IRP_MJ_SET_QUOTA fffff80310e11010 ACPI!ACPIDispatchIrp
[1b] IRP_MJ_PNP fffff80310e11010 ACPI!ACPIDispatchIrp

Fast I/O routines:
FastIoDetachDevice fffff80310e65b50 ACPI!ACPIFilterFastIoDetachCallback

Device Object stacks:

!devstack ffff968bc58cee10 :
!DevObj !DrvObj !DevExt ObjectName
Could not read Type from DeviceObject 0xffff968bc4a342a0

!devstack ffff968bbe69bde0 :
!DevObj !DrvObj !DevExt ObjectName
ffff968bbe6f9700 \Driver\usbccgp ffff968bbe6f9850 InfoMask field not found for _OBJECT_HEADER at ffff968bbe6f96d0

> ffff968bbe69bde0 \Driver\ACPI ffff968bb0506420 InfoMask field not found for _OBJECT_HEADER at ffff968bbe69bdb0

ffff968bbde7bd70 \Driver\USBHUB3 ffff968bb720dda0 InfoMask field not found for _OBJECT_HEADER at ffff968bbde7bd40

!DevNode ffff968bbe651ca0 :
DeviceInst is "USB\VID_046D&PID_C534\7&1e9c88a7&0&3"
ServiceName is "usbccgp"

ffff968bbdf31e00: Could not read device object
Error processing device objects. Processed 2 device objects before error.
There seems to be an USB device (Logitech Unifying Receiver) somehow involved in the crash. Not sure what exactly is that but if it's possible to detach it, might be worth to try..
Thanks. I have a Bluetooth receiver in one of the other USB ports. It's for a Logitech wireless mouse. Tonight I'll try it with that disconnected.
Yes, it seems that Windows always crashes with a DRIVER_POWER_STATE_FAILURE error, as described above, when the following 3 things are true:
  • HWiNFO64 is running and minimized
  • The computer is on USB-PD power
  • The Bluetooth receiver for a Logitech wireless mouse is in one of the USB-A ports
This happens even with EC Support and Evaluate ACPI Methods both disabled. It doesn't happen (or at least not nearly as quickly) if the computer is plugged in with the AC adapter that came with the computer, or if HWiNFO64 is not running, or if the USB receiver is not present. I haven't tried on battery power yet, and I'm not sure if it will still crash if HWiNFO64 is running in the foreground.

EDIT: it happens on battery also.

Thanks for the help.
Last edited:
Try the following:
- Open the HWiNFO64.INI file in some text editor (e.g. Notepad)
- Insert "UsbEnum=0" (without the quotes) at the end of the file
- Restart HWiNFO
Hi, has the problem been solved? To me the bsod happens even only on battery and with no usb device connected
I edited the HWiNFO64.INI file to include UsbEnum=0, but it still the BSOD still happens when on battery power. For me it seems the USB receiver for the Logitech mouse has to be in one of the USB-A ports. I'll try again without it though.
I edited the HWiNFO64.INI file to include UsbEnum=0, but it still the BSOD still happens when on battery power. For me it seems the USB receiver for the Logitech mouse has to be in one of the USB-A ports. I'll try again without it though.
Darn thanks for this post. This is the issue I'm having with a Lenovo Thinkpad Z13. I tried to disable EC support but it still freezes. Will continue to test with the suggestions in this thread.
Hi, I wanted to warn that this problem on my laptop has been solved for a while now, I think after updating the bios to the latest version or maybe it was solved in HWiNFO64 itself. In any case I haven't had any BSoDs since then.
I've performed some testing by additionally disabling Evaluate ACPI Methods and SMBus Support. Still had a freeze. I did not get to test UsbEnum=0 for long because I tried to use TrafficMonitor (lite version) as a replacement for HWinfo64 to monitor only CPU, RAM, and network usage in the taskbar on my Thinkpad Z13. So far no freezes by using TrafficMonitor, but will continue with longer term testing.

I still use Hwinfo64 on my other laptops without any problems at all (Microsoft Surface Laptop Go and a cheap fanless laptop with Intel N5000). I also use Hwinfo64 on all my current desktops (Intel Z690, Intel B360, Intel Ivy Bridge/3rd gen) without any problems.

Hwinfo64 is my greatly preferred resource monitoring software in the Windows 11 taskbar, but TrafficMonitor is only needed for my one Lenovo Thinkpad laptop (all drivers/bios up to date) that has freezing issues with Hwinfo64.