Corsair ax1600i


Well-Known Member
I am not seeing my Corsair ax1600i in the sensor panel.

Under Settings>Safety, the Corsair Link support box is checked.
Separately the Corsair Link 4 reads and shows the PSU info.

I am not sure if I am missing a driver or something else is set incorrectly.

Any help appreciated.
This model is currently not supported. I will try to add support in the next build, but the communication protocol used there is not stable and problematic.
Moreover running the Corsair Link software with any other Corsair monitoring tool can cause problems.
That would be much appreciated.
I do not run the Link software. I would just like to monitor the PSU performance & display with aquasuite.
Please try the new build 3385 Beta.
It should support the AX1600i, but it's quite likely that the communication with the device won't be reliable.
Yep, I can see the ax1500i now:

And as you predicted, some of the values are intermittent.
The value I am currently most interested in, is power into the unit, and how it correlates to coolant temperature.
Fortunately, the "PSU Power in (Est)" value appears the same as the "PSU Power In" values, and is very stable.
Not sure what the difference is, but that works for me.
I also look at the "PSU Efficiency", and that is also appears quite stable.

So I am good to go... thank you.

Here is an updated debug file: [attachment=2734]


  • ax1600i_Sensors.jpg
    162.5 KB · Views: 13
  • HWiNFO64.DBG
    1.3 MB · Views: 2
Thanks for the feedback.
Indeed, the communication shows several errors and that's the reason why several values are not read properly. I'm not sure why is this, it might be the protocol itself not stable, or some other application causing conflicts. Unfortunately Corsair is not helpful with this at all...
Corsair PSUs usually can measure the output power only and using some 'magic' interpolation calculate the input power and efficiency from this (that's the "PSU Power in (Est)" value). But HWiNFO goes further and shows also the measured value of input power from the device.. which seems quite in sync with the 'magical' interpolation ;)
Arggh, I had to reinstall windows 10 on my system and now the ax1600i is no longer listed in the sensor list.
I know I screwed it up somewhere, and I could use a little help if there are any suggestions available.

Debug file:[attachment=2741]

Corsair Link driver is running:


  • HWiNFO64.DBG
    1.8 MB · Views: 1
  • link.jpg
    95.2 KB · Views: 4
HWiNFO cannot access the device.
Not sure why exactly is this, I think there was some problem in the past with USB power management.
Try to run the Corsair Link software once to see if that will fix it.
Ran Link4 and it sees the ax1600i, but HWiNFO still doesn't.
I will try a hard shut down tonight, going so far as to pull the mains plug from the PSU.

Sure wish Corsair was a bit better responding to these issues.
Unfortunately, even after the hard shutdown including unplugging the PSU from the mains, still no ax1600i in sensor panel.
Maybe, hopefully, whatever switched in the system will switch back in the future.
Lucky me.

Last time it was a hardware failure that had me reinstall Windows.
This time Windows just puked on me... said it had to reinstall, and I could keep my data files if I wanted.

Windows finished doing its thing, and I am busy reinstalling all my apps now.

It is said every cloud has a silver lining.
After reinstalling HWiNFO, I am now able to see the Corsair ax1600i again.



  • HWiNFO64.DBG
    2 MB · Views: 3
A final thought on this issue.?

The previous installation I installed Corsair Link 4, because I was working under the impression a "driver" should be installed, but Link NOT running... which was the case.

This time I have not installed the Link software at all and HWiNFO is reading the PSU, for the most part.

I do not know if the results are related or coincidental, but...
The Corsair Link software doesn't play nice with other tools. It either completely blocks others from accessing the device, or can cause several issues when running concurrently.
We're still trying to push them for a solution that would allow using other tools with their software.